Add a Printer Wizard stops responding when you try to install a network printer

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Article ID: 830732 - View products that this article applies to.
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SYMPTOMS

When you try to install a network printer on your Microsoft Windows XP-based computer, the Add a Printer Wizard stops responding.

CAUSE

This problem may occur if the following conditions are true:
  • You have a firewall that separates your Active Directory directory service root domain from a child domain.
  • The network printer exists on the child domain.
  • The Windows XP-based computer exists on the child domain.
  • The port that is used by Lightweight Directory Access Protocol (LDAP) is closed on your firewall.
When the Windows XP client connects to the network printer, an LDAP query is sent to the root domain controller to obtain RootDSE properties. The LDAP query for the printer's properties is sent to the forest root name when you use an "Entire Directory" query to search for printers.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP, 32-Bit Editions
   Date         Time   Version        Size    File name
   --------------------------------------------------------
   11-Aug-2003  23:43  5.2.9354.0     26,112  _sfx_.dll
   16-Oct-2003  19:47                 86,287  _sfx_0000._p
   16-Oct-2003  19:47                 26,899  _sfx_0001._p
   16-Oct-2003  19:47                  1,695  _sfx_0002._p
   16-Oct-2003  19:48                    793  _sfx_0003._p
   16-Oct-2003  19:47                  4,589  _sfx_0004._p
   16-Oct-2003  19:47                    883  _sfx_0005._p
   16-Oct-2003  19:47                  8,871  _sfx_0006._p
   16-Oct-2003  19:47                 86,341  _sfx_0007._p
   16-Oct-2003  19:48                    617  _sfx_manifest_
Windows XP, 64-Bit Editions
   Date         Time   Version        Size     File name     Platform
   ------------------------------------------------------------------
   16-Oct-2003  03:02  5.1.2600.1310  468,992  Dsquery.dll   IA-64
   16-Oct-2003  04:02  5.1.2600.1310  227,840  Wdsquery.dll  x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the Standard Terminology That Is Used to Describe Microsoft Software Updates

Properties

Article ID: 830732 - Last Review: August 29, 2007 - Revision: 3.1
APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbqfe kbfirewall kbprint kbwinxppresp2fix kbfix kbbug KB830732

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