You may see garbled text on the logon page when you connect to a Terminal Services RemoteApp application from the Administration Console for Windows Essential Business Server 2008 Management Server

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Article ID: 970435 - View products that this article applies to.
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SYMPTOMS

When you connect to a Windows Server 2008 Terminal Services RemoteApp (TS RemoteApp) application from the Administration Console for Windows Essential Business Server (Windows EBS) 2008 Management Server, you may see garbled text.

For example, when you start the Microsoft Forefront Threat Management Gateway task from the Security page of the Windows EBS Administration Console, the task connects to a TS RemoteApp application. Then, you may see garbled text on the logon page.

This problem occurs in the following language versions of Windows EBS 2008:
  • Spanish
  • French
  • Japanese
  • Korean
  • Portuguese (Brazil)
  • Russian
  • Chinese (Simplified)
  • Chinese (Traditional, Taiwan)

CAUSE

This problem occurs because the following Remote Desktop Protocol (.rdp) files are created by using UTF-8 encoding instead of Unicode encoding:
  • RemoteExchangeAdminEdge.rdp
  • RemoteExchangeAdminExchange.rdp
  • RemoteForefrontAdminExchange.rdp
  • RemoteIISManagerExchange.rdp
  • RemoteISAAdminEdge.rdp
  • RemoteServerManagerEdge.rdp
  • RemoteServerManagerExchange.rdp
Note These .rdp files are used by various tasks in the Windows EBS Administration Console to connect to the corresponding TS RemoteApp applications. All the .rdp files are in the following location:
%ProgramFiles%\Windows Essential Business Server\Data

WORKAROUND

To work around this problem, follow these steps for each .rdp file that is listed in the "Cause" section.

Note These steps use the RemoteISAAdminEdge.rdp file as an example.
  1. On the Windows EBS 2008 Management Server, use Notepad to open the RemoteISAAdminEdge.rdp file from the following location:
    %ProgramFiles%\Windows Essential Business Server\Data
  2. On the File menu, click Save As.
  3. In the Save As dialog box, click Unicode in the Encoding list, and then click Save to replace the original RemoteISAAdminEdge.rdp file.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 970435 - Last Review: April 22, 2009 - Revision: 1.0
APPLIES TO
  • Windows Essential Business Server 2008 Standard
Keywords: 
kbsurveynew kbexpertiseadvanced kbtshoot kbprb KB970435

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