The Active Directory Application Mode index may become corrupted if you search the instance by using the LDAP virtual list view control

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Article ID: 972622 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • Active Directory Application Mode is installed on a computer that is running Windows Server 2003 Service Pack 2 (SP2).
  • An application or service searches the Active Directory Application Mode instance by using the virtual list view control for the Lightweight Directory Access Protocol (LDAP).
In this scenario, the Active Directory Application Mode instance may become corrupted and the application or service may encounter a search failure. You have to do an offline defragmentation to clear the corrupted index.

When this problem occurs, the following event is logged in the Active Directory Application Mode instance event log:

Event Type: Error
Event Source: ADAM <name> ISAM
Event Category: Database Corruption
Event ID: 467
Date: <date>
Time: <time>
User: N/A
Computer: <computer name>
Description: <name> (1912) ADAMDSA: Index INDEX_S_00000003 of table datatable is corrupted (0).

CAUSE

This problem occurs because the Active Directory Application Mode instance database engine does not manage the index update correctly when a tuple index has more than one key column. This behavior causes index corruption.

RESOLUTION

This hotfix prevents a future occurrence of index corruption. If the Active Directory Application Mode index is corrupted because of this issue, you must first perform an offline defragmentation to resolve the corruption. Then you must install this hotfix to prevent a future occurrence of index corruption.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must be running Windows Server 2003 Service Pack 2 (SP2).

For more information about how to install the Windows Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Server 2003 SP2

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Esent.r2.dll1.1.3790.45631,007,61631-Jul-200916:00x86
For all supported x64-based versions of Windows Server 2003 SP2

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Esent.r2.dll1.1.3790.45632,066,43201-Aug-200905:21x64

WORKAROUND

To work around the issue, perform offline defragmentation on the corrupted Active Directory Application Mode instance. To do this, you can reference the steps in the following Knowledge Base article:

232122 Performing offline defragmentation of the Active Directory database


Note This issue occurs whenever the Active Directory Application Mode instance is corrupted. We recommend that you install this hotfix to resolve the issue completely.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

REFERENCES

For more information about searching by using the LDAP virtual list view control, visit the following Microsoft Web site:
http://msdn.microsoft.com/en-us/library/aa367018(VS.85).aspx
For more information about searching by using the Search-Flags attribute, visit the following Microsoft Web site:
http://msdn.microsoft.com/en-us/library/ms679765(VS.85).aspx

Properties

Article ID: 972622 - Last Review: October 30, 2009 - Revision: 1.0
APPLIES TO
  • Microsoft Windows Server 2003 Service Pack 2, when used with:
    • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
    • Microsoft Windows Server 2003, Datacenter x64 Edition
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Standard x64 Edition
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Keywords: 
kbqfe kbhotfixserver kbsurveynew kbautohotfix kbexpertiseinter kbbug kbfix KB972622

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