Bad IP Address When Using HOSTS or LMHOSTS

Article translations Article translations
Article ID: 139414 - View products that this article applies to.
This article was previously published under Q139414
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

SYMPTOMS

You may receive Bad IP address "name" when trying to ping a NetBIOS or HOST name.

CAUSE

Possible causes include:
  • The LMHOSTS or HOSTS file was saved as a Unicode file.
  • Entry does not exist or is incorrect in LMHOSTS, HOSTS, or Windows Internet Name service (WINS).
  • LMHOSTS lookup is not enabled.

RESOLUTION

  1. Load LMHOSTS or HOSTS file in Notepad and save as a standard text file instead of a Unicode file.
  2. Be sure the entry does exist in LMHOSTS, HOSTS, or is registered with your WINS server. If using static mapping on WINS server be sure the entry it is correct.
  3. Check your settings in Control Panel Network (TCPIP/Advanced) to make sure Enable LMHOSTS Lookup is checked.

Properties

Article ID: 139414 - Last Review: February 21, 2014 - Revision: 2.1
APPLIES TO
  • Microsoft Windows NT Advanced Server 3.1
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 3.1
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Advanced Server 3.1
  • Microsoft TCP/IP for Windows for Workgroups 3.11
Keywords: 
kbnosurvey kbarchive kbnetwork KB139414

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com