Cannot Configure Scheduled Tasks to Use System Account

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Article ID: 223375 - View products that this article applies to.
Notice
This article applies to Windows 2000. Support for Windows 2000 ends on July 13, 2010. The Windows 2000 End-of-Support Solution Center is a starting point for planning your migration strategy from Windows 2000. For more information see the Microsoft Support Lifecycle Policy.
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Symptoms

When you create or modify a task in the Scheduled Tasks tool to use the System account, the task does not run as scheduled.

When you view the Scheduled Tasks log file, you receive the following error message:
The attempt to log on to the account associated with the task failed, therefore, the task did not run.

The specific error is: 0x80070057: The parameter is incorrect. Verify that the task's Run-as name and password are valid and try again.

Cause

This issue occurs because you cannot configure a task to use the System account using the Scheduled Tasks Wizard.

Resolution

Currently, the only way to schedule a task as the System Account is to use AT.EXE to schedule the task. This command is shipped in Windows 2000 for backward compatibility for NT 4.0 scheduled events. Its defaults are to schedule jobs to run as the Task Scheduler service account (System by default).

To access this tool, open a Command Prompt (cmd.exe) and type AT /?. Be aware that after a job is scheduled using AT, manipulation of the task through the Scheduled Tasks folder will permanently change the job and turn it into a Windows 2000 Scheduled Tasks Job object (.JOB files). During this process, you must enter new credentials, and the only way to return the scheduled event to its original state using the system account is to delete and reschedule the event using AT.EXE.

Properties

Article ID: 223375 - Last Review: June 22, 2014 - Revision: 5.0
Applies to
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Keywords: 
kbenv kbprb KB223375

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