The report generation process may stop responding when you run Perfmon.exe with the Active Directory Diagnostics template to generate a report on a Windows Server 2008-based domain controller

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Article ID: 971714 - View products that this article applies to.
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SYMPTOMS

When you run Perfmon.exe with the Active Directory Diagnostics template to generate a report on a Windows Server 2008-based domain controller, the process may stop responding.

CAUSE

This issue occurs because the Reliability and Performance Monitor (Perfmon.exe) console that is running the TraceRpt.exe tool consumes too much memory and CPU resources during the report generation process. If the Windows Server 2008-based server is really busy and lacks resources, the report generation process will stop responding.

RESOLUTION

To resolve this issue, copy your files to a different computer that has same server role and that has enough hardware resources. Then, run TraceRpt.exe with the files. To do this, follow these steps:
  1. In the Reliability and Performance Monitor (Perfmon.exe) console, click Data Collector Sets, and then click System.
  2. Right-click Active Directory Diagnostics, and then click Start. The file collection process starts on the Windows Server 2008-based domain controller.
  3. After the report status changes to generating report from collecting data for <time>, copy the files to the second Windows Server 2008-based domain controller.

    Note You can find the files at the following location:
    %systemdrive%\Perflogs\ADDS\date report generation run\*
  4. Locate the files, and then run the following command at the command line on the second Windows Server 2008-based domain controller:
    tracerpt *.blg *.etl -df your_tmp_filename.tmp -report your_report.html -f html
    
  5. Use Windows Internet Explorer to view the .html file that is generated.

MORE INFORMATION

To review the Performance and Reliability Monitoring Step-by-Step guide for Windows Server 2008, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/library/cc771692.aspx

Properties

Article ID: 971714 - Last Review: June 10, 2009 - Revision: 1.0
APPLIES TO
  • Windows Server 2008 Standard
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 Datacenter without Hyper-V
Keywords: 
kbprb kbexpertiseinter kbtshoot KB971714

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