OFF2000: Windows Installer Appears Every Time a Program Is Started

Article translations Article translations
Article ID: 265194 - View products that this article applies to.
This article was previously published under Q265194
Expand all | Collapse all

On This Page

SYMPTOMS

Each time you start an Office program, a dialog box for Windows Installer appears with the following message:
Preparing to install...
This is followed by another dialog box, with the following message:
Please wait while Windows configures Office Edition
where Office Edition is the edition of Office that you have installed.

CAUSE

These messages may appear if any one (or all) of the following DWORD values in the registry is missing from the HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\LanguageResources key:
UILanguage
HelpLanguage
InstallLanguage

RESOLUTION

To resolve this problem, use each of the following methods in the order they are listed, until you resolve the problem. After you resolve the problem, do not use the remaining methods.

Method 1: Use the Language Version Tool

  1. In your Web browser, visit the following Microsoft Web site:
    http://www.microsoft.com/en-us/download/details.aspx?id=5314
    Save the Orktools.exe program to your desktop when prompted.
  2. Install Orktools.exe by double-clicking it on your desktop.
  3. Click I accept the terms of the License Agreement, and then click Next.
  4. Specify the path for the installation location, and then click Next.
  5. Under the Tools feature, click each of the sub features, except for the Office Language Version sub feature. Change the installation state to Not Available. Leave the Office Language Version sub feature set to the default Run from My Computer installation state.
  6. Click Install Now.
  7. When the installation is finished, point to Programs on the Start menu, point to Microsoft Office Tools, point to Microsoft Office 2000 Resource Kit Tools, and then click Language Version.
  8. Select the language for your version of Office in the Use defaults for list. For example, if you have a U.S. version of Office, click English.
  9. Click OK.

Method 2: Modify the Registry

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
  1. Click Start and then click Run.
  2. In the Open box, type Regedit and then click OK.
  3. Locate and select the following key:
    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common
  4. Select the UserData DWORD value for the above key.
  5. On the Edit menu, click Rename.
  6. Rename the UserData DWORD value to UserDataOld.
  7. Find the following key:
    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common
  8. Find the following value: OSAShortcut. If it does not exist, create it. On the Edit menu, click New and then click Dword. Name the value OSAShortcut, and then set the value to 1.
  9. On the Registry menu, click Exit.
  10. Start any Office program.NOTE: The same Windows Installer dialog boxes appear one more time.

  11. When you are prompted, type your name and initials in the User Name dialog box, and then click OK.

Method 3: Reinstall Microsoft Access

To resolve this problem, rename the Msaccess.exe and System.mdw files, and then reinstall Microsoft Access. To do this, follow the steps for your computer's operating system.

NOTE: By default, the Msaccess.exe file is installed in the "C:\Program Files\Microsoft Office\Office10" folder, and the System.mdw file is installed in the "C:\Program Files\Common Files\SYSTEM" folder.

Microsoft Windows 98 or Microsoft Windows NT 4.0:
  1. Quit all instances of Word, including Microsoft Outlook if Word is selected as your e-mail editor.
  2. Click Start, point to Find, and then click Files or Folders.
  3. In the Named box, type Msaccess.exe.
  4. In the Look in box, select your local hard disk. (If you are running Word from a network server, select an alternate user template location.)
  5. Click Find Now to search for the file.
  6. For each occurrence of the Msaccess.exe file that appears in the Find program, right-click the file. Click Rename on the shortcut menu. Name the file a new name, such as OldMsaccess.exe or Msaccess.exe-1.dot, and then press ENTER.
  7. Repeat steps 3 through 6 to rename the System.mdw file.
  8. On the File menu, click Close to close the Find dialog box.
  9. Click Start, point to Programs, and then click Microsoft Access. If you are prompted for the application CD-ROM, insert the CD-ROM, and then click OK to continue the application Setup.
  10. After Setup finishes, start Microsoft Access.
  11. On the File menu in Microsoft Access, click Exit to quit Microsoft Access, and then start Microsoft Access again.
Microsoft Windows Millennium Edition (Me) or Microsoft Windows 2000:
  1. Quit all instances of Word, including Outlook if Word is selected as your e-mail editor.
  2. Click Start, point to Search, and then click For Files or Folders.
  3. In the Search for files or folders named box, type Msaccess.exe.
  4. In the Look in box, select your local hard disk. (If you are running Word from a network server, select an alternate user template location.)
  5. Click Search Now to search for the file.
  6. For each occurrence of the Msaccess.exe file that appears in the Search Results dialog box, right-click the file. Click Rename on the shortcut menu. Name the file a new name, such as OldMsaccess.exe or Msaccess.exe-1.dot, and then press ENTER.
  7. Repeat steps 3 through 6 to rename the System.mdw file.
  8. On the File menu, click Close to close the Search program.
  9. Click Start, point to Programs, and then click Microsoft Access. If you are prompted for the application CD-ROM, insert the CD-ROM, and then click OK to continue the application Setup.
  10. After Setup finishes, start Microsoft Access.
  11. On the File menu in Microsoft Access, click Exit to quit Microsoft Access, and then start Microsoft Access again.
Microsoft Windows XP:
  1. Quit all instances of Word, including Outlook if Word is selected as your e-mail editor.
  2. Click Start and then click Search.
  3. Under What do you want to search for, click All files and folders.
  4. In the All or part of the file name box, type Msaccess.exe.
  5. In the Look in box, select your local hard disk. (If you are running Word from a network server, select an alternate user template location.)
  6. Click Search to search for the file.
  7. For each occurrence of the Msaccess.exe file that appears in the Search Results dialog box, right-click the file, and then click Rename on the shortcut menu. Name the file a new name, such as OldMsaccess.exe or Msaccess.exe-1.dot, and then press ENTER.
  8. Repeat steps 3 through 7 to rename the System.mdw file.
  9. On the File menu, click Close to close Search Results.
  10. Click Start, point to All Programs, and then click Microsoft Access. If you are prompted for the application CD-ROM, insert the CD-ROM, and then click OK to continue the application Setup.
  11. After Setup finishes, start Microsoft Access.
  12. On the File menu in Microsoft Access, click Exit to quit Microsoft Access, and then start Microsoft Access again.

Properties

Article ID: 265194 - Last Review: May 24, 2012 - Revision: 6.0
APPLIES TO
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft Outlook 2000 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft Publisher 2000 Standard Edition
  • Microsoft Word 2000
Keywords: 
kbbug kbpending KB265194

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com