Windows 98/Me Setup Hangs During Plug and Play Hardware Detection

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Article ID: 194721
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http://support.microsoft.com/default.aspx/w98?sid=460
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Symptoms

When you attempt to install Windows 98 or Windows Millennium Edition (Me), Setup may stop responding (hang) during the Plug and Play hardware detection process. When you restart your computer, Setup may hang at the same point.

Cause

This behavior can occur if the System.ini file contains the "Display.drv=pnp.drv" line.

Resolution

To resolve this behavior, disable the "Display.drv=pnp.drv" line in the System.ini file. To do so, follow these steps:

  1. Restart your computer, press and hold down the CTRL key after your computer completes the Power On Self Test (POST), and then choose Safe Mode from the Startup menu. For more information about Windows 98 startup, see the following article in the Microsoft Knowledge Base: No "Starting Windows 98" Message at Startup
  2. Click Start, point to Programs, point to Accessories, point to System Tools, and then click System Information.
  3. On the Tools menu, click System Configuration Utility.
  4. On the Sytem.ini tab, double-click [Boot].
  5. Click the "Display.drv=pnp.drv" check box to clear it, click OK, and then click Yes when you are prompted to restart your computer.
  6. After Setup is completed, repeat steps 2-5, clicking the "Display.drv=pnp.drv" check box to select it in step 5.
  7. Verify that Normal Startup is selected on the General tab in System Configuration Utility.
  8. Restart the computer when prompted.

More information

Some video adapters, such as Creative Labs PCI 3D video adapters, may replace the "Display.drv=pnpdrvr.drv" line with the "Display.drv=pnp.drv" line. This can prevent Plug and Play hardware detection from working properly.

Properties

Article ID: 194721 - Last Review: June 22, 2014 - Revision: 5.0
Keywords: 
kbnosurvey kbarchive kbhardware kbprb kbsetup KB194721

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