Article ID: 2008303 - Last Review: August 24, 2010 - Revision: 2.0

You have to reinstall some drivers when you install SQL Server 2005

System TipThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.
Expand all | Collapse all

Symptoms

Consider the following scenarios:

Scenario 1:

  • You install an update for third-party software. For example, you install an update for a third-party printer driver.
  • You install Microsoft SQL Server 2005 after you install the update.
  • After you complete both installations, you restart the computer.

In this scenario, the third-party software does not function correctly.

Scenario 2:

 

You install Microsoft Office 2010 suite including OneNote on a Windows 7 machine and you do not restart the computer after installation.

Immediately after installing Microsoft Office 2010, you install Microsoft SQL Server 2005 Express.

  In this scenario, you are not able to print using the XPS printer driver. Additionally, you are no longer able to send items to OneNote using the Send to OneNote 2010 printer driver.

 

Cause

This problem occurs because the SQL Server Setup program deletes some files that are installed by the update. This issue occurs when you install SQL Server 2005 after you install the driver update and you do not restart the computer between the two installations.

Status: Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Resolution

Scenario 1:

After you install SQL Server 2005, uninstall the third-party software update by using Add or Remove Programs in Control Panel. Then, reinstall the third-party software update by using the package that the program vendor provides.

To prevent this problem on other computers in your environment, restart computers after you install the third-party software updates and before you install SQL Server 2005.

Scenario 2:

 

After you install Microsoft Office 2010, restart the machine before installing SQL Server 2005 Express.  

You may also be able to resolve the issue by repairing Office. To repair Office, follow these steps: 

Note Repairing Office 2010 does not resolve the issue if the version of Office is 64-bit.

Run the Detect and Repair tool from Add or Remove Programs

1.

Click Start , and then click Control Panel .

2.

If you are running Microsoft Windows Vista or Microsoft Windows 7, do the following:

a.

Click Programs , and then click Uninstall a Program .

b.

Click the name of the Microsoft Office Edition 2010 you want to change, and then click Change

c.

Click Repair , and then click Continue .

 

Note   In Classic view on Windows Vista or in Icon View on Windows 7, double-click Programs and Features . Click the name of the Microsoft Office Edition 2010 you want to change, and then click Change . Click Repair , and then click Continue .

If you are running Microsoft Windows XP, do the following:

a.

Click Add or Remove Programs .

b.

Click the name of the Microsoft Office Edition 2010 you want to change, and then click Change .

c.

Click Repair , and then click Continue .

Note In Classic view, double-click Add or Remove Programs , click the name of the Microsoft Office Edition 2010 you want to change, and then click Change . Click Repair , and then click Continue .

 

 

More Information

Consider the following scenario that involves a third-party software update for a printer driver:

  1. You install an update for a third-party printer driver.
  2. The update installation requires you to restart the computer for the changes to take effect.
  3. You decide to restart the computer later.
  4. You install any edition of SQL Server on the same computer.
  5. The SQL Server Setup program deletes some files that were installed as part of the update.
  6. You try to print.

In this scenario, you cannot print because the printer driver files no longer exist.

Note Microsoft is aware that this problem affects updates for some Canon printer drivers.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use (http://go.microsoft.com/fwlink/?LinkId=151500) for other considerations.

APPLIES TO
  • Microsoft SQL Server 2005 Developer Edition
  • Microsoft SQL Server 2005 Enterprise Edition
  • Microsoft SQL Server 2005 Enterprise Edition for Itanium-based Systems
  • Microsoft SQL Server 2005 Enterprise X64 Edition
  • Microsoft SQL Server 2005 Evaluation Edition
  • Microsoft SQL Server 2005 Express Edition
  • Microsoft SQL Server 2005 Express Edition with Advanced Services
  • Microsoft SQL Server 2005 Standard Edition
  • Microsoft SQL Server 2005 Standard X64 Edition
  • Microsoft SQL Server 2005 Workgroup Edition
Keywords: 
KB2008303