Article ID: 825576 - View products that this article applies to.
Expand all | Collapse all

On This Page

SUMMARY

This article describes various methods that you can use to minimize the metadata in your Word documents.

When you create, open, or save a document in Microsoft Office Word 2003, the document may contain content that you may not want to share with others when you distribute the document electronically. This information is known as metadata. Metadata is used for a variety of purposes to enhance the editing, viewing, filing, and retrieval of Office documents.

Some metadata is easily accessible through the Word user interface. Other metadata is only accessible through extraordinary means, such as by opening a document in a low-level binary file editor. The following are some examples of metadata that may be stored in your documents:
  • Your name
  • Your initials
  • Your company or organization name
  • The name of your computer
  • The name of the network server or hard disk where you saved the document
  • Other file properties and summary information
  • Non-visible portions of embedded OLE objects
  • Document revisions
  • Document versions
  • Template information
  • Hidden text
  • Comments
Metadata is created in a variety of ways in Word documents. As a result, there is no single method to remove all such content from your documents. The following sections describe areas where metadata may be saved in Word documents.

This article describes various methods that you can use to minimize the metadata in your Word documents.

Microsoft provides programming examples for illustration only, without warranty either expressed or implied. This includes, but is not limited to, the implied warranties of merchantability or fitness for a particular purpose. This article assumes that you are familiar with the programming language that is being demonstrated and with the tools that are used to create and to debug procedures. Microsoft support engineers can help explain the functionality of a particular procedure, but they will not modify these examples to provide added functionality or construct procedures to meet your specific requirements. For more information about how to use the sample code in this article, click the following article number to view the article in the Microsoft Knowledge Base:
290140 How to run sample code for the Office XP programs from Knowledge Base articles

How to Automatically Remove Personal Information When You Save

You can now automatically remove personal information from a Word document when you save the document. To turn this option on, follow these steps:
  1. On the Tools menu, click Options.
  2. On the Security tab, click to select the Remove personal information from file properties on save check box under Privacy options, and then click OK.
Note This is the preferred method of removing personal information when you save a Word document.

How to Manually Remove Your User Name from Your Documents

To view or change your user name, follow these steps:
  1. On the Tools menu, click Options, and then click the User Information tab.

    The following edit boxes appear:
    Name
    Initials
    Mailing Address
  2. If you do not want any of this information to appear in your documents, enter non-identifying strings or spaces in the appropriate edit boxes, and then click OK to accept the changes.
Note Any new documents that you create will contain this information instead of the default values that are entered when you installed Office. However, existing documents may already contain this information.

How to Manually Remove Personal Summary Information

When you create or save a document in Word, summary information may be saved in the document. There are several methods that you can use to access this information:
  • Open the document. On the File menu, click Properties. The Summary, Statistics, Contents, and Custom tabs may all contain various properties such as your name, your manager's name, and your company name.
  • In Microsoft Windows Explorer, right-click the document, and then click Properties. The tabs in the Properties dialog box may contain information.
  • You can use a Microsoft Visual Basic for Applications (VBA) macro or other program code to read the properties shown in the Properties dialog box.
To clear summary information from an existing document or template, follow these steps:
  1. Open the document or template.
  2. On the File menu, click Properties.
  3. On the Summary tab, click to clear the Author, Manager, Company, and any other edit boxes that you do not want to distribute.
  4. On the Custom tab, delete any properties that contain information that you do not want to distribute.
  5. Click OK.

    On the File menu, click Save, and then click Close.
After you complete these steps, the document will not contain summary properties.

How to Manually Remove Personal Summary Information When Connected to a Network

If you are logged on to a network, your network user name may appear in the Author box on the Summary tab and in the Last saved by field on the Statistics tab when you save a document. This issue may occur even if you have removed all other personal information from your computer.

To remove summary information from a document when you are on a network, follow these steps:
  1. If the document is stored on a network server, copy it to your local hard disk.
  2. Start your computer, but do not log on to your network. When you see the network logon dialog box, click Cancel or press ESCAPE.

    Note If you cannot start Windows by pressing ESCAPE (for example, your computer is running Microsoft Windows NT), you cannot continue these steps.
  3. Open the document.
  4. On the File menu, click Properties.
  5. On the Summary tab, click to clear the Author, Manager, Company, and any other edit boxes that contain information that you do not want to distribute.
  6. On the Custom tab, delete any properties that contain information that you do not want to distribute.
  7. Click OK.

    On the File menu, click Save, and then click Close.
When you log on to the network, do not open the file. If you do, your network user name may be written in the file. However, you can use Windows Explorer to copy the file to either a network server or a floppy disk.

How to Manually Remove Comments in Documents

Word offers the ability to add comments to documents. Typically, comments contain the name of the person who created them so that you can tell who wrote them.

Comments typically appear as a highlighted section of text; you can right-click the comment, and then click Delete Comment.

Any new comments that you create will not contain your user name because you have removed it from your Options dialog box as described in the "How to Manually Remove Your User Name from Your Documents" section of this article.

How to Manually Remove Headers and Footers from Documents

Headers and footers in documents may contain identifying information. To remove information from headers and footers, follow these steps:
  1. On the View menu, click Header and Footer.
  2. The header and footer appear at the top and bottom of each page in your document.

    Change them as you want.
  3. Click Close on the Header and Footer toolbar.

How to Manually Remove Revision Marks

Documents can contain revision marks. With revision marks you can determine who makes specific changes to a document. When you accept or reject revision marks, the revised text is saved in the document and the revision marks are removed.

To accept or reject revisions, follow these steps:
  1. On the Tools menu, click Track Changes to enable it.
  2. On the Reviewing toolbar, click Previous or Next to locate and select specific revisions. Then, click Accept Change or Reject Change/Delete Comment to accept or reject the revision that is selected.
  3. When you are finished, click Close.
Note If you change the "Show" settings on the Reviewing toolbar, revision information is not removed.

How to Turn Off Fast Saves

The Fast Saves feature speeds up the process of saving a document by saving only the changes that are made to a document.

Because of the design of the Fast Saves feature, text that you delete from a document may remain in the document even after you save the document. If you are concerned about deleted text remaining in your documents, follow these steps:
  1. On the Tools menu, click Options.
  2. Select the Save tab.
  3. Click to clear the Allow fast saves check box, and then click OK.
For more information about the Fast Saves feature, click the following article number to view the article in the Microsoft Knowledge Base:
291181 Frequently asked questions about "Allow Fast Saves" in Word 2002

How to Search for and Remove Text That Is Formatted As Hidden

In Word documents, you can format text as hidden. Because hidden text can contain information that you may not want to distribute, you may want to unhide and remove it. To remove all the text in a document that is formatted as hidden, follow these steps:
  1. On the Tools menu, click Options, and then click the View tab.
  2. Click to select the Hidden text check box, and then click OK.
  3. On the Edit menu, click Replace.
  4. Click More to expand the dialog box.
  5. Click anywhere in the box next to Find what.
  6. Click the Format button, and then click Font.

    Click to select the Hidden check box, and then click OK.
  7. Click Replace All.
All hidden text is removed from the document. To turn off the display of hidden text, follow these steps:
  1. On the Tools menu, click Options, and then click the View tab.
  2. Click to clear the Hidden text check box, and then click OK.

How to Remove Hyperlinks from Documents

Documents may contain hyperlinks to other documents or Web pages on an intranet or the Internet. Hyperlinks typically appear as blue underlined text strings.

To manually delete a single hyperlink from a document, right-click the hyperlink, point to Hyperlink, and then click Remove Hyperlink.

If you want to delete all the hyperlinks in a document, you can use a VBA macro to do this. The following sample VBA macro removes all hyperlinks in a document.

Note In the following sample macro, only the link is removed. The text of the hyperlink remains in the document.

Important Before you use the following macro example, review the Disclaimer earlier in this article.
	Sub RemoveHyperlinks()
	
	   Dim oDoc As Document
	   Dim oStory As Range
	   Dim oHlink As Hyperlink
	
	   For Each oStory In ActiveDocument.StoryRanges
	      For Each oHlink In oStory.Hyperlinks
	         oHlink.Delete
	      Next
	   Next
	
	End Sub
To remove all traces of both the hyperlink and the text of the hyperlink from the document, you can use the following sample macro instead.
	Sub RemoveAllHyperlinks()
	
	   Dim oDoc As Document
	   Dim oStory As Range
	   Dim oHlink As Hyperlink
	
	   For Each oStory In ActiveDocument.StoryRanges
	      For Each oHlink In oStory.Hyperlinks
	         oHlink.Range.Delete
	      Next
	   Next
	
	End Sub

How to Remove Styles from Documents

Documents may include styles that contain metadata. You can remove these styles or rename them. To do this, follow these steps:
  1. Open the document that contains the styles.
  2. On the Format menu, click Style.
  3. Select the style that you want to delete or rename.

    Click Delete to delete the style, or click Modify to rename it.

How to Remove Old File Versions from Documents

Word includes a file version feature that permits you to save multiple versions of the same document in the same file. You may want to delete older versions of the document before you share it with others.

To delete one or more versions of a document, follow these steps:
  1. On the File menu, click Versions.
  2. Select the version of the document that you want to delete.

    You can select more than one version by pressing CTRL while you select the versions.
  3. Click Delete.
  4. When you are finished deleting old versions of the document, click Save on the File menu.

How to Remove Links from Field Codes

Linked images and other objects in Word documents may contain linking information, such as the path of the linked image or object. You can remove linking information from your document by editing the field codes.

To display field codes, follow these steps:
  1. On the Tools menu, click Options, and then click the View tab.
  2. Click to select the Field codes check box, and then click OK.
After field codes are visible, you can check to see if any of them contain identifying information.

To remove the linking information from a linked image or other object, follow these steps:
  1. Select the linked image or object, or select the field code for the image or object if field codes are visible.
  2. Press CTRL+SHIFT+F9.
The image or object is now unlinked. When an image or object is unlinked, you cannot edit it.

How to Remove the Template Name and Location

All documents that are created in Word are based on a template. By default, this is the Normal.dot template file, located in the Templates folder. However, you can create a document that is based on a different template in another location. The path and name of this template are stored in the properties of the document.

To view the template name and location, click Properties on the File menu, and then click the Summary tab.

Even if you do not send the template with the document, the document retains the name and location of the template. To change the template name and location to non-identifying values, follow these steps:
  1. On the Tools menu, click Templates and Add-Ins.
  2. Click Attach.
  3. Select a template that has a name and location that are not sensitive or unique.

    For example, because every computer that has Word installed includes Normal.dot, you may want to select Normal.dot.
  4. Click Open, and then click OK.
Note The template may contain macros, autotext entries, custom styles, and custom toolbars. By changing templates, you may make some of these items unavailable to your document.

How to Remove Routing Slip Information

If you send a document through e-mail by using a routing slip, routing information may be attached to the document. To remove this information from the document, you must save the document in a format that does not retain routing slip information.

In Word, save your document in either Rich Text Format (RTF) or HTML format. Close the document, and then reopen the new file. Because the routing slip information is no longer present, you can now save your document in the Word format.

You can also follow these steps:
  1. Turn off Allow fast saves by using the instructions earlier in this article.
  2. On the File menu, point to Send to, and then click Other Routing Recipient.
  3. Click Clear to remove the routing slip, and then click OK.
  4. On the File menu, click Save.
The document is now saved without any routing slip information.

How to Remove Your Name from Visual Basic Code

Important Before you use the following macro example, review the Disclaimer earlier in this article.

When you record a VBA macro in Word, the recorded macro begins with a header that is similar to the following:
	' Macro1 Macro
	' Macro recorded 3/11/1999 by <User Name>
To remove your name from any macros that you have recorded, follow these steps:
  1. Open the document that contains the macros.
  2. On the Tools menu, point to Macro, and then click Visual Basic Editor. Or press ALT+F11.
  3. In the project window, double-click the module that contains the macros.
  4. Remove your name from the recorded macro code.
When you are finished removing your name, press ALT+Q to return to the program, and then click Save on the File menu.

How to Remove Visual Basic References to Other Files

In the Visual Basic Editor, you can create a reference to another file. If a user opens a document that contains references to other files, the user can see the names of the referenced files.

To remove these references, follow these steps:
  1. Open the document that contains references.
  2. On the Tools menu, point to Macro, and then click Visual Basic Editor or press ALT+F11.
  3. On the Tools menu, click References.
  4. Click to clear the check box next to the referenced file or files.

    When you are finished, click OK.
  5. Press ALT+Q.
  6. On the File menu, click Save.
Note If you remove references to other files, this may adversely affect the ability of macros in your document to function correctly.

How to Remove Network or Hard Disk Information

When you save a document to your local hard disk or to a network server, information that identifies the local hard disk or network server may be written in the document.

To remove this information from the document, follow these steps:
  1. Open the document.
  2. On the File menu, click Save As.

    Save the document to your floppy disk drive (generally drive A).
  3. On the File menu, click Close.
  4. Remove the floppy disk from your floppy disk drive.
You can now use Windows Explorer to copy the document from the floppy disk to any hard disk or network server.

Note Because of the space limitation of a floppy disk (generally 1.44 megabytes [MB]), this method cannot be used if the document file size exceeds the free space on the floppy disk.

Embedded Objects in Documents May Contain Metadata

If you embed an object in a document, the object still retains its own properties, regardless of what you do to the document. For example, if you embed a Microsoft Excel workbook in a Word document, the document and the workbook each has its own properties.

To remove metadata from an embedded object, activate the object, remove any metadata as described in the earlier sections, reactivate the container document, and then save the container document.

Note When you activate an embedded object in a document, only part of the embedded object is displayed in the document; the object may contain additional information that does not appear. If you want a document to contain only a rendering of the embedded object and not the actual contents, use the Cut command on the Edit menu to delete the object, and then use the Paste Special command to paste the object into the document by using a Metafile format. After you do this, you can no longer edit the embedded object; however it will not contain any metadata.

Document Variables May Contain Metadata

Important Before you use the following sample macro, review the Disclaimer earlier in this article.

To delete the document variables that are contained in your Word document, use the following sample macro:
	Sub DeleteDocVars()
	
	   Dim Response
	   Dim myVar As Variable
	
	   For Each myVar In ActiveDocument.Variables
	      Response = MsgBox("The document variable: " & myVar.Name & vbCr & _
	         "Value: " & myVar.Value & vbCr & vbCr & _
	         "Do you want to delete the variable from this document?", vbYesNo)
	            
	      If Response = "6" Then
	         ' Delete the variable.
	         myVar.Delete
	      Else
	         End
	      End If
	   Next myVar
	            
	   MsgBox "There are no variables in the document."
	   
	End Sub
For more information about variables, in the Visual Basic Editor, click Microsoft Visual Basic Help on the Help menu, type Variables Property in the Office Assistant or the Answer Wizard, and then click Search to view the topic.

General Suggestions About Security

Here are some general suggestions that you can use to help increase the level of security in your computing environment:
  • Whenever you are not at your computer, help to secure it by using a password-protected screen saver, power-on password, or the Windows NT lock feature.
  • If your computer has any shared folders, make sure that you apply passwords to them so that only authorized users can access your shares. For even more security, use user-level access control so that you can control exactly who can access your computer's shares.
  • When you delete a file, empty the Recycle Bin immediately. You may want to consider a utility that completely erases or overwrites files when they are deleted.
  • When you back up your data, store the backups in a secure location, such as a safe, a security deposit box, or a locked cabinet.
  • Make sure that important documents are password-protected so that only authorized users can open them. Store your passwords in a secure, separate location. If you cannot recall a password, there is no way to recover the contents of a password-protected document.
  • Do not distribute documents in electronic form. Instead, print them out. Do not use identifying elements such as distinctive fonts, watermarks, logos, or special paper, unless you have to (for example, for a presentation).
  • E-mail is not anonymous. Do not e-mail a document if you are concerned about your identity being attached in any way to the document.
  • Do not send a document over the Internet by using either the HTTP or File Transfer Protocol (FTP) protocol. Information sent across these protocols is sent in "clear text," this means that it is technically possible (however unlikely) for it to be intercepted.

Properties

Article ID: 825576 - Last Review: July 27, 2006 - Revision: 5.4
APPLIES TO
  • Microsoft Office Word 2003
Keywords: 
kbregistry kbhowtomaster KB825576

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com