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This article applies to Microsoft Dynamics AX for all regions.

Symptoms

Consider the following scenario in Microsoft Dynamics AX 2012:

  • You create a sales agreement that links to a project.

  • You create a purchase agreement that links to the project.

  • You create a sales order that releases the sales agreement.

  • You create a purchase order from the sales order. Additionally, you select the Search for purchase agreements check box and set the vendor account as same as that in the purchase agreement.

In this scenario, the purchase order is not associated to the purchase agreement as expected.

Cause

This problem occurs because the getAgreementLinesForOrderLine method in the AgreementLine table does not select the record for AgreementLineQuantityCommitment table.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. There is a "Hotfix download available" section at the top of this Knowledge Base article. If you are encountering an issue downloading, installing this hotfix, or have other technical support questions, contact your partner or, if enrolled in a support plan directly with Microsoft, you can contact technical support for Microsoft Dynamics and create a new support request. To do this, visit the following Microsoft website:

https://mbs.microsoft.com/support/newstart.aspx You can also contact technical support for Microsoft Dynamics by phone using these links for country specific phone numbers. To do this, visit one of the following Microsoft websites:

Partners

https://mbs.microsoft.com/partnersource/support/Customers

https://mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htmIn special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to any additional support questions and issues that do not qualify for the specific update in question.

Installation information

If you have customizations for one or more of the methods or the tables that are affected by this hotfix, you must follow these steps:

  1. Review the changes that are documented in the .xpo file.

  2. Apply these changes in a test environment before you apply the hotfix in a production environment.



For more information about how to install this hotfix, click the following article number to view the article in the Microsoft Knowledge Base:

893082 How to install a Microsoft Dynamics AX hotfix

Prerequisites

You must have Microsoft Dynamics AX 2012 installed to apply this hotfix.

Restart requirement

You must restart the Application Object Server (AOS) service after you apply the hotfix.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

File name

File version

File size

Date

Time

Platform

Aximpactanalysis.exe

Not applicable

60,280

04-Nov-2011

16:41

x86

Axupdate.exe

Not applicable

60,264

04-Nov-2011

16:41

x86

Dynamicsax2012-kb2661924-foundation.axmodel

6.0.947.811

96,680

05-Jan-2012

00:34

Not applicable

Dynamicsax2012-kb2661924-syplabels.axmodel

6.0.947.811

661,416

05-Jan-2012

00:34

Not applicable

Axsetupsp.exe

6.0.947.513

1,337,192

11-Nov-2011

05:07

x86

Axutillib.dll

6.0.947.0

817,512

10-Jul-2011

09:27

x86

Microsoft.dynamics.servicing.operations.dll

6.0.888.436

35,752

09-Jun-2011

05:42

x86

Axsetupsp.resources.dll

6.0.947.491

382,848

04-Nov-2011

16:41

x86

Axsetupsp.resources.dll

6.0.947.491

370,560

04-Nov-2011

16:41

x86

Axsetupsp.resources.dll

6.0.947.491

374,656

04-Nov-2011

16:41

x86

Axsetupsp.resources.dll

6.0.947.491

374,656

04-Nov-2011

16:41

x86

Axsetupsp.resources.dll

6.0.947.491

370,560

04-Nov-2011

16:41

x86

Axsetupsp.resources.dll

6.0.947.491

378,752

04-Nov-2011

16:41

x86

Axsetupsp.resources.dll

6.0.947.491

370,560

04-Nov-2011

16:41

x86

Axsetupsp.resources.dll

6.0.947.491

374,656

04-Nov-2011

16:41

x86

Axsetupsp.resources.dll

6.0.947.491

370,560

04-Nov-2011

16:41

x86

Axsetupsp.resources.dll

6.0.947.491

374,656

04-Nov-2011

16:41

x86

Axsetupsp.resources.dll

6.0.947.491

370,560

04-Nov-2011

16:41

x86

Axsetupsp.resources.dll

6.0.947.491

407,424

04-Nov-2011

16:41

x86

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

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