Failed to find Windows Identity Foundation setup package error when installing Report Authoring Extension

This article provides a resolution for the Microsoft Dynamics CRM Report Authoring Extension Setup Failed to find Windows Identity Foundation setup package error that occurs when installing the Report Authoring Extension for Microsoft Dynamics CRM 2011 on Windows 8.

Applies to:   Microsoft Dynamics CRM 2011
Original KB number:   2745961

Symptoms

When attempting to install the Microsoft Dynamics CRM 2011 Report Authoring Extension on a Windows 8 machine, users may receive the error message below:

Microsoft Dynamics CRM Report Authoring Extension Setup Failed to find Windows Identity Foundation setup package. For additional details see log file C:\Users\<user>\AppData\Roaming\Microsoft\MSCRM\Logs\BIDSExtensionsSetup.log.

Cause

The Windows Identity Foundation 3.5 feature component is not active on the Operating System.

Resolution

Enable Windows Identity Foundation 3.5:

  1. In the Start menu, right-click and then select All Apps.
  2. Under the Windows System group, select Control Panel.
  3. Select Programs, and then select Programs and Features.
  4. In the left menu, select Turn Windows features on or off.
  5. Scroll through the list until Windows Identity Foundation 3.5 is found.

More information

In Windows 7 systems, the Microsoft Dynamics CRM 2011 setup program will detect if the Windows Identity Foundation update is installed on the system. If the update is not present, the setup program will automatically install the update during installation. However, if this update is removed after installation, the configuration process will fail with the same error mentioned in this article.

Windows 8 includes Windows Identity Foundation 3.5 out of the box, but is disabled by default.