Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Consider the following scenario:

  • You have an environment that has Update Rollup 4 for Microsoft Exchange Server 2010 Service Pack 2 (SP2) or a later update rollup that is earlier than Update Rollup 6 installed.

  • You send an email message that contains an attached Open Office XML document (for example, a .pptx or .docx document) that is missing a file name extension.

In this scenario, the Microsoft Full-Text Engine Filter Daemon (Msftefd.exe) process crashes. Additionally, the following events are logged on the Mailbox server:

Cause

This issue occurs because the incorrect file name extension causes a crash when the Exchange search engine indexes the email message.

Resolution

To resolve this issue, install the following update rollup:

2746164 Description of Update Rollup 6 for Exchange Server 2010 Service Pack 2

Workaround

To work around this issue, follow these steps:

  1. Click Start, click Run, type regedit in the Open box, and then click OK.

  2. Locate and then select the following registry subkey:

    HKEY_LOCAL_MACHINE\Software\Microsoft\ExchangeServer\v14\ExSearch

  3. On the Edit menu, point to New, and then click DWORD (32-bit) Value.

  4. Type NeverOverrideAttachmentExtension, and then press Enter.

  5. In the Details pane, right-click NeverOverrideAttachmentExtension, and then click Modify.

  6. In the Value data box, type 1, and then click OK.

  7. Exit Registry Editor.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about the Msftefd.exe process, go to the following website:

General information about the Msftefd.exe processFor more information, click the following article number to view the article in the Microsoft Knowledge Base:

2713339 Multi-Mailbox Search feature returns incorrect results when you perform a complex discovery search in an Exchange Server 2010 environment

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×