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Symptoms

Consider the following scenario:

  • You install the Remote Desktop Session Host role service on a computer that is running Windows Server 2008 R2.

  • You publish a RemoteApp application on the computer. For example, you configure Notepad.exe as the RemoteApp application.

  • On a Windows 7-based or Windows 8-based client, you set the screen resolution to 1366 x 768.

  • You start the RemoteApp application from the client.

  • You maximize the RemoteApp application when it is started.


In this scenario, the taskbar is hidden because the RemoteApp application window consumes the whole desktop instead of the actual work area.

Cause

This problem occurs because there is a resolution mismatch between the client-side and server-side work areas.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 Service Pack 1 (SP1). For information about how to obtain a Windows Server 2008 R2 service pack, see Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2008 R2 file information notesImportant Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    Version

    Product

    SR_Level

    Service branch

    6.1.760
    1.
    22xxx

    Windows Server 2008 R2

    SP1

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Wksprt.exe

6.1.7601.22298

249,344

13-Apr-2013

04:11

x64

Mstsc.exe

6.1.7601.22298

1,119,232

13-Apr-2013

04:11

x64

Mstsc.mof

Not applicable

1,199

12-Nov-2010

23:42

Not applicable

Aaclient.dll

6.1.7601.22298

158,720

13-Apr-2013

05:18

x64

Aaclient.mof

Not applicable

1,261

10-Jun-2009

20:31

Not applicable

Mstscax.dll

6.1.7601.22298

3,718,656

13-Apr-2013

05:22

x64

Mstscax.mof

Not applicable

2,054

10-Jun-2009

20:34

Not applicable

Tsgqec.dll

6.1.7601.22298

44,032

13-Apr-2013

05:24

x64

For all supported IA-64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Wksprt.exe

6.1.7601.22298

456,704

13-Apr-2013

03:48

IA-64

Mstsc.exe

6.1.7601.22298

1,702,912

13-Apr-2013

03:48

IA-64

Mstsc.mof

Not applicable

1,199

12-Nov-2010

23:42

Not applicable

Aaclient.dll

6.1.7601.22298

339,968

13-Apr-2013

04:33

IA-64

Aaclient.mof

Not applicable

1,261

10-Jun-2009

20:36

Not applicable

Mstscax.dll

6.1.7601.22298

6,309,376

13-Apr-2013

04:36

IA-64

Mstscax.mof

Not applicable

2,054

10-Jun-2009

20:38

Not applicable

Tsgqec.dll

6.1.7601.22298

97,792

13-Apr-2013

04:39

IA-64


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

See Description of the standard terminology that is used to describe Microsoft software updates.

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2

File name

Amd64_microsoft-windows-t..es-workspaceruntime_31bf3856ad364e35_6.1.7601.22298_none_84c2405f0d3ccd64.manifest

File version

Not applicable

File size

10,551

Date (UTC)

13-Apr-2013

Time (UTC)

05:53

Platform

Not applicable

File name

Amd64_microsoft-windows-t..minalservicesclient_31bf3856ad364e35_6.1.7601.22298_none_ac395337511223f2.manifest

File version

Not applicable

File size

21,624

Date (UTC)

13-Apr-2013

Time (UTC)

05:55

Platform

Not applicable

File name

Amd64_microsoft-windows-t..s-clientactivexcore_31bf3856ad364e35_6.1.7601.22298_none_8e4b0d5ef5a2ca71.manifest

File version

Not applicable

File size

131,895

Date (UTC)

13-Apr-2013

Time (UTC)

05:57

Platform

Not applicable

File name

Wow64_microsoft-windows-t..minalservicesclient_31bf3856ad364e35_6.1.7601.22298_none_b68dfd898572e5ed.manifest

File version

Not applicable

File size

13,023

Date (UTC)

13-Apr-2013

Time (UTC)

05:13

Platform

Not applicable

Additional files for all supported IA-64-based versions of Windows Server 2008 R2

File name

Ia64_microsoft-windows-t..es-workspaceruntime_31bf3856ad364e35_6.1.7601.22298_none_28a548d154dd652a.manifest

File version

Not applicable

File size

10,549

Date (UTC)

13-Apr-2013

Time (UTC)

05:16

Platform

Not applicable

File name

Ia64_microsoft-windows-t..minalservicesclient_31bf3856ad364e35_6.1.7601.22298_none_501c5ba998b2bbb8.manifest

File version

Not applicable

File size

21,621

Date (UTC)

13-Apr-2013

Time (UTC)

05:18

Platform

Not applicable

File name

Ia64_microsoft-windows-t..s-clientactivexcore_31bf3856ad364e35_6.1.7601.22298_none_322e15d13d436237.manifest

File version

Not applicable

File size

131,892

Date (UTC)

13-Apr-2013

Time (UTC)

05:18

Platform

Not applicable

File name

Wow64_microsoft-windows-t..minalservicesclient_31bf3856ad364e35_6.1.7601.22298_none_b68dfd898572e5ed.manifest

File version

Not applicable

File size

13,023

Date (UTC)

13-Apr-2013

Time (UTC)

05:13

Platform

Not applicable


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