Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

When you insert a CD or a DVD, Windows Vista may not recognize the disc. If you double-click the disc drive in Windows Explorer after you insert the disc, you receive the following error message:

Insert disk
Please insert a disk into Drive (DriveLetter:).

This problem occurs if the following conditions are true:

  • An audio device is disabled.

  • Windows Media Player is already running when you insert the disc.

Cause

This problem occurs because of an error in the Mcicda.dll file.

Workaround

To work around this problem, exit Windows Media Player before you insert the disc. Or, if the audio device is not enabled, use the Sound item in Control Panel to enable the audio device. To enable the audio device, follow these steps:

  1. Click Start, click Control Panel, and then double-click Sound.

  2. On the Playback tab, right-click in the blank area under Select a playback device below to modify its settings, and then select Show Disabled Devices.

  3. Right-click an audio device, and then click Enable.

References

For more information about automatically diagnose and repair problems with your CD or DVD drive when trying to read or burn media, visit the following Microsoft Website:

Your CD or DVD drive can't read or write mediaFor more information about troubleshooting CD or a DVD recognizing issue, visit the following Microsoft Knowledge Base:

929461 The CD drive or the DVD drive does not work as expected on a computer that you upgraded to Windows Vista

314060 Your CD drive or DVD drive is missing or is not recognized by Windows or other programs

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×