Plug and Play Manager deja de funcionar al reactivar un equipo desde el modo de suspensión en Windows

Se aplica a
Windows 7 Service Pack 1 Windows 7 Enterprise Windows 7 Home Basic Windows 7 Home Premium Windows 7 Professional Windows 7 Ultimate Windows 7 Starter Windows Server 2008 R2 Service Pack 1 Windows Server 2008 R2 Datacenter Windows Server 2008 R2 Enterprise Windows Server 2008 R2 for Itanium-Based Systems Windows Server 2008 R2 Foundation Windows Server 2008 R2 Standard Windows Server 2008 R2 Web Edition Windows 8 Windows 8 Pro Windows 8 Enterprise Windows Server 2012 Datacenter Windows Server 2012 Datacenter Windows Server 2012 Essentials Windows Server 2012 Standard Windows Server 2012 Standard Windows Server 2012 Foundation Windows Server 2012 Foundation

Síntomas

Tenga en cuenta el siguiente escenario:

  • Reinicia un equipo con Windows 7 Service Pack 1 (SP1), Windows Server 2008 R2 SP1, Windows 8 o Windows Server 2012.
  • Pones el equipo en modo de suspensión.
  • Despiertas el ordenador.

En este escenario, Plug and Play Manager puede dejar de funcionar. Además, si conectas un dispositivo USB o una tarjeta Secure Digital (SD), el dispositivo USB o la tarjeta SD no aparece en el administrador de dispositivos ni en la sección "Dispositivos con almacenamiento extraíble" de Mi PC.

Causa

Este problema se produce porque Portcls.sys controla incorrectamente el error de los controladores de audio.

Resolución

Información de la actualización

Para resolver estos problemas, instale el paquete acumulativo de actualizaciones 2889784. Para obtener más información sobre cómo obtener este paquete acumulativo de actualizaciones, haga clic en el número de artículo siguiente para ir al artículo en Microsoft Knowledge Base:

paquete acumulativo de actualizaciones de Windows RT, Windows 8 y Windows Server 2012 de 2889784: noviembre de 2013

Información de revisiones

Microsoft dispone de una revisión compatible. Sin embargo, esta revisión está pensada para corregir solo el problema que se describe en este artículo. Aplique esta revisión solo a los sistemas que experimentan el problema descrito en este artículo. Esta revisión podría recibir pruebas adicionales. Por lo tanto, si no se ve gravemente afectado por este problema, le recomendamos que espere a la siguiente actualización de software que contiene esta revisión.

Si la revisión está disponible para su descarga, hay una sección "Descarga de revisiones disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio de asistencia al cliente de Microsoft para obtener la revisión.

Nota Si se producen problemas adicionales o si es necesario solucionarlos, es posible que deba crear una solicitud de servicio independiente. Los costos de soporte técnico habituales se aplicarán a preguntas y problemas de soporte técnico adicionales que no reúnan los requisitos para esta revisión específica. Para obtener una lista completa de los números de teléfono de atención al cliente y soporte técnico de Microsoft o para crear una solicitud de servicio independiente, visita el siguiente sitio web de Microsoft:

http://support.microsoft.com/contactus/?ws=support Nota El formulario "Descarga de revisiones disponible" muestra los idiomas para los que está disponible la revisión. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previosPara aplicar esta revisión, debe ejecutar uno de los siguientes sistemas operativos:

  • Windows 7 SP1
  • Windows Server 2008 R2 SP1
  • Windows 8
  • Windows Server 2012

Información del RegistroPara aplicar esta revisión, no es necesario realizar ningún cambio en el Registro.

Requisito de reinicioPuede que se le solicite reiniciar el equipo después de aplicar esta revisión.

Información de reemplazo de revisionesEsta revisión no reemplaza una revisión publicada anteriormente.

Información de archivo

La versión global de esta revisión instala archivos que tienen los atributos que se enumeran en las siguientes tablas. La fecha y la hora de estos archivos se expresan de acuerdo con la hora universal coordinada (UTC). Las fechas y horas de estos archivos se muestran en el equipo local en horario local con la configuración actual del horario de verano (DST). Además, las fechas y horas pueden cambiar cuando realiza determinadas operaciones en los archivos.

información de archivos de Windows RT, Windows 8 y Windows Server 2012

Las revisiones Windows 8 y Windows Server 2012 importantes se incluyen en los mismos paquetes.

Notas

  • Los archivos que se aplican a un producto, hito (RTM, SPn) y tipo de servicio (LDR, GDR) específicos se pueden identificar consultando los números de versión de los archivos, recogidos en la siguiente tabla:

    Versión Producto Hito Rama de servicio
    6.2.920 0.16 xxx Windows RT, Windows 8 y Windows Server 2012 RTM GDR
    6.2.920 0.20 xxx Windows RT, Windows 8 y Windows Server 2012 RTM LDR

Para Windows RT

Nombre del archivo File version Tamaño de archivo Fecha Hora Plataforma
Drmk.sys 6.2.9200.16720 90 112 21-Sep-2013 02:37 No es aplicable
Drmkaud.sys 6.2.9200.16433 5,632 11 de octubre de 2012 04:30 No es aplicable
Portcls.sys 6.2.9200.16723 194 560 24-Sep-2013 22:17 No es aplicable
Sysfxui.dll 6.2.9200.16433 340,992 11 de octubre de 2012 04:50 No es aplicable
Wmalfxgfxdsp.dll 6.2.9200.16433 1,144,968 11 de octubre de 2012 05:10 PM No es aplicable

Para todas las versiones basadas en x86 compatibles de Windows 8

Nombre del archivo File version Tamaño de archivo Fecha Hora Plataforma
Drmk.sys 6.2.9200.16433 83,456 11 de octubre de 2012 04:39 x86
Drmkaud.sys 6.2.9200.16433 5 120 11 de octubre de 2012 04:40 x86
Portcls.sys 6.2.9200.16723 219,136 24-Sep-2013 22:19 x86
Sysfxui.dll 6.2.9200.16433 336,896 11 de octubre de 2012 05:07 x86
Wmalfxgfxdsp.dll 6.2.9200.16433 1,262,744 11 de octubre de 2012 05:18 x86
Drmk.sys 6.2.9200.20534 83,456 11 de octubre de 2012 04:44 x86
Drmkaud.sys 6.2.9200.20534 5 120 11 de octubre de 2012 04:44 x86
Portcls.sys 6.2.9200.20833 218,112 24-Sep-2013 22:19 x86
Sysfxui.dll 6.2.9200.20534 336,896 11 de octubre de 2012 05:12 x86
Wmalfxgfxdsp.dll 6.2.9200.20534 1,262,744 11 de octubre de 2012 05:43 x86

Para todas las versiones compatibles basadas en x64 de Windows 8 y de Windows Server 2012

Nombre del archivo File version Tamaño de archivo Fecha Hora Plataforma
Drmk.sys 6.2.9200.16433 111 616 11 de octubre de 2012 05:18 x64
Drmkaud.sys 6.2.9200.16433 5,632 11 de octubre de 2012 05:19 x64
Portcls.sys 6.2.9200.16723 288 768 24-Sep-2013 22:18 x64
Sysfxui.dll 6.2.9200.16433 370,176 11 de octubre de 2012 05:45 x64
Wmalfxgfxdsp.dll 6.2.9200.16433 1,636,672 11 de octubre de 2012 07:02 x64
Drmk.sys 6.2.9200.20534 111 616 11 de octubre de 2012 05:17 x64
Drmkaud.sys 6.2.9200.20534 5,632 11 de octubre de 2012 05:17 x64
Portcls.sys 6.2.9200.20833 285,696 24-Sep-2013 22:18 x64
Sysfxui.dll 6.2.9200.20534 370,176 11 de octubre de 2012 05:44 x64
Wmalfxgfxdsp.dll 6.2.9200.20534 1,636,672 11 de octubre de 2012 11:07 x64

Información sobre archivos de Windows 7 y Windows Server 2008 R2

Importante Las revisiones de Windows 7 y Windows Server 2008 R2 se incluyen en los mismos paquetes. Sin embargo, las revisiones de la página Solicitud de revisión figuran para ambos sistemas operativos. Para solicitar la revisión que se aplica a uno o a ambos sistemas operativos, seleccione la revisión que aparece enumerada bajo "Windows 7/Windows Server 2008 R2" en la página. Consulte siempre la sección "La información de este artículo se refiere a" en los artículos para determinar el sistema operativo al que se aplica cada revisión.

Notas

  • Los archivos que se aplican a un producto, hito (RTM, SPn) y tipo de servicio (LDR, GDR) específicos se pueden identificar consultando los números de versión de los archivos, recogidos en la siguiente tabla:

    Versión Producto Hito Rama de servicio
    6.1.760
    1.18xxx
    Windows 7 y Windows Server 2008 R2 SP1 GDR
    6.1.760
    1.22xxx
    Windows 7 y Windows Server 2008 R2 SP1 LDR
  • Los tipos de servicio GDR contienen solo las correcciones de amplia distribución para solucionar problemas críticos generalizados. Los tipos de servicio LDR contienen revisiones, además de las correcciones de amplia distribución.

Para todas las versiones compatibles basadas en x86 de Windows 7

Nombre del archivo File version Tamaño de archivo Fecha Hora Plataforma
Drmk.sys 6.1.7601.18270 81,408 25-Sep-2013 01:48 x86
Portcls.sys 6.1.7601.18270 177,152 25-Sep-2013 01:15 x86
Drmk.sys 6.1.7601.22465 81,408 25-Sep-2013 01:52 x86
Portcls.sys 6.1.7601.22465 177,152 25-Sep-2013 01:19 x86

Para todas las versiones basadas en x64 compatibles con Windows 7 y Windows Server 2008 R2

Nombre del archivo File version Tamaño de archivo Fecha Hora Plataforma
Drmk.sys 6.1.7601.18270 116,736 25-Sep-2013 02:11 x64
Portcls.sys 6.1.7601.18270 230 400 25-Sep-2013 01:32 x64
Drmk.sys 6.1.7601.22465 116,736 25-Sep-2013 02:15 x64
Portcls.sys 6.1.7601.22465 230 400 25-Sep-2013 01:36 x64

Para todas las versiones basadas en IA-64 compatibles de Windows Server 2008 R2

Nombre del archivo File version Tamaño de archivo Fecha Hora Plataforma
Portcls.sys 6.1.7601.18270 605,696 25-Sep-2013 01:00 IA-64
Portcls.sys 6.1.7601.22465 605,696 25-Sep-2013 01:02 IA-64

      

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

Para obtener más información acerca de la terminología relativa a las actualizaciones de software de Microsoft, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

824684 Descripción de la terminología estándar que se usa para describir las actualizaciones de software de Microsoft