CORRECTIF : L’altération des données se produit dans l’index cluster lorsque vous exécutez la reconstruction d’index en ligne dans SQL Server 2012 ou SQL Server 2014

S’applique à
SQL Server 2012 Enterprise SQL Server 2012 Enterprise SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use)

Symptômes

La reconstruction d’index en ligne peut entraîner une altération ou une perte de données d’index lorsqu’elle est utilisée avec des requêtes simultanées qui modifient de nombreuses lignes dans Microsoft SQL Server 2012 ou Microsoft SQL Server 2014. Par exemple, une réplication met à jour de nombreuses lignes sur une table lorsque la build d’index en ligne s’exécute simultanément sur la même table.

Ce problème se produit lorsque les conditions suivantes sont remplies :

  • La requête de génération d’index en ligne s’exécute en mode parallèle.
  • Une erreur d’interblocage et une erreur irrécupérable telle que « délai de verrouillage » se produisent dans un ordre spécifique.

Remarque Pour contourner ce problème, exécutez la build d’index en ligne en mode série (DOP = 1).

Résolution

Informations sur les mises à jour cumulatives

Le problème a été résolu pour la première fois dans la mise à jour cumulative suivante de SQL Server.

Mise à jour cumulative 11 pour SQL Server 2012 SP1 /en-us/help/2975396

Mise à jour cumulative 1 pour SQL Server 2012 SP2 /en-us/help/2976982

Mise à jour cumulative 2 pour SQL Server 2014 /en-us/help/2967546

À propos des mises à jour cumulatives pour SQL Server

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

      

informations sur le correctif logiciel SQL Server 2012 Un correctif logiciel pris en charge est disponible auprès de Microsoft. Toutefois, il est conçu uniquement pour corriger le problème décrit dans cet article. Appliquez ce correctif logiciel uniquement aux systèmes qui rencontrent ce problème spécifique.

Si le correctif logiciel est disponible en téléchargement, il existe une section « Téléchargement du correctif logiciel disponible » en haut de cet article de la Base de connaissances. Si cette section n’apparaît pas, envoyez une demande au service clientèle et au support technique Microsoft pour obtenir le correctif logiciel.

Remarque Si des problèmes supplémentaires surviennent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support s'appliqueront aux autres questions et problèmes du support non directement liés au correctif logiciel en question. Pour obtenir la liste complète des numéros de téléphone du service clientèle et du support technique Microsoft ou pour créer une demande de service distincte, visitez le site web Microsoft suivant :

http://support.microsoft.com/contactus/?ws=support Remarque Le formulaire « Téléchargement du correctif logiciel disponible » affiche les langues pour lesquelles le correctif logiciel est disponible. Si votre langue n'est pas répertoriée, cela signifie qu'aucun correctif logiciel n'est disponible pour cette langue.

Remarque Après avoir appliqué le correctif logiciel, le progress_report_online_index_operation d’événement étendu inclut également les détails de l’erreur dans le champ de données error_number qui a été ajouté à l’événement. Ce champ peut être utilisé pour identifier les défaillances internes pendant l’opération d’index en ligne.

Condition requise pour le redémarrageVous n’avez pas besoin de redémarrer l’ordinateur après avoir appliqué ce correctif logiciel.

Informations sur le remplacement du correctif logicielCe correctif logiciel ne remplace pas un correctif logiciel publié précédemment.

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».