Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

After you deploy a custom image or perform a new install from DVD to a Surface Pro 3, the device's battery life may be shorter than expected. Specifically, you may notice that the battery life was longer when the Surface Pro 3 had the original Windows 8.1 Professional with Update image installed that's included with the device.

Additionally, if you review the powercfg /sleepstudy output, you may see evidence of connected standby sessions that run for extended periods (more than four hours).

Cause

The Windows 8.1 Professional with Update image that's included with the Surface Pro 3 is configured from the factory to hibernate after four hours in connected standby. If a custom image or a new install is deployed to the device, the settings to hibernate after four hours are not configured by default. This setting is typically configured by the OEM.

Note This four-hour hibernation behavior occurs only when you're running on battery power. When the device is plugged in, it does not hibernate after four hours.

Resolution

If you want to configure the system to hibernate after four hours, first make sure that the following update is installed:

2955769 Improvement that saves battery power on a Windows 8.1 or Windows Server 2012 R2-based computer


Note Although KB article 2955769 mentions that this update is part of update 2955164, we recommend that you specifically install update 2955769 to make sure that this functionality is available.

Then, run the following commands to configure the power settings.

REM sets CS battery saver time-out to four hours:

powercfg /setdcvalueindex SCHEME_CURRENT e73a048d-bf27-4f12-9731-8b2076e8891f 7398e821-3937-4469-b07b-33eb785aaca1 14400 
powercfg /setacvalueindex SCHEME_CURRENT e73a048d-bf27-4f12-9731-8b2076e8891f 7398e821-3937-4469-b07b-33eb785aaca1 14400 


REM sets CS battery saver trip point to 100:

powercfg /setdcvalueindex SCHEME_CURRENT e73a048d-bf27-4f12-9731-8b2076e8891f 1e133d45-a325-48da-8769-14ae6dc1170b 100 
powercfg /setacvalueindex SCHEME_CURRENT e73a048d-bf27-4f12-9731-8b2076e8891f 1e133d45-a325-48da-8769-14ae6dc1170b 100 


REM sets the CS battery saver action to hibernate:

powercfg /setdcvalueindex SCHEME_CURRENT e73a048d-bf27-4f12-9731-8b2076e8891f c10ce532-2eb1-4b3c-b3fe-374623cdcf07 001 
powercfg /setacvalueindex SCHEME_CURRENT e73a048d-bf27-4f12-9731-8b2076e8891f c10ce532-2eb1-4b3c-b3fe-374623cdcf07 001 
powercfg /setactive SCHEME_CURRENT 


Note Four hours is the minimum supported value for the CS battery saver time-out.

More Information

After the system is configured to hibernate, the powercfg /sleepstudy output should show connected standby sessions that last for approximately four hours. If, after you install this update and configure the system to hibernate, you still see sessions that last for extended periods, this might indicate an issue that's preventing the device from hibernating.

To troubleshoot this type of issue, use the output from Powercfg /requests to determine why the device does not hibernate. For more information about troubleshooting power management issues, see the following Windows blog post:

Sleep Study: Diagnose what’s draining your battery while the system sleeps

To determine whether a system is going into hibernation, check the System log for the following event:

Log Name: System
Source: Microsoft-Windows-Kernel-Power
Event ID: 42
Level: Information
Description:
The system is entering sleep.
Sleep Reason: Battery

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×