ロールと機能を表示できず、サーバー マネージャーでエラー コード0x800706BEを受け取ることができません

この記事では、ロールと機能を表示できず、サーバー マネージャーでエラー コード 0x800706BEを受け取ることができない問題の解決策について説明します。

適用対象: Windows Server 2012 R2
元の KB 番号: 2461206

現象

次のような状況で問題が発生します。

  1. Windows Server 2008 または Windows Server 2008 R2 を実行しているコンピューターがあります。
  2. [サーバー マネージャー] ウィンドウを開いて、ロールと機能を表示/追加/削除します。

このシナリオでは、ロールと機能は、サーバー マネージャー ウィンドウに黄色の強打で表示されません。 開こうとすると、サーバー マネージャーの下部に次のエラー メッセージが表示されます。

サーバー マネージャ
予期しないエラーの更新サーバー マネージャー: リモート プロシージャ呼び出しに失敗しました。 (HRESULT からの例外: 0x800706BE)
詳細については、「診断、イベント ビューアー、アプリケーションとサービス ログ、Microsoft、Windows、サーバー マネージャー、Operational」のイベント ログを参照してください。

同時に、次のイベントが Microsoft-Windows-ServerManager/Operational ログに追加されます。

ログ名: Microsoft-Windows-ServerManager/Operational
ソース: Microsoft-Windows-ServerManager
日付: <日付 & 時刻>
イベント ID: 1601
タスク カテゴリ: なし
レベル: エラー
キーワード:
ユーザー: <ユーザー名>
コンピューター: <コンピューター名>
説明:
システムの状態を検出できませんでした。 予期しない例外が見つかりました。
System.Runtime.InteropServices.COMException (0x800706BE): リモート プロシージャ呼び出しに失敗しました。 (HRESULT からの例外: 0x800706BE)
at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
at Microsoft.Windows.ServerManager.ComponentInstaller.CreateSessionAndPackage(IntPtr& セッション, IntPtr& パッケージ)
at Microsoft.Windows.ServerManager.ComponentInstaller.InitializeUpdateInfo()
at Microsoft.Windows.ServerManager.ComponentInstaller.Initialize()
at Microsoft.Windows.ServerManager.Common.Provider.RefreshDiscovery()
at Microsoft.Windows.ServerManager.LocalResult.PerformDiscovery()
at Microsoft.Windows.ServerManager.ServerManagerModel.CreateLocalResult(RefreshType refreshType)
at Microsoft.Windows.ServerManager.ServerManagerModel.InternalRefreshModelResult(Object state)

原因

一部のカタログ ファイル、マニフェスト ファイル、または MUM ファイルがコンピューター上で破損しています。

解決方法

この問題を解決する手順を次に示します。

  1. Microsoft Update 準備ツールを次の場所から取得します https://support.microsoft.com/kb/947821

  2. 問題のあるコンピューターで Microsoft Update 準備ツールを実行します。

  3. スキャンが完了した後、%Systemroot%\Windows\logs\CBS\Checksur.log ファイルを開きます。

  4. ファイルに破損した情報がチェック。 いくつかのサンプルを次に示します。

    (f) CBS MUM 破損した0x00000000サービス\Packages\Package_for_KB978601~31bf3856ad364e35~amd64~~6.0.1.0.mum 予期されるファイル名 Package_for_KB978601_server~31bf3856ad364e35~amd64~~6.0.1.0.mum が実際のファイル名と一致しません
    (f) CBS MUM 破損した0x00000000サービス\Packages\Package_for_KB979309~31bf3856ad364e35~amd64~~6.0.1.0.mum 予期されるファイル名 Package_for_KB979309_server~31bf3856ad364e35~amd64~~6.0.1.0.mum が実際のファイル名と一致しません

    または

    (f) CBS MUM 破損した0x800B0100サービス\Packages\Package_for_KB978601~31bf3856ad364e35~amd64~~6.0.1.0.mum servicing\Packages\Package_for_KB978601~31bf3856ad364e35~amd64~~~6.0.1.0.cat パッケージ マニフェストは、対応するカタログで検証できません (f) CBS MUM 破損した0x800B0100サービス\Packages\Package_for_KB979309~31bf3856ad364e35~amd64~~6.0.1.0.mum servicing\Packages\Package_for_KB979309~31bf3856ad364e35~amd64~~6.0.1.0.cat パッケージ マニフェストは、対応するカタログ

    または

    (f) CBS MUM 不足0x00000002サービス\packages\Package_114_for_KB955839~31bf3856ad364e35~amd64~~6.0.1.0.mum (f) CBS MUM 不足0x00000002サービス\packages\Package_83_for_KB955839~31bf3856ad364e35~amd64~~6.0.1.0.mum

    さらに下に、次の情報が表示されます。

    利用できない修復ファイル:
    servicing\packages\Package_for_KB978601~31bf3856ad364e35~amd64~~~6.0.1.0.mum
    servicing\packages\Package_for_KB979309~31bf3856ad364e35~amd64~~~6.0.1.0.mum
    servicing\packages\Package_for_KB978601~31bf3856ad364e35~amd64~~~6.0.1.0.cat
    servicing\packages\Package_for_KB979309~31bf3856ad364e35~amd64~~~6.0.1.0.cat

%systemroot\Windows\Servicing\Packages にこれらのファイルをコピーします。

  1. まず、そのフォルダーを制御する必要があります。 これを行うには、次のコマンドを使用します。

    takeown /F c:\Windows\Servicing\Packages /D y /R
    
  2. 次のコマンドを使用して、フル コントロールを割り当てます。 ディレクトリを完全に制御できるようになります。

    cacls c:\Windows\Servicing\Packages /E /T /C /G "UserName": F
    
  3. 次に、不足しているファイルまたは破損したファイルをログから収集する checksur 必要があります。不足しているファイルの KB ファイルをダウンロードします。

    servicing\packages\Package_for_ KB978601 ~31bf3856ad364e35~amd64~~~6.0.1.0.mum

  4. 次のコマンドを使用して開梱します。

    Expand -F:\* UpdateKBXXXX.msu x:\DestinationDirectory
    
  5. 展開すると、UpdateKBXXXX.cab ファイルが表示されます。 同様に展開します。

    Expand -F:\* UpdateKBXXXX.CAB x:\DestinationDirectoryCAB
    

    このタクシーの内部では、update.mum と update.cat の 2 つのファイルを取得する必要があります。

  6. 収集した update.mum ファイルと update.cab ファイルの名前を、checksur.logとまったく同じ名前に変更します。

    例: KB978601の update.mum は~31bf3856ad364e35~amd64~~~6.0.1.0.mum Package_for_ KB978601されます
    他のすべての不足しているファイルや破損したファイルに対して同じ操作を行い、checksur.log (/servicing/packages) で指定されたディレクトリに配置します。

これらの手順の後、問題を修正する必要があります。再起動は必要ありません。

注:

これらの手順を実行してもサーバー マネージャーが機能しない場合は、更新準備ツールをもう一度実行し、上記の手順チェック二重にしてください。