Microsoft Office Outlook Microsoft Dynamics CRMクライアントをインストールするときに InstallPSTAction エラーが発生しました
この記事では、Microsoft Office Outlook 用のクライアントをインストールするときに InstallPSTAction 失敗エラー Microsoft Dynamics CRM発生する問題の解決策について説明します。
適用対象: Microsoft Dynamics CRM 2011
元の KB 番号: 2496442
現象
Microsoft Office Outlook 用Microsoft Dynamics CRM 2011 クライアントをアンインストールし、Microsoft Dynamics CRM 4.0 クライアントを Outlook 用にインストールすると、構成ウィザードを実行しようとすると、次のエラーが発生します。
エラー|構成例外。System.Exception: アクション Microsoft.Crm.Config。Client.InstallPstAction が失敗しました。 --->
System.Runtime.InteropServices.COMException (0x8004010F): LaunchOutlookInstallerProcess が失敗しました。
at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
を Microsoft.Crm.Config します。Client.InstallPstAction.Do(IDictionary パラメーター)
at Microsoft.Crm.Setup.Common.Action.ExecuteAction(Action action, IDictionary parameters, Boolean undo)
原因
これは、アンインストールによって、CRMForOutlookInstaller.exe ファイルがディレクトリに C:\Program Files\Microsoft Dynamics CRM\Client\ConfigWizard
残されていることが原因です。
解決方法
この問題を解決するには、次の手順を実行します。
- ディレクトリまたは
C:\Program Files (x86)\Microsoft Dynamics CRM\Client\ConfigWizard
ディレクトリにC:\Program Files\Microsoft Dynamics CRM\Client\ConfigWizard
移動します。 - CRMForOutlookInstaller.exe ファイルを削除します。
- 次のいずれかのオプションを実行します。
- Microsoft Dynamics CRM 4.0 クライアント インストール ビットの CRMForOutlookInstaller.exe を置き換えます。
- Microsoft Office Outlook のMicrosoft Dynamics CRM 4.0 クライアントで修復を実行します。
- Microsoft Dynamics CRM 4.0 クライアントをアンインストールして再インストールします。
- 構成ウィザードを実行します。
詳細
CRMForOutlookInstaller.exe は、Microsoft Dynamics CRM クライアントを構成している可能性がある他のユーザーからユーザーごとのレジストリ キーを削除するために残されています。