Microsoft Dynamics CRM 2011 organizationをインポートしようとすると、ユーザーまたはグループが見つからないエラーをWindows NT

適用対象: Microsoft Dynamics CRM 2011
元の KB 番号: 2564514

現象

以前に Dynamics CRM 2011 がアンインストールされ、再インストールが実行された環境にMicrosoft Dynamics CRM organization データベースをインポートしようとすると、次のエラーが発生する可能性があります。

ログ ファイルに次のエラー メッセージが表示されます。

エラー|組織のインポート (Name=<ORGNAME>、Id=ID) が例外で失敗しました。

System.Data.SqlClient.SqlException (0x80131904): ユーザーまたはグループ '<DOMAINNAME>\SQLAccessGroup {ID}' が見つかりませんWindows NT。 名前をもう一度確認します。

原因

これは、Microsoft Dynamics CRMがアンインストールされたときに、Microsoft Dynamics CRM特権グループが SQL Server Security フォルダーに残されていることが原因で発生する可能性があります。

解決方法

この問題を解決するには、データベース サーバーの SQL Server Security Logins フォルダー内から古いMicrosoft Dynamics CRM特権グループを削除します。

  1. SQL Serverで、SQL Server管理サーバーを開きます。

    1. [スタート] を選択します。
    2. [ すべてのプログラム] を選択します
    3. [Microsoft SQL Server 2008] または [Microsoft SQL Server 2008 R2] を選択します。
    4. [SQL Server Management Studio] を選択します。
  2. SQL Server Management Studioにサインインします。

  3. [セキュリティ] フォルダーを展開します。

    1. [セキュリティ] フォルダーを展開する場合に選択します。
    2. [ログイン] フォルダーを展開する場合に選択します。
  4. CRM セキュリティ グループを見つけます。

    <DOMAINNAME>\PrivReportingGroup {GUID VALUE}
    <DOMAINNAME>\ReportingGroup {GUID VALUE}
    <DOMAINNAME>\SQLAccessGroup {GUID VALUE}

  5. 各セキュリティ グループを削除します。

    1. 名前を右クリックします。
    2. [削除] を選択します。
    3. [OK] を選択します。
  6. インポートorganizationを再試行します。