Microsoft Application Virtualization でパッケージ バージョンを追加すると、エラー 0x8007012Fが返されます

この記事では、Microsoft Application Virtualization コンソールで同じパッケージ バージョンを削除して追加したときにエラー 0x8007012Fが発生する問題を回避するためのヘルプを提供します。

適用対象: Windows Server 2008 R2 Service Pack 1、Windows 7 Service Pack 1
元の KB 番号: 2780304

現象

Microsoft Application Virtualization コンソールで同じパッケージ バージョンを削除してから追加すると失敗し、エラー 0x8007012Fが返されます。

原因

App-V v5 パッケージ バージョンが追加されると、パッケージ ファイルは %programdata%\App-V\{PackagID}\{VersionId} に作成されます。 パッケージのバージョンが削除されると、%programdata%\App-V のパッケージ ファイルも削除されます。 App-V v5 クライアントが削除できないファイルは、次回のシステム再起動時に削除対象としてマークされます。

すべてのパッケージ バージョン ファイルが正常に削除された場合は、システムを再起動せずに同じパッケージ バージョンをすぐに追加できますが、いずれかのファイルを削除できなかった場合は、削除したばかりの同じパッケージ バージョンを追加すると、エラー 0x8007012Fが返されます。 この動作は仕様です。

回避策

この問題を回避するには、同じパッケージ バージョンを再度追加する前にコンピューターを再起動します。 システムの再起動によってパッケージ バージョンの削除が完了し、その後、同じパッケージ バージョンが正常に再び追加されます。

このシナリオは、運用環境でパッケージ バージョンを削除し、同じパッケージ バージョンをもう一度追加する理由がないため、テスト環境で発生する可能性が最も高いです。 ただし、これが運用環境で発生し、システムの再起動を実行できない場合は、システムの再起動を必要としない別の回避策があります。 別の方法として、同じパッケージの新しいバージョンを作成することもできます。 これを行うには、Sequencer でパッケージを開き、保存します。 新しいパッケージ バージョンは、以前のバージョンの部分的に削除された状態の影響を受けないため、システムを再起動せずに追加できます。

注:

この問題が完全なインフラストラクチャ シナリオで発生した場合、次の "更新" で、このエラーは App-V クライアント 管理 イベント ログに記録されます。