クライアント正常性評価タスクの実行後Configuration Manager管理ポイントが失敗する

この記事では、Configuration Manager管理ポイントが失敗し、HTTP 500 エラーが返される問題について説明します。

元の製品バージョン:Microsoft System Center 2012 Configuration Manager
元の KB 番号: 2796086

現象

Microsoft System Center 2012 Configuration Managerクライアントと併置された管理ポイントは、HTTP 500 エラーを呼び出し元のクライアントに返すことによって毎日失敗します。 この問題は、 クライアント正常性評価 タスクを実行してクライアントを再インストールした後に発生します。 このような場合、CCMEval.log ファイルには次のようなエントリが含まれます。

マニフェスト ファイルの読み込み: C:\Program Files\SMS_CCM\CcmEval.xml
ccmeval マニフェスト ファイルが正常に読み込まれました。
クライアント正常性ルールの評価を開始します。
すべてのクライアント正常性チェックが正常に取得されました。
正常性チェックルール {4AB7D77D-3BB0-4EAB-BEFD-7C0F7DA10296} の評価: WMI サービスが存在することを確認します。
正常性チェックルール {518C0699-03F8-4F38-85C4-4D319EAEFC05} の評価 : WMI サービスのスタートアップの種類を確認/修復します。
正常性チェックルール {7F4B6E15-2221-455B-9615-93C379E470D5} の評価 : WMI サービスの状態を確認/修復します。
正常性チェックルール {A81778B5-9A1E-4A52-9C6E-6939CEFAA118} の評価 : WMI リポジトリ整合性テスト。
Windows では、20121218093732.000000-000 で最新の起動前に不適切なシャットダウンが行われます
正常性チェックルール {14E6774A-1795-4E09-B17D-B6F36A124205} の評価 : WMI リポジトリの読み取り/書き込みテスト。
クラス 'CIM_ClassDeletion' を削除できませんでした (80041002)
クラス 'CIM_ClassCreation' を削除できませんでした (80041002)
クラス 'CIM_ClassModification' を削除できませんでした (80041002)
クラス 'CIM_ClassIndication' を削除できませんでした (80041002)
クラス 'CIM_InstCreation' を削除できませんでした (80041002)
クラス 'CIM_InstModification' を削除できませんでした (80041002)
クラス 'CIM_InstDeletion' を削除できませんでした (80041002)
クラス 'CIM_InstIndication' を削除できませんでした (80041002)
クラス 'CIM_Indication' を削除できませんでした (80041002)
クラス 'MSFT_ExtendedStatus' を削除できませんでした (80041002)
クラス 'MSFT_WmiError' を削除できませんでした (80041002)
クラス 'CIM_Error' を削除できませんでした (80041002)
名前空間の削除に失敗する (root\cimv2\ccm2) (0x80041002)
WMI リポジトリの機能の確認全般に失敗しました
WMI チェック失敗しました
Windows では、20121218093732.000000-000 で最新の起動前に不適切なシャットダウンが行われます
サービス 'ccmexec' を正常に停止しました
サービス 'winmgmt' の依存サービスを正常に停止しました
サービス 'winmgmt' を正常に停止しました
リポジトリの修復を起動しようとしています。
クライアントまたはクライアントの前提条件のインストールを修復しようとしています。
クライアントまたはクライアントの前提条件のインストール修復が成功しました。
クラス 'CIM_ClassDeletion' を削除できませんでした (80041002)
クラス 'CIM_ClassCreation' を削除できませんでした (80041002)
クラス 'CIM_ClassModification' を削除できませんでした (80041002)
クラス 'CIM_ClassIndication' を削除できませんでした (80041002)
クラス 'CIM_InstCreation' を削除できませんでした (80041002)
クラス 'CIM_InstModification' を削除できませんでした (80041002)
クラス 'CIM_InstDeletion' を削除できませんでした (80041002)
クラス 'CIM_InstIndication' を削除できませんでした (80041002)
クラス 'CIM_Indication' を削除できませんでした (80041002)
クラス 'MSFT_ExtendedStatus' を削除できませんでした (80041002)
クラス 'MSFT_WmiError' を削除できませんでした (80041002)
クラス 'CIM_Error' を削除できませんでした (80041002)
名前空間の削除に失敗する (root\cimv2\ccm2) (0x80041002)
WMI リポジトリの機能の確認全般に失敗しました
WMI チェック失敗しました
結果: 修復に失敗しました、ResultCode: 304、ResultType: 202、ResultDetail: root\cimv2\ccm2#CCMEVALPARAMSEP#20121218093732.000000-000*

原因

この問題は、Windows Management Framework 3.0 (KB 2506143 で説明) が System Center 2012 Configuration Manager RTM 環境にインストールされている場合に発生する可能性があります。 System Center 2012 Configuration Manager RTM クライアントは、Windows Management Framework 3.0 と互換性がありません。 毎日の クライアント正常性評価中に、CCMEval.exe が誤って WMI リポジトリが破損しているのを検出します。 そのため、CCMEval.exe はリビルドを要求してから、クライアントを再インストールします。 CCMEval によるリポジトリの再構築により、WMI から管理ポイント固有の情報、メソッドなどが失われます。 これにより、管理ポイントが失敗します。

System Center 2012 Configuration Manager Service Pack 1 (SP1) は、Windows Management Framework 3.0 の公式サポートを提供します。 したがって、System Center 2012 Configuration Manager SP1 はこの問題の影響を受けません。

解決方法

この問題を解決するには、System Center 2012 Configuration Manager SP1 を環境に適用します。 System Center 2012 Configuration Manager RTM 環境の場合は、影響を受けるクライアントで次のレジストリ値を True に設定することで、この問題を回避できます。

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\CCM\CcmEval\NotifyOnly

このレジストリ値が True に設定されている場合でも、クライアントは評価タスクを毎日実行し、WMI リポジトリが破損していることを誤って報告します。 ただし、リポジトリの再構築や毎日のクライアントの再インストールは要求されません。

実行されている評価のために管理ポイントが既に失敗している場合は、管理ポイントをアンインストールしてから再インストールして、オンラインに戻っていることを確認する必要があります。 これを行うには、次の手順を実行します。

  1. [ サーバーとサイト システムの役割] で、障害が発生した管理ポイントをホストしているサーバーを選択します。
  2. 管理ポイントロールを右クリックし、[ ロールの削除] を選択します。
  3. 管理ポイント サーバーのMPSetup.logを監視して、削除が完了したことを確認します。
  4. 同じサーバーを右クリックし、[ サイト システムの役割の追加] を選択します。
  5. ウィザードで管理ポイントの役割を選択し、管理ポイント サーバーのMPSetup.logを監視して、再インストールが完了したことを確認します。