オンプレミスの Exchange からオンラインに移行するときに、リモート サーバー エラーに接続できませんでした

元の KB 番号: 2903050

現象

Outlook Anywhere (RPC over HTTP とも呼ばれます) を使用してExchange Onlineするオンプレミスの Exchange organizationからカットオーバー移行を実行しようとすると、移行エンジンは移行エンドポイントを作成しません。 さらに、次のようなエラー メッセージが表示されます。

Microsoft.Exchange.Data.Storage.Management.MigrationTransientException: リモート サーバーに接続できませんでした。 移行エンドポイントの設定が正しく、証明書が有効であることを確認してから、もう一度やり直してください。 Exchange リモート接続アナライザーを使用して接続の問題を診断することを検討してください。 >--- Microsoft.Exchange.Rpc.ServerUnavailableException: エラー 0x6ba (RPC サーバーは使用できません) からcli_NspiBind

原因

この問題は、Outlook Anywhere で次の条件のいずれかまたは両方が当てはまる場合に発生する可能性があります。

  • Outlook Anywhere の認証設定が正しくありません。
  • Outlook Anywhere の RPC プロキシ構成設定が正しくありません。

解決方法

この問題を解決するには、次の手順を実行します。

  1. オンプレミスの Outlook Anywhere クライアント認証方法が Basic 認証に設定されていることを確認します。 詳細については、実行しているExchange Serverのバージョンに応じて、次のいずれかの記事を参照してください。

  2. 特定のポートを使用して Outlook Anywhere と通信するように RPC プロキシ サーバーが正しく設定されていること、およびオンプレミスのドメイン コントローラーがポート 6004 でリッスンしていることを確認します。 詳細については、「Outlook Anywhere のしくみ (および動作しない)」を参照してください。

  3. オンプレミスの Exchange サーバーへの Outlook Anywhere 接続を確認します。 これを行うには、次の手順を実行します。

    1. リモート PowerShell を使用して Exchange Online に接続します。 これを行う方法の詳細については、「PowerShell に接続する」Exchange Online参照してください。

    2. 次の PowerShell コマンドを実行します。

      $pscred=Get-Credential
      
      Test-MigrationServerAvailability -Credentials $pscred -ExchangeOutlookAnywhere -ExchangeServer <Internal FQDN of the Exchange server> -RPCProxyServer <FQDN of the proxyserver> -Authentication Basic -EmailAddress <AdminEmail>
      

      検証が成功した場合は、Microsoft 365 で移行エンドポイントを作成できます。

さらにヘルプが必要ですか? Microsoft コミュニティを参照してください。