リモート Windows PowerShell を使用して Exchange Online に接続すると (アクセスが拒否されました) エラー

問題

リモート Windows PowerShell を使用して Microsoft Exchange Online に接続しようとすると、次のエラー メッセージが表示されます。

[outlook.office365.com] Connecting to remote server failed with the following error message: Access is
denied. For more information, see the about_Remote_Troubleshooting Help topic.

+ CategoryInfo : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [].
PSRemotingTransportException

+ FullyQualifiedErrorId : PSSessionOpenedFailed

Import-PSSession : Cannot validate argument on parameter 'Session'. The argument is null.
Supply a non-null argument and try the command again.

At D:\Users\Connect.ps1:7 char:21

+ Import-PSSession < < < < $Session

+ CategoryInfo : Invalid Data: (:) [Import-PSSession], ParameterBindingValidationException

+ FullyQualifiedErrorId :
ParameterArgumentValidationError,Microsoft.PowerShell.Commands.ImportPSSessionCommand

原因

この問題は、次のいずれかの理由で発生します。

  • 正しくないユーザー名またはパスワードを入力します。
  • Exchange Online にアクセスできないアカウントを使用して、サービスにサインインしようとするとします。
  • テナントでセキュリティの既定値が有効になっています。

ソリューション

この問題を解決するには、Microsoft 365 の Exchange 管理センターを使用して、管理者役割グループのメンバーとしてユーザーを追加します。 これを行うには、次の手順を実行します。

  1. 管理者として Microsoft 365 ポータル (https://portal.office.com) にサインインします。
  2. [管理者] をクリックし、[Exchange] をクリックします。
  3. [アクセス許可] をクリックし、[管理者ロール] をクリックします。
  4. ユーザーを追加する役割グループをダブルクリックします。 たとえば、Windows PowerShell を含むフル アクセス権をユーザーに付与する場合は、[組織管理] をダブルクリックします。
  5. ユーザーを一覧に追加するには、[メンバー] の [追加] ( ) をクリックします。
  6. [保存] をクリックします。

セキュリティの既定値が有効になっている場合は、「MFA の有無にかかわらず、先進認証を使用して PowerShell Exchange Online に接続する」を参照してください。

詳細情報

リモート PowerShell を使用して Exchange Online に接続する方法の詳細については、「リモート PowerShell を使用して Exchange Online に接続する」を参照してください。

さらにヘルプが必要ですか? Microsoft コミュニティを参照してください。