MSSQLSERVER_3013

適用対象:SQL Server

詳細

属性
製品名 SQL Server
イベント ID 3013
イベント ソース MSSQLSERVER
コンポーネント SQLEngine
シンボル名 DMP_ABORT
メッセージ テキスト BACKUP DATABASE が異常終了している /RESTORE DATABASE は異常終了しています。

説明

このエラーは、バックアップまたは復元操作が予期せず中断されたときに発生する一般的なエラーです。 3013 が他のエラー メッセージと共に発生し、バックアップ エラーの原因に関するより具体的な分析情報が得られることがわかります。 たとえば、バックアップ メディアからの読み取りまたは書き込みの失敗、またはその他の予期しない Win32 API 呼び出しエラーなどがあります。

原因

バックアップの異常終了やSQL Serverの復元には、さまざまな原因が考えられます。 一般的な理由の一覧を次に示します。

  • ディスクの空き領域が不足しています。
  • バックアップ ストレージ デバイスへのパスが正しくありません
  • バックアップ ファイル/デバイスが別のプログラムによって既に開かれている
  • バックアップ メディア デバイスの障害または誤動作
  • データベースの破損 - データベースが破損している場合、バックアップまたは復元操作が失敗する可能性があります。
  • バックアップまたは復元できる BACKUP DATABASE、BACKUP LOG、または CREATE DATABASE のアクセス許可がない
  • SQL Serverサービス アカウントにバックアップ デバイスへのアクセスがない

ユーザー アクション

追加情報やトラブルシューティングが必要な場合、このエラーと共に発生した他のメッセージの SQL エラー ログを調べてください。

  • ディスク領域が不足している場合は、バックアップを書き込むドライブに十分な空き領域があることを確認するか、別のデバイスを使用してください。 エラー 3203 および 3203 の例を参照してください

  • ファイル パスが正しくない場合は、backup コマンドまたは RESTORE コマンドで指定したパスとファイル名をダブルチェックして修正します。

  • バックアップ メディアの障害の場合、テープ ドライブまたはその他のバックアップ デバイスにバックアップする場合は、デバイスが正しく機能していて、ハードウェア エラーが発生していないことを確認します。 エラー 3203 と 3203 の例とエラー 3241 の例を参照してください

  • データベースの破損の問題については、SQL Serverで他のエラーが発生する可能性があります。 DBCC CHECKDB を実行して、データベース内のエラーを特定し、解決します。 詳細については、「DBCC CHECKDB によって報告されるデータベース整合性エラーのトラブルシューティング」を参照してください。

  • サーバー プリンシパル アカウントにバックアップまたは復元操作を実行するためのアクセス許可がない場合は、それらのアクセス許可が付与されているアカウントを確認してください。 バックアップのアクセス許可復元のアクセス許可に関するページを参照してください

  • SQL Serverサービス アカウントのアクセス許可の問題については、バックアップ デバイスまたはバックアップ ファイルが書き込まれるファイル システムに対する読み取りおよび書き込みアクセス権をSQL Serverサービス アカウントに付与してください。 「バックアップのアクセス許可」を参照してください。

一般的に観察されるエラーと 3013 の例を次に示します。

エラー 3241 の例

このシナリオでは、エラー 3241 は 3013 で発生し、バックアップ自体の問題を示します。

Msg 3241, Level 16, State 0, Line 2
The media family on device 'G:\backup\ProdDB_backup.bak' is incorrectly formed. SQL Server cannot process this media family.
Msg 3013, Level 16, State 1, Line 2
RESTORE FILELIST is terminating abnormally.

解決策:

通常、このエラーは、バックアップが破損しているか、バックアップを保存または転送したメディアが誤動作したことを示します。 別のメディアから復元する代替バックアップを見つけるか、以前または後のバックアップを試してください。 また、TDE データベースのバックアップ/復元については KB5014298 を参照してください。 修正: RESTORE DATABASE または RESTORE LOG の実行中にエラー 3241 が発生する

トラブルシューティングのアイデアの詳細については、「バックアップからデータベースを復元するときのメディア関連のエラー」を参照してください。

エラー 3203 および 3203 の例

エラー 3202 および 3203 は、I/O 関連の問題がある場合に発生するバックアップ エラーです。 これら 2 つのエラーは、読み取り要求と書き込み要求のどちらが実行されたかを示し、I/O エラーの原因となった基になる OS エラーを示します。 次の例が確認されています。

Msg 3203, Level 16, State 1, Line 1
Read on "G:\SQLDATA\ProductionDb.ndf" failed: 483(The request failed due to a fatal device hardware error.)
Msg 3013, Level 16, State 1, Line 1
BACKUP DATABASE is terminating abnormally.
Msg 3202, Level 16, State 1, Line 2
Write on "Y:\SQLDATA\ProductionDb.bak" failed: 1117(The request could not be performed because of an I/O device error.)
Msg 3013, Level 16, State 1, Line 2
RESTORE DATABASE is terminating abnormally.
Msg 3202, Level 16, State 1, Line 14
Write on "\\BackupServer\Share\ProdDb.bak" failed: 112(There is not enough space on the disk.)
Msg 3013, Level 16, State 1, Line 14
BACKUP DATABASE is terminating abnormally.

解決策:

  • OS 483 および 1117 の例は、I/O デバイスの障害を示しています。 記憶媒体の故障や損傷がないか確認してください。 システム イベント ログ、ハードウェア構成、ログを確認し、ハードウェア管理者とベンダーと協力して、バックアップを格納するメディアに関する問題に対処します。 システム イベント ログに表示されるメッセージの例を次に示します。これは、対処する必要がある I/O の問題を示しています。

    Warning PM,Disk,153,None,The IO operation at logical block address 0xe90525a0 for Disk 3 (PDO name: \Device\00000017) was retried.
    
  • 領域の問題を示す OS エラー 112 が発生した場合は、バックアップが送信されるローカルまたはリモート ストレージに十分なディスク領域を確保してください。 十分な領域が使用可能な場合は、ストレージ メディアの信頼性を確保してください。

3624 の例

場合によっては、システム アサーションと共にエラー 3013 が発生することがあります。 アサーションでバックアップが失敗した場合、メインの焦点はアサーション自体に対処することです。 観察された問題の例を次に示します。

Msg 3013, Sev 16, State 1, Line 1
VERIFY DATABASE is terminating abnormally.
Msg 3624, Sev 20, State 1, Line 1
A system assertion check has failed. Check the SQL Server error log for details. Typically, an assertion failure is caused by a software bug or data corruption. To check for database corruption, consider running DBCC CHECKDB. If you agreed to send dumps to Microsoft during setup, a mini dump will be sent to Microsoft. An update might be available from Microsoft in the latest Service Pack or in a Hotfix from Technical Support.
Error: 17066, Severity: 16, State: 1.
SQL Server Assertion: File:     mediaRead.cpp:429 Expression:     !m_ActiveConsumptionList.IsEmpty () || !m_ActiveReads.IsEmpty () || !m_DecodeOutputQ.IsEmpty () || (CFeatureSwitchesMin::GetCurrentInstance ()->FEnableCheckingActiveDecodeQueueEnabled () && !m_ActiveDecodeInput.IsEmpty ()) SPID:         74 Process ID:     25440

解決策:

SQL Serverエラー ログを確認し、この記事のMSSQLSERVER_3624に記載されている手法を使用してアサート エラーのトラブルシューティングを行います。

エラー 4303 の例

この例では、失敗してエラー 3013 が発生したトランザクション ログ シーケンスの復元を示します。 特定のエラー 4303 は、この前にトランザクション ログの復元がさらに不足しているか、トランザクション ログ バックアップ ファイルが破損していることを示します。 たとえば、LSN = 4294967295429496729565535は有効な LSN とは見なされないため、バックアップ ファイルまたはメディアが破損している可能性があります。

Msg 4303, Level 16, State 1, Line 3
The roll forward start point is now at log sequence number (LSN) 8177105000003941300003. Additional roll forward past LSN 4294967295429496729565535 is required to complete the restore sequence.
Msg 3013, Level 16, State 1, Line 3
RESTORE DATABASE is terminating abnormally.

解決策:

3013 と共に 4303 などのエラーが発生した場合は、復元する別の適切なバックアップを見つけます。 また、バックアップが配置され、必要に応じて修復されるストレージ メディアの安定性もチェックします。

関連項目