Windows Server 2008 R2 に VMWare ドライバーをインストールすることはできません

この記事では、Windows Server 2008 R2 を実行しており、Telnet Server サービスがインストールされているサーバーに VMWare ドライバーをインストールできない問題の回避策について説明します。

適用対象: Windows Server 2008 R2 Service Pack 1
元の KB 番号: 3066752

現象

次のような状況で問題が発生します。

  • Windows Server 2008 R2 を実行しているコンピューターでは、VMWare vSphere 環境にイーサネット アダプターを追加します。
  • Telnet サーバー サービスがインストールされています。
  • Microsoft 管理コンソール (MMC) の [サービス] スナップインで、手動または自動で開始するように Telnet Server サービスを構成します。
  • サービス スナップインでは、ローカル システム アカウントを使用してログオンするように Telnet Server サービスを構成します。 また、[ デスクトップとの対話をサービスに許可する ] チェック ボックスはオンにしません。

このシナリオでは、デバイス マネージャーを使用してドライバーをインストールしようとすると、試行が失敗し、次のエラー メッセージが表示されます。

Windows でデバイスのドライバー ソフトウェアが見つかりましたが、インストール中にエラーが発生しました。

インストールエラーが発生した後、VM 設定の一覧から別の使用可能なイーサネット アダプターのインストールに失敗します。 たとえば、Intel E1000 を選択します。 ただし、2 つ目のドライバーもインストールされません。 さらに、% windir%/inf/の下のSetupapi.dev.logに、次のようなログ エントリが記録されます。

dvi: {プラグ アンド プレイ Service: Device Install for PCI\VEN_15AD&DEV_07B0&SUBSYS_07B015AD&REV_01\FF565000B37984FE00}
ump: インストール プロセスの作成: DateTime> DrvInst.exe<
ump: DateTime> 0xc0000142コード<を使用してサーバーのインストール プロセスが終了しました
ump: {プラグ アンド プレイ Service: Device Install exit(c0000142)}
ndv: 新しいデバイスのデバイスのインストールに失敗しました...NULL ドライバーをインストールしています。
dvi: {プラグ アンド プレイ Service: Device Install for PCI\VEN_15AD&DEV_07B0&SUBSYS_07B015AD&REV_01\FF565000B37984FE00}

原因

この問題は、Telnet Server サービスが、実行されているウィンドウ ステーションへの初期化中にセキュリティ関連のアクセス許可を変更するためです。 デスクトップと対話することなくローカル システム アカウントを使用して実行するように Telnet Server サービスを構成した場合、サービスは別のウィンドウ ステーションで開始されます。 これにより、ローカル システム アカウントで実行され、デスクトップと対話しない他のプロセス (新しいデバイス ドライバーのインストール プロセスなど) と競合する可能性があります。

回避策

この問題を回避するには、ローカル システム アカウントで Telnet Server サービスを実行しないでください。 既定のローカル サービス アカウントで実行するには、Telnet Server サービスをそのまま使用することをお勧めします。

それでも問題が一時的に解決しない場合は、最新バージョンの VMWare Tools がインストールされていることを確認します。 VMWare Tools を更新またはアンインストールできない場合は、次の手順に従います。

  1. VMWare Tools の最新バージョンのセットアップ ファイルを取得します。

  2. [ スタート] をクリックし、[ 検索の開始 ] ボックスに「cmd」と入力し、[OK] をクリック します

    注:

    コマンド プロンプト ウィンドウが表示されます。

  3. コマンド プロンプトで、ドライブを CD-ROM ドライブ (ドライブ D など) に変更します。

  4. と入力 setup /cし、Enter キーを押してすべてのレジストリ エントリを強制的に削除し、以前のバージョンの VMware Tools を削除します。

    注:

    64 ビット ゲスト オペレーティング システムの場合は、代わりに「setup64 /c」と入力します。

  5. VMWare Tools の最新バージョンをインストールします。

  6. Telnet サービスのログオン設定が正しく設定されていることを確認します。

  7. サーバーを再起動します。

データ収集

Microsoft サポートの支援が必要な場合は、「展開関連の問題について TSS を使用して情報を収集する」に記載している手順に従って情報を収集することをお勧めします。

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