クライアントが非アクティブになり、インベントリを送信しないConfiguration Manager

この記事では、Configuration Manager クライアントが非アクティブになり、インベントリ情報が送信されない問題の解決策について説明します。

元の製品バージョン:Microsoft System Center 2012 Configuration Manager、Microsoft System Center 2012 R2 Configuration Manager
元の KB 番号: 3067633

現象

特定のサーバーまたはサーバーのサブセットに報告するクライアントConfiguration Manager、繰り返し非アクティブになる可能性があります。 また、クライアントが 30 日以上インベントリ情報を送信せず、Inventoryagent.log ファイル内のデータが静的であることにも気付く場合があります。 さらに、ClientIDManagerStartup.logは、このエラーの繰り返し発生を表示します。

[RegTask] - クライアントが登録されていません。 GUID:4874BD6C-CB98-4EEB-9F4F-721CC65B25C3 ...

[RegTask] - クライアントが登録されています。 サーバー割り当て ClientID は GUID:4874BD6C-CB98-4EEB-9F4F-721CC65B25C3 です。 承認の状態 1

SetRegistrationState が失敗しました (0x80071770)

[RegTask] - 15360 秒間スリープ中 ...

注:

エラー コード 0x80071770は、指定したファイルを暗号化できなかったことを示します。

原因

これは cng.sys の既知の問題であり、「 Microsoft セキュリティ アドバイザリ: Windows コマンド ライン監査を改善するための更新プログラム: 2015 年 2 月 10 日」で説明されている更新プログラムに関連しています。

解決方法

この問題を解決するには、 更新プログラムの3023562 または 更新3046049 を適用して、cng.sys のバージョンを更新します。 これらの更新プログラムのいずれかを適用してコンピューターを再起動すると、影響を受けるクライアントはハートビートを正常に送信し、インベントリ データを更新します。 このアクションにより、クライアントがアクティブなままになります。