リモート コンピューターから IIS マネージャーを使用してアプリケーション プールの ID を変更するとエラーが発生する: Keyset が存在しません

この記事では、 Keyset が存在しない エラーを解決します。 このエラーは、リモート コンピューターから Microsoft インターネット インフォメーション サービス (IIS) マネージャーを使用してアプリケーション プールの ID を変更するときに発生します。

元の製品バージョン: Windows Server 2008、Windows Server 2008 R2
元の KB 番号: 977754

現象

次のような状況で問題が発生します。

  • Windows Server 2008 または Windows Server 2008 R2 を実行しているサーバーでは、IIS のリモート管理を有効にします。
  • サーバーには、IIS で複数のアプリケーション プールが構成されています。
  • アプリケーション プールの 1 つは、カスタム ユーザー ID を使用するように構成されています。
  • IIS マネージャーを使用して、リモート コンピューターから管理者としてサーバーに接続します。

このシナリオでは、アプリケーション プールの ID を変更しようとすると、次のエラー メッセージが表示されます。

この操作の実行中にエラーが発生しました。
詳細:
キーセットが存在しない (HRESULT からの例外: 0x80090016)

原因

LOCAL SERVICE アカウントは、IIS Web 管理サービス (WMSvc とも呼ばれます) のサービス アカウントです。 この問題は、 LOCAL SERVICE アカウントにフォルダー内にあるキーに対する iisWasKey 読み取りアクセス権がないために %ALLUSERSPROFILE%\Microsoft\Crypto\RSA\MachineKeys 発生します。

キーのファイル名を次に iisWasKey 示します。
76944fb33636aeddb9590521c2e8815a_GUID

解決方法

この問題を解決するには、次の手順を実行します。

  1. フォルダーを %ALLUSERSPROFILE%\Microsoft\Crypto\RSA\MachineKeys 見つけます。
  2. 76944fb33636aeddb9590521c2e8815a_GUID ファイルを右クリックし、[プロパティ] を選択します
  3. [ セキュリティ ] タブを選択し、[ 編集] を選択します。 操作を続行するかどうかを確認するメッセージが表示されたら、[続行] を選択 します。 次に、このキー ファイルにアクセスできるグループ名とユーザー名の一覧が [ アクセス許可 ] ダイアログ ボックスに表示されます。
  4. [追加] を選択します。 次に、[ ユーザー、コンピューター、サービス アカウント、またはグループの選択 ] ダイアログ ボックスが表示されます。
  5. 「LOCAL SERVICE」と入力し、[名前の確認] を選択します。
  6. [OK] を選択します。
  7. [ グループ名またはユーザー名 ] の一覧 で、[LOCAL SERVICE] を選択します。 [ローカル サービスのアクセス許可] ボックスの一覧で、[読み取りチェック] ボックスがオンになっていることを確認します。
  8. [OK] をクリックします。

詳細

この問題は、Windows Server 2008 Service Pack 2 で修正されています。