Como para ligar o Microsoft Access no Word consultar documentos

Traduções de Artigos Traduções de Artigos
Artigo: 100931 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sumário

Este artigo descreve como criar uma hiperligação no Word para Windows para uma consulta do Microsoft Access. Pode ligar uma consulta do Microsoft Access ou tabela para o documento do Word, mas não é possível ligar um formulário do Microsoft Access ou o relatório.

Mais Informação

Microsoft Word para Windows 2.x e o Microsoft Access 1.x

O Microsoft Access copia uma consulta para a área de transferência no formato de texto não formatado; assim, quando liga uma consulta do Microsoft Access para o documento do Word, aparece no formato de texto delimitado por tabulações.

Uma ligação automática a uma consulta do Microsoft Access não será actualizada. Depois de criar uma ligação automática, tem de alterá-lo para uma ligação manual utilizando o comando ligações no menu Editar. Em seguida, pode utilizar o comando Actualizar ligações (no menu Editar) ou prima F9 para actualizar as informações de acesso.

Para obter mais informações sobre Editar e actualizar ligações, consulte páginas 686 690 no Word para Windows, versão 2.0, "Manual do utilizador."

Só é possível ligar uma consulta do Microsoft Access toda numa aplicação cliente. Não é possível ligar uma parte de uma consulta do Microsoft Access o documento do Word. Se copiar uma parte da consulta do Microsoft Access para ligar o documento do Word, o botão Colar ligação não está disponível e a origem é desconhecida na caixa de diálogo Colar especial no Word.

NOTAS

Em versões do Word 6.0 e 7.0 e versões do Microsoft Access 2.0 e 7.0, o campo DDEAUTO não muda para DDE depois de clicar no comando Editar ligações e seleccionar ' Manual '. Tem de editar o campo e remover AUTO.

No Word 7.0 e Microsoft Access 7.0, por predefinição o DDEAUTO campo é inserido com um parâmetro \r em vez do parâmetro \t. O parâmetro \r impede que o utilizador alterem o item especificado, tal como alterar "Todos" a "Dados". Se alterar um item para "Dados", receberá a mensagem de erro "O Word não é possível obter dados a partir de.....". Remova o \r e irá funcionar correctamente como Word 6.0. Além disso, no Word 6.0, \t para texto não formatado está incluído por predefinição; no Word 7.0 é colado texto não formatado como texto formatado.

Criar a ligação

  1. No Microsoft Access, Active a janela da base de dados.
  2. Escolha o botão consulta (ou no menu ' Ver ' seleccione consultas.)
  3. Seleccione o ícone que representa a consulta pretendida para copiar. No menu ' Editar ', escolha Copiar. (Nota: não abrir a consulta e se decidir seleccionar todos os registos do menu ' Editar '.)
  4. Mude para o Word para Windows.
  5. No menu Editar, clique em Colar especial.
  6. Na caixa Tipo de dados, seleccione o texto não formatado e, em seguida, escolha o botão Colar ligação.
NOTA: O texto não formatado é a selecção só aparece na caixa Tipo de dados.

Os passos acima criar um campo DDEAUTO no documento que pode ser apresentado, activando a códigos de campo no menu Ver. O campo DDEAUTO serão apresentadas da seguinte forma:

{DDEAUTO MSAccess "database.mdb;QUERY nomeconsulta" All \ * mergeformat \t}

Para alterar a ligação manual de modo a que serão actualizado correctamente, o menu ' Editar ' seleccionar hiperligações, seleccione a hiperligação pretendida e, em seguida, seleccionar manual em actualização. Isto irá alterar o campo DDEAUTO para um campo DDE que pode ser actualizado manualmente premindo a tecla F9.

Este campo também pode ser criado manualmente escrevendo no código de campo acima (prima CTRL+F9 para criar as chavetas de campo) e, em seguida, premindo F9 para actualizar o campo e estabelecer a ligação. A base de dados deve estar aberto para criar e actualizar a ligação com êxito.

O campo DDE ligar uma consulta do Microsoft Access também pode ser editado para especificar diferentes itens na consulta. "Tudo" é o item pedido por predefinição, quando copiar e colar a consulta no exemplo acima. No entanto, os seguintes itens podem ser utilizados em vez de "Todos" na fieldcode DDEAUTO para ligar diferentes itens na consulta:
   Item          Result
   -------------------------------------------------------------------

   All           All the data in the table including the column names.

   Data          All rows of data without the column names.

   FieldNames    A list of Columns.

   NextRow       Only the next row in the table/query. When the
                 conversation is first started, NextRow returns the
                 first row. If the current row is the last record and
                 NextRow is executed, the request will fail.

   PrevRow       Only the previous row. If PrevRow is the first
                 request ever, a new channel the last row of the
                 table/query is returned. If the current row is the
                 first record, the request for PrevRow will fail.

   FirstRow      Data in the first row of the table/query.

   LastRow       Data in the last row of the table/query.

   FieldCount    Count of columns in the table/query.

   MacroName     You may also send the name if a macro to be executed.
				
por exemplo, o campo que se segue cria uma hiperligação para os nomes dos campos na consulta lista de clientes na base de dados NWIND.MDB:

{DDE MSAccess FieldNames "Lista de clientes C:\\ACCESS\\NWIND.MDB;Query" mergeformat \t}

Referências

Word para Windows 'do utilizador Guide, versão 2.0, páginas 686 690

Propriedades

Artigo: 100931 - Última revisão: 16 de agosto de 2005 - Revisão: 2.2
A informação contida neste artigo aplica-se a:
  • Microsoft Word 2.0 Standard Edition
  • Microsoft Word 2.0a
  • Microsoft Word for Windows 2.0b
  • Microsoft Word 2.0c
  • Microsoft Word 6.0 Standard Edition
  • Microsoft Word 6.0a
  • Microsoft Word 6.0c
  • Microsoft Word 95 Standard Edition
  • Microsoft Word 95a
  • Microsoft Access 1.0 Standard Edition
  • Microsoft Access 1.1 Standard Edition
  • Microsoft Access 2.0 Standard Edition
  • Microsoft Access 95 Standard Edition
  • Microsoft Access 95 Standard Edition
Palavras-chave: 
kbmt KB100931 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 100931
Exclusão de Responsabilidade para Conteúdo sem Suporte na KB
Este artigo foi escrito sobre produtos para os quais a Microsoft já não fornece suporte. Por conseguinte, este artigo é oferecido "tal como está" e deixará de ser actualizado.

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com