Como para vincular um Microsoft Access Query in Word documento

Traduções deste artigo Traduções deste artigo
ID do artigo: 100931 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sumário

Este artigo descreve como criar um vínculo no Word para Windows para uma consulta do Microsoft Access. Você pode vincular uma tabela ou consulta do Microsoft Access para o documento do Word, mas não é possível vincular um formulário do Microsoft Access ou o relatório.

Mais Informações

Microsoft Word para Windows 2.x e do Microsoft Access 1.x

Microsoft Access copia uma consulta para a área de transferência no formato de texto não formatado; portanto, quando você vincula uma consulta do Microsoft Access a seu documento do Word, ele aparece no formato de texto delimitado por tabulação.

Uma vinculação automática a uma consulta do Microsoft Access não será atualizada. Depois de criar um vínculo automático, você deve alterá-lo a um link manual usando o comando vínculos no menu Editar. Em seguida, você pode usar o comando atualizar links (no menu Editar) ou pressione F9 para atualizar as informações de acesso.

Para mais informações sobre como editar e atualizar os vínculos, consulte páginas 686 690 no Word para Windows, versão 2.0, "Guia do usuário."

Somente é possível vincular uma consulta inteira do Microsoft Access em um aplicativo cliente. Não é possível vincular uma parte de uma consulta do Microsoft Access a seu documento do Word. Se você copiar parte de consulta do Microsoft Access para vincular a seu documento do Word, o botão Colar vínculo não estiver disponível e a fonte é desconhecido na caixa de diálogo Colar especial no Word.

ANOTAÇÕES

Em versões do Word 6.0 e 7.0 e versões do Microsoft Access 2.0 e 7.0, o campo DDEAUTO não alterar para DDE depois de clicar no comando Editar vínculos e selecione manual. Você precisará editar o campo e remover AUTO.

No Word 7.0 e Microsoft Access 7.0, por padrão o DDEAUTO campo é inserido com uma opção \r em vez da opção \t. A opção \r impede que usuários alterem o item especificado, como alterar "All" para "Dados". Se você alterar um item para "Dados", você receberá a mensagem de erro "O Word não é possível obter dados de.....". Remova o \r e ele funcionará corretamente como Word 6.0. Além disso, no Word 6.0, \t para texto não formatado é incluído por padrão; no Word 7.0 não formatado texto é colado como texto formatado.

Criar o link

  1. No Microsoft Access, ative a janela banco de dados.
  2. Escolha o botão consulta (ou no menu View escolha consultas.)
  3. Selecione o ícone que representa a consulta desejada para copiar. No menu Editar, escolha Copiar. (Observação: não abrir a consulta e escolha Selecionar todos os registros no menu Editar.)
  4. Alterne para o Word para Windows.
  5. No menu Editar, clique em Colar especial.
  6. Na caixa Tipo de dados, selecione o texto não formatado e, em seguida, escolha o botão Colar vínculo.
Observação: O texto não formatado é a seleção única que aparece na caixa Tipo de dados.

As etapas acima criam um campo DDEAUTO no documento que pode ser exibido ativando códigos de campo no menu Exibir. O campo DDEAUTO aparecerá da seguinte maneira:

{DDEAUTO MSAccess "database.mdb;QUERY queryname" All \ * mergeformat \t}

Para alterar o link para manual para que serão atualizado corretamente, no menu ' Editar ', escolha links, selecione o link desejado e escolha manual em Update. Isso irá alterar o campo DDEAUTO a um campo DDE que pode ser atualizado manualmente pressionando a tecla F9.

Este campo também pode ser criado manualmente digitando no código de campo acima (pressione CTRL+F9 para criar os colchetes do campo) e, em seguida, pressionando F9 para atualizar o campo e estabelecer o vínculo. O banco de dados deve estar aberto para criar e atualizar o vínculo com êxito.

O campo DDE vinculando uma consulta do Microsoft Access também pode ser editado para especificar itens diferentes na consulta. "All" é o item solicitado por padrão ao copiar e colar a consulta no exemplo acima. No entanto, os itens a seguir podem ser usados no lugar de "All" em fieldcode DDEAUTO para vincular itens diferentes na consulta:
   Item          Result
   -------------------------------------------------------------------

   All           All the data in the table including the column names.

   Data          All rows of data without the column names.

   FieldNames    A list of Columns.

   NextRow       Only the next row in the table/query. When the
                 conversation is first started, NextRow returns the
                 first row. If the current row is the last record and
                 NextRow is executed, the request will fail.

   PrevRow       Only the previous row. If PrevRow is the first
                 request ever, a new channel the last row of the
                 table/query is returned. If the current row is the
                 first record, the request for PrevRow will fail.

   FirstRow      Data in the first row of the table/query.

   LastRow       Data in the last row of the table/query.

   FieldCount    Count of columns in the table/query.

   MacroName     You may also send the name if a macro to be executed.
				
por exemplo, o campo a seguir cria um link para os nomes dos campos na consulta de lista de clientes no banco de dados NWIND.MDB:

{DDE MSAccess "Lista de clientes C:\\ACCESS\\NWIND.MDB;Query" FieldNames mergeformat \t}

Referências

Word para Windows "Do User Guide", versão 2.0, páginas 686 690

Propriedades

ID do artigo: 100931 - Última revisão: terça-feira, 16 de agosto de 2005 - Revisão: 2.2
A informação contida neste artigo aplica-se a:
  • Microsoft Word 2.0 Standard Edition
  • Microsoft Word 2.0a
  • Microsoft Word for Windows 2.0b
  • Microsoft Word 2.0c
  • Microsoft Word 6.0 Standard Edition
  • Microsoft Word 6.0a
  • Microsoft Word 6.0c
  • Microsoft Word 95 Standard Edition
  • Microsoft Word 95a
  • Microsoft Access 1.0 Standard Edition
  • Microsoft Access 1.1 Standard Edition
  • Microsoft Access 2.0 Standard Edition
  • Microsoft Access 95 Standard Edition
  • Microsoft Access 95 Standard Edition
Palavras-chave: 
kbmt KB100931 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 100931
Aviso de Isenção de Responsabilidade sobre Conteúdo do KB Aposentado
Este artigo trata de produtos para os quais a Microsoft não mais oferece suporte. Por esta razão, este artigo é oferecido "como está" e não será mais atualizado.

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com