Error NTVDM: Hay ningún disco en la unidad

Seleccione idioma Seleccione idioma
Id. de artículo: 102418 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Al iniciar sesión en Windows, aparece uno de los mensajes de error siguientes:

  • NTVDM - sin disco
    No hay disco en la unidad. Inserte un disco en la unidad A:

    -o bien -
  • NTVDM - sin disco
    No hay disco en la unidad. Inserte un disco en la unidad < letra de unidad >
Error de Windows NT 4.0:

  • <service> - no disco no es ningún disco en la unidad. Inserte un disco en la unidad <drive.letter> donde < letra de unidad > es una unidad de CD-ROM lógica y <service> puede ser servicios que deben iniciarse automáticamente, como SPOOLSS y SNMP.

Causa

Este problema se produce cuando la instrucción PATH en el archivo Autoexec.bat, variables de entorno del sistema de Windows NT o variables de entorno de usuario < nombre de usuario > hace referencia a una unidad de disco o unidad de CD-ROM.

Si hace referencia a un disquete o unidad de CD-ROM en el Autoexec.bat, Windows NT 4.0 no muestra el mensaje de error cuando se inicie sesión, pero se mostrará el error al ejecutar aplicaciones como Edit.com, Write.exe o Notepad.exe.

Solución

Para evitar este problema, tiene un disco en la unidad o quite la entrada de la instrucción PATH.

La letra de unidad no puede introducirse en la instrucción PATH, pero se encuentra en la siguiente ubicación del registro:
HKEY_LOCAL_MACHINE\SYSTEM\SETUP\WinntPath


Elimínelo aquí y vuelva a iniciarla.

Más información

Cuando un usuario inicia sesión en su cuenta, Windows busca un archivo Autoexec.bat en el directorio raíz de la unidad C. Si se encuentra el archivo, NTVDM.EXE anexa su variable de entorno PATH a la variable de entorno PATH del sistema. Se ve afectada sólo la variable PATH de VDM.

NTVDM comprueba la instrucción PATH de validez. Si la unidad físicamente sale, NTVDM comprueba el tipo de unidad (extraíble o fija). Si la unidad es un disquete o CD-ROM, comprueba la presencia de medios válido. Si no se encuentra ninguno, se muestra el mensaje de error. Si se utilizan las unidades no válidas en la instrucción PATH de Autoexec.bat, no se muestra ningún mensaje de error, pero la variable PATH en cualquier VDMs que se abren no será válido.

El mismo mensaje también puede aparecer si intenta iniciar una aplicación como, por ejemplo, Notepad.exe en el Administrador de programas seleccionando ejecutar en el menú de archivo.

Propiedades

Id. de artículo: 102418 - Última revisión: martes, 20 de febrero de 2007 - Versión: 2.2
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Advanced Server 3.1
  • Microsoft Windows NT Workstation 3.1
  • Microsoft Windows NT Advanced Server 3.1
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
Palabras clave: 
kbmt kbenv KB102418 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 102418

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com