NTVDM 오류: 드라이브에 디스크가 없습니다

기술 자료 번역 기술 자료 번역
기술 자료: 102418 - 이 문서가 적용되는 제품 보기.
모두 확대 | 모두 축소

현상

Windows NT에 로그온하면 다음 오류 메시지 중 하나가 나타납니다.

  • NTVDM - 디스크 없음
    드라이브에 디스크가 없습니다. A: 드라이브에 디스크를 넣으십시오.

    또는
  • NTVDM - 디스크 없음
    드라이브에 디스크가 없습니다. <drive letter> 드라이브에 디스크를 넣으십시오.
Windows NT 4.0 오류:

  • <service> - 디스크 없음. 드라이브에 디스크가 없습니다. <drive letter> 드라이브에 디스크를 넣으십시오. 여기서 <drive letter>는 논리적 CD-ROM 드라이브이고 <service>는 SPOOLSS 및 SNMP 같이 자동으로 시작되어야 하는 서비스일 수 있습니다.

원인

이 문제는 <user name>의 사용자 환경 변수, Windows NT 시스템 환경 변수 또는 AUTOEXEC.BAT 파일의 PATH 문이 플로피 디스크 드라이브나 CD-ROM 드라이브를 참조할 때 발생합니다.

AUTOEXEC.BAT에서 플로피 디스크 또는 CD-ROM 드라이브를 참조하는 경우 Windows NT 4.0은 로그온할 때 오류를 표시하지 않지만 EDIT.COM, WRITE.EXE 또는 NOTEPAD.EXE 같은 응용 프로그램을 실행할 때 오류를 표시합니다.

해결 방법

이 문제를 해결하려면 드라이브에 디스크를 넣거나 PATH 문에서 해당 항목을 제거하십시오.

드라이브 문자는 PATH 문에 입력되지 않을 수 있지만 다음 레지스트리 위치에는 나타납니다.
HKEY_LOCAL_MACHINE\SYSTEM\SETUP\WinntPath


이 레지스트리 위치에서 해당 항목을 삭제하고 다시 로그인하십시오.

추가 정보

사용자가 자신의 계정에 로그인하면 Windows NT는 C 드라이브의 루트 디렉터리에서 AUTOEXEC.BAT 파일을 검색합니다. 파일이 발견되면 NTVDM.EXE는 PATH 환경 변수를 시스템 PATH 환경 변수에 추가합니다. VDM PATH 변수만 영향을 받습니다.

NTVDM은 PATH 문의 유효성을 테스트합니다. 드라이브가 실제로 존재하는 경우 NTVDM은 드라이브 종류(이동식 미디어 또는 고정 미디어)를 테스트합니다. 드라이브가 플로피 디스크나 CD-ROM인 경우 유효한 미디어가 있는지 테스트합니다. 유효한 미디어가 없는 경우 오류 메시지가 표시됩니다. AUTOEXEC.BAT PATH 문에 잘못된 드라이브가 사용된 경우 오류 메시지는 표시되지 않지만 열려 있는 VDM의 PATH 변수가 유효하지 않게 됩니다.

프로그램 관리자의 파일 메뉴에서 실행을 선택하여 NOTEPAD.EXE 같은 응용 프로그램을 시작하려고 해도 같은 메시지가 표시될 수 있습니다.





Microsoft 제품 관련 기술 전문가들과 온라인으로 정보를 교환하시려면 Microsoft 뉴스 그룹에 참여하시기 바랍니다.

속성

기술 자료: 102418 - 마지막 검토: 2003년 7월 1일 화요일 - 수정: 2.0
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Advanced Server 3.1
  • Microsoft Windows NT Workstation 3.1
  • Microsoft Windows NT Advanced Server 3.1
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
키워드:?
kbenv KB102418

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com