Cómo cifrar una base de datos en Visual Basic de Microsoft Access

Seleccione idioma Seleccione idioma
Id. de artículo: 104875 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Resumen

Cifrado de base de datos tiene nada que ver con la seguridad. Sin embargo, puede utilizar el cifrado de base de datos para evitar que alguien utilice un editor de archivo o disco para leer y escribir datos en un archivo .mdb de Microsoft Access. En este artículo se muestra en ejemplo de cómo cifrar un archivo de base de datos de Microsoft Access en Microsoft Visual Basic versión 3.0 para Windows.

Más información

Microsoft Access lee y escribe todos los datos de una página a la vez. Cada página está siempre 2 KB de tamaño. Cifrado se realiza en el nivel de página, no en el nivel de datos. Esto significa que el proceso de cifrado no tiene conocimiento de lo que en la página, sólo que hay 2 KB de datos que necesita se cifra y se escribe. o leer y descifrar.

Todo en un archivo de base de datos de Microsoft Access .mdb se cifra, incluidos tablas, consultas, formularios, los índices y así sucesivamente. Microsoft Access utiliza el algoritmo de compañía RSA para cifrado de base de datos.

La sobrecarga implicada en cifrado y descifrado de causas es una degradación del rendimiento de aproximadamente 10-15 % en las bases de datos cifrados. Archivos cifrados no se puede comprimir mediante herramientas como PKZip, Stacker, versión de MS-DOS 6 DoubleSpace y así sucesivamente.

Cifrado en Visual Basic

Utilice la instrucción CompactDatabase en Microsoft Visual Basic versión 3.0 para Windows para cifrar un archivo de base de datos de Microsoft Access. Para obtener más información en la instrucción CompactDatabase, revise páginas 90-92 en el manual de "Referencia del lenguaje" versión 3.0 de Visual Basic.

Ejemplo paso a paso de cifrado

  1. Inicie Visual Basic o en el menú Archivo, elija Nuevo proyecto (ALT, F, N) si Visual Basic ya se está ejecutando. Se creará Form1 de manera predeterminada.
  2. En el menú Ventana, elija Administrador de datos.
  3. En el Administrador de datos, elija nueva base de datos en el menú archivo. A continuación, seleccione Microsoft Access 1.0 o 1.1 de Microsoft Access.
  4. Escriba el nombre TESTING.MDB el nombre de archivo de Microsoft Access que va a crear.
  5. Haga clic en el botón nuevo y escriba Tabla1 el nombre de la tabla.
  6. Haga clic en el botón Agregar y escriba el nombre como nombre del campo. A continuación, seleccione el texto para el tipo de campo y escriba 15 como el tamaño del campo.
  7. Haga clic en el botón Agregar para índices y escriba nombre índice como el nombre de índice. A continuación, seleccione única, principal y haga clic en Listo.
  8. Haga clic en el botón Abrir y, después, el botón Agregar. A continuación escriba un nombre (por ejemplo, Bob) en el campo nombre. A continuación, haga clic en el botón Agregar.
  9. Cierre el Administrador de datos y agregue un botón de comando a Form1.
  10. Agregue el código siguiente al procedimiento de evento Click de Command1:
        Sub Command1_Click ()
           Const DB_ENCRYPT = 2
           Const DB_LANG_GENERAL = ";LANGID=0x0809;CP=1252;COUNTRY=0"
    
           '** Enter the following two lines as one, single line:
           CompactDatabase "C:\VB\TESTING.MDB", "C:\VB\NEWTEST.MDB",
              DB_LANG_GENERAL, DB_ENCRYPT
        End Sub
    
    						
  11. En el menú Ejecutar, elija Iniciar (ALT, R, S) para ejecutar el programa. Haga clic en el botón Command1 para cifrar el archivo de base de datos TESTING.MDB. Para comprobar el nuevo archivo NEWTEST.MDB, elija Administrador de datos en el menú Ventana en la versión 3.0 de Visual Basic para Windows. En el Administrador de datos, elija Abrir base de datos en el menú de archivo. A continuación, seleccione el archivo NEWTEST.MDB.

Propiedades

Id. de artículo: 104875 - Última revisión: miércoles, 8 de enero de 2003 - Versión: 1.1
La información de este artículo se refiere a:
  • Microsoft Visual Basic 3.0 Professional Edition
Palabras clave: 
kbmt KB104875 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 104875
Renuncia a responsabilidad de los contenidos de la KB sobre productos a los que ya no se ofrece asistencia alguna
El presente artículo se escribió para productos para los que Microsoft ya no ofrece soporte técnico. Por tanto, el presente artículo se ofrece "tal cual" y no será actualizado.

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com