Mensagem de erro: Não há Processadores de Impressão... Criando uma Impressora

Traduções deste artigo Traduções deste artigo
ID do artigo: 105247 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Sintomas

Ao tentar instalar uma impressora no Windows NT, você poderá receber uma das seguintes mensagens de erro:

  • Não há processadores de impressão
  • Processador de Impressão é desconhecido

Causa

Esse comportamento pode ocorrer se todas as seguintes condições existirem:

  • Nenhum processador de impressão é especificado no registro do Windows NT.
  • O arquivo do processador de impressão (Winprint.dll) está ausente ou corrompido.

Resolução

Para resolver o problema, execute estas etapas:

  1. Verifique se o arquivo Winprint.dll existe na seguinte pasta:

    %SystemRoot%\system32\spool\prtprocs\w32x86

    Se o arquivo Winprint.dll estiver ausente, use o comando a seguir para expandir o arquivo Winprint.dl_ no seu CD-ROM de instalação do Windows NT ou nos discos de instalação para o Winprint.dll na pasta acima:

    expand x:\i386\winprint.dl_ c:\winnt\system32\spool\prtprocs\w32x86\winprint.dll

    onde x: é a letra da unidade da sua unidade de CD-ROM.
  2. Verifique se o processador de impressão está configurado corretamente no Registro do Windows NT. Para fazer isto, execute as etapas a seguir:

    AVISO: Ao usar o Editor do Registro incorretamente pode causar problemas sérios no sistema inteiro que podem necessitar da reinstalação do Windows NT para corrigi-los. A Microsoft não garante que qualquer problema resultante do uso do Editor de Registro possa ser resolvido. O uso dessa ferramenta é de sua responsabilidade.

    a. Localize a seguinte chave no Registro do Windows NT:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print \Environments\Windows NT x86\Print Processors\winprint

    Se a chave Winprint não estiver presente, crie-a clicando em Adicionar chave no menu Editar. Se o Winprint.dll não for especificado como o valor do Driver na chave Winprint, clique em Adicionar valor no menu Editar para criar o valor do Driver usando as seguintes configurações:

    Driver:REG_SZ:winprint.dll

    OBSERVAÇÃO: Talvez seja necessário reiniciar o computador após fazer essas alterações.
Observação: este é um artigo de ?PUBLICAÇÃO RÁPIDA? criado diretamente pela organização de suporte da Microsoft. As informações aqui contidas são fornecidas no presente estado, em resposta a questões emergentes. Como resultado da velocidade de disponibilização, os materiais podem incluir erros tipográficos e poderão ser revisados a qualquer momento, sem aviso prévio. Consulte os Termos de Uso para ver outras informações.

Propriedades

ID do artigo: 105247 - Última revisão: terça-feira, 2 de julho de 2013 - Revisão: 1.0
A informação contida neste artigo aplica-se a:
  • Microsoft Windows NT Workstation 3.1
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
Palavras-chave: 
kbprint KB105247

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com