Mensaje de error: "no hay suficientes servidores de almacenamiento de información está disponible para procesar este comando"

Seleccione idioma Seleccione idioma
Id. de artículo: 106167 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Cuando tiene acceso a los elementos compartidos en un servidor Windows NT desde un cliente Windows NT, puede aparece el mensaje siguiente:
No hay suficientes servidores de almacenamiento de información está disponible para procesar este comando.
También pueden anotarse los sucesos siguientes:

ID. de suceso: 2011

ID. de suceso: 2011
Origen: Srv
Parámetro de configuración del servidor "irpstacksize" es demasiado pequeño para el servidor utilice un dispositivo local. Aumente el valor de este parámetro.

ID. de suceso: 0

ID. de suceso: 0
Origen: SRV
Descripción: No se puede encontrar la descripción del ID. Lo contiene la cadena de inserción \device\LanManServer

Causa

Este problema puede producirse si la entrada de registro de IRPStackSize en el servidor se establece demasiado baja.

Solución

Importante Esta sección, el método o la tarea contiene pasos que le indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de que sigue estos pasos cuidadosamente. Para mayor protección, hacer la copia del registro antes de modificarlo. A continuación, puede restaurar el registro si surge algún problema. Para obtener más información acerca de cómo realizar copias de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 Cómo hacer copia de seguridad y restaurar el registro en Windows


Para resolver este problema, aumente el valor de la entrada del registro IRPStackSize. Para ello, siga estos pasos:
  1. Haga clic en Inicio, haga clic en Ejecutar, tipo Regedity, a continuación, haga clic en ACEPTAR.
  2. Busque y, a continuación, haga clic en la siguiente subclave del registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
    Si la entrada de IRPStackSize no está presente en esta subclave, siga estos pasos:
    1. Haga clic en Editar, seleccione Nuevoy, a continuación, haga clic en Valor DWORD.
    2. Tipo IRPStackSize, y, a continuación, presione ENTRAR.

      NotaTipo IRPStackSizetal y como aparece. El nombre de valor es entre mayúsculas y minúsculas.
  3. Haga clic en IRPStackSize, haga clic en Editary, a continuación, haga clic en Modificar.
  4. En el Valor de datos Escriba un valor mayor y, a continuación, haga clic en ACEPTAR.

    Nota Los valores pueden oscilar entre 0 x 1 a 0xC. Estos valores equivalen a 1 y 12 en notación decimal.
Si el problema persiste después de completar el procedimiento anterior, aumente el valor de IRPStackSize más.

Más información

Si la entrada de registro IRPStackSize no está presente, el equipo utiliza un valor predeterminado de 0 x 4. Dependiendo de la configuración del hardware del equipo, este valor predeterminado puede no se lo suficientemente grande como para el servicio Srv administre compartir carpetas en algunas de las unidades físicas. Cuando un cliente de Windows para trabajo en grupo intenta obtener acceso a estos compartida directorios, recibirá el siguiente mensaje:
No se encontró la ruta de acceso.
Si aparece este mensaje de error, aumente gradualmente la valor de IRPStackSize con el fin de encontrar el valor mínimo que se resuelve el problema. Utilizando un valor que es mayor de lo necesario puede malgastar los recursos del sistema. Otros factores también pueden dar lugar a esta mensaje de error. Si el problema persiste después de haber utilizado todos los valores válidos para IRPStackSize, restaurar IRPStackSize a su valor original y buscar otra explicación para el error.

Si recibe este mensaje de error y está ejecutando Microsoft Windows NT 4.0, consulte el artículo siguiente en Microsoft Knowledge Base:
198386 Cambios en el tamaño de pila IRP en Lanman server

Propiedades

Id. de artículo: 106167 - Última revisión: jueves, 5 de julio de 2012 - Versión: 7.0
La información de este artículo se refiere a:
  • Microsoft Windows NT Workstation 3.1
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Server 3.51
Palabras clave: 
kbnetwork kbprb kbmt KB106167 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 106167

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com