Word 如何建立和復原自動回復檔案

文章翻譯 文章翻譯
文章編號: 107686 - 檢視此文章適用的產品。
全部展開 | 全部摺疊

在此頁中

結論

本文將告訴您,選取 [每 <n> 分鐘儲存一次自動回復資訊] 核取方塊之後,Microsoft Word 如何建立和復原自動回復 (.asd) 檔案 (在 Word 7.x 中為「自動儲存」)(如果要找出這個選項,請按一下 [工具] 功能表上的 [選項],再按一下 [儲存] 索引標籤)。

其他相關資訊

注意「自動回復」或「自動儲存」並不能取代 [儲存檔案] 指令。您應該定期及在結束使用文件時使用 [儲存檔案] 指令儲存文件。

「自動回復」只能用於意外的中斷,例如停電或當機。在執行排程的登出或正常關機時,不會儲存自動回復檔案。

設定 .asd 檔案的位置

如果您沒有設定自動回復檔案的位置,Word 便會將自動回復檔案放在暫存目錄中。

如果要設定 .asd 位置,請依照下列步驟執行:
  1. [工具] 功能表上,按一下 [選項],然後按一下 [檔案位置] 索引標籤。

    注意 在 Word 2007 中,請依照下列步驟開啟 [檔案位置] 對話方塊:
    1. 按一下 [Microsoft Office 按鈕],然後按一下 [Word 選項]
    2. 在左邊窗格中,按一下 [進階]
    3. 在右窗格中,按一下 [一般] 區段下的 [檔案位置]
  2. [檔案類型] 方塊中,按一下 [自動回復檔案]

    注意 在 Word 7.x 中,請按一下 [自動儲存]
  3. 按一下 [修改]
  4. 輸入您希望 Word 儲存所復原文件的資料夾名稱。
  5. 如果需要新的資料夾位置,請按一下 [建立新資料夾],輸入新的資料夾名稱,按一下 [確定],然後按一下 [確定] 結束。

命名慣例

Word 97 和更新版的 Word:Word 自動回復檔案的命名慣例為「儲存自動回復 <document name>.asd」,其中的 <document name> 是文件的檔案名稱。

Word 7.x:Word 自動儲存檔案的命名慣例為 ~Wra####.asd,其中 #### 是 Windows 隨機產生的號碼。

開啟儲存的檔案

當您啟動 Word 時,Word 會搜尋任何 .asd 檔案。如果 Word 找到檔案,就會執行下列操作:
  1. 將每個 .asd 檔案重新命名為 <document name>.wbk。在 Word 7.0 SR-2 或更新版本中,副檔名為 .wbk。

    注意:由於 Word 會避免任何與現有 .bak 檔案衝突的名稱,因此,#### 號碼不一定與 .asd 檔名相同。
  2. 開啟所有自動回復檔案。
  3. 當您執行下列任一操作時,請刪除自動回復檔案 (「儲存自動回復 <document name>.wbk」或 ~Wra####.bak 檔案):

    儲存復原的檔案。
    -或-
    關閉復原的檔案而不儲存。

重新命名檔案的時候

當程式在開啟自動回復檔案時擱置 (停止回應),Word 會重新命名自動回復檔案。當 Word 下次啟動時,您會看到下列徵狀。

Microsoft Office Word 2007、Microsoft Office Word 2003 和 Microsoft Word 2002

Word 啟動時會開啟 [文件復原] 工作窗格,其中列出 Word 復原的可用檔案。檔名後面會是狀態指示器,其中顯示回復期間對檔案執行過的操作。「原始」狀態代表原始的檔案,為上次手動儲存的那一個版本。「復原」狀態是指,在回復程序期間復原的檔案,或者在「自動回復」儲存程序期間儲存的檔案。[文件復原] 工作窗格可以讓您開啟檔案、檢視執行過的修復,並且比較復原的版本。接著,您可以儲存想要使用的版本並刪除其他版本,或者儲存所有開啟的檔案以供日後檢視。

Word 2000

Word 會啟動。如果 Word 能夠偵測到復原的檔案,則 Word 啟動時將會開啟文件。在標題列中,文件的名稱為 <original filename> (復原)。接著,您可以選擇將檔案儲存回原始名稱或其他名稱。

Word 97

Word 在開啟 <filename> 時發現檔案有毀損。此文件的部分可能可以回復。嘗試現在復原嗎?
如果您按下 [是],Word 會嘗試復原所有或部分檔案。如果您按下 [否],.wbk 檔案仍會留在自動回復目錄中。

Word 7.x

當程式在開啟自動儲存檔案時擱置 (停止回應),Word 會重新命名自動儲存檔案。如果發生會毀損自動儲存檔案的問題,您仍然可以使用位於自動儲存目錄的 ~Wra####.bak 檔案復原您的工作。

Word 並不會在重新命名您的 .asd 檔案後自動開啟 .bak 檔案,所以您必須按一下 [檔案] 功能表上的 [開啟舊檔] 手動開啟檔案。如果要列出所有 .bak 檔案,請在 [檔案名稱] 方塊中輸入 ~wra*.bak
注意 :本文屬於「快速發佈」文章,係由 Microsoft 技術支援或組織內部直接建立。 本文所包含的資訊是為了回應新問題而依現況提供。 因此為了迅速對外發佈,文章內容可能含有印刷錯誤,而且可能會在不另行通知的情況下進行修改。 如需其他考量事項,請參閱使用規定

屬性

文章編號: 107686 - 上次校閱: 2013年3月29日 - 版次: 1.0
這篇文章中的資訊適用於:
  • Microsoft Office Word 2007
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
  • Microsoft Word 97 Standard Edition
  • Microsoft Word 95a
關鍵字:?
KB107686
Microsoft及(或)其供應商不就任何在本伺服器上發表的文字資料及其相關圖表資訊的恰當性作任何承諾。所有文字資料及其相關圖表均以「現狀」供應,不負任何擔保責任。Microsoft及(或)其供應商謹此聲明,不負任何對與此資訊有關之擔保責任,包括關於適售性、適用於某一特定用途、權利或不侵權的明示或默示擔保責任。Microsoft及(或)其供應商無論如何不對因或與使用本伺服器上資訊或與資訊的實行有關而引起的契約、過失或其他侵權行為之訴訟中的特別的、間接的、衍生性的損害或任何因使用而喪失所導致的之損害、資料或利潤負任何責任。

提供意見

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com