Article ID: 119837 - Last Review: January 19, 2007 - Revision: 2.3

OFF: Setup Program Keeps Requesting Disk 2

This article was previously published under Q119837

On This Page

Expand all | Collapse all

SYMPTOMS

When you run the Setup program for one of the programs listed at the beginning of this article from floppy disks, after you remove Disk 1, insert Disk 2, and press ENTER, Setup repeatedly prompts you to insert Disk 2 again.

CAUSE

This behavior occurs if the information from the disk in the floppy disk drive (Disk 1) that has been cached in random access memory (RAM) is not flushed when you insert the next disk (Disk 2). The operating system, MS- DOS or Microsoft Windows, is still reading Disk 1, even though you have inserted Disk 2 in the drive.

WORKAROUND

To work around this behavior, use one of the following methods:

Method 1: MS-DOS DRIVPARM Solution



Use a text editor to open the CONFIG.SYS file. Place the DRIVPARM command in the CONFIG.SYS file with the following syntax:
   For a 1.44-MB A: drive      For a 1.44-MB B: drive
   --------------------------------------------------
   DRIVPARM=/d:0 /f:7          DRIVPARM=/d:1 /f:7
NOTE: You must reboot your computer after you modify the Config.sys file.

Method 2: Reset the Floppy Disk Drive

To reset the floppy drive, remove Setup Disk 2 and press ENTER. Insert the same disk in the drive again and press ENTER.

Method 3: Refresh the File List

With Setup Disk 2 in the floppy disk drive, do the following:

Microsoft Windows 95

  1. On the Windows taskbar, click Start. Click Programs, and then click Windows Explorer.
  2. In Windows Explorer, click the drive that contains the Setup disk (for example, A) and press F5 to refresh the list of files displayed in the folder window. (If this doesn't work work, you may need to click another disk drive and then switch back to the drive that contains the Setup disk).
  3. Press ALT+TAB to switch back to the Setup program and continue installing the application.

Microsoft Windows 3.x

  1. Press ALT+TAB to switch to File Manager (or to Program Manager, and then run File Manager).
  2. Select the drive that contains the Setup disk (for example, A) and press F5 to update the directory window. (If this doesn't work, you may need to select another disk drive and then switch back to the drive that contains the Setup disk).
  3. Press ALT+TAB to switch back to the Setup program and continue installing the application.

Method 4: Reread the Tree at MS-DOS Prompt

If the options above do not correct the problem you can force the tree to be reread by using the following steps:
  1. Switch to or start an MS-DOS prompt.
  2. At the MS-DOS prompt, change to the installation drive.
  3. Press CTRL+C to clear the cache and force MS-DOS to reread the tree.
  4. Type exit to exit MS-DOS and return to Windows.
  5. Press ALT+TAB (if necessary) to return to the Setup program and continue installing the application.

    Note: You may have to repeat this process between each disk change.

MORE INFORMATION

For more information, please see the following article(s) in the Microsoft Knowledge Base: 79207  (http://support.microsoft.com/kb/79207/EN-US/ ) WinWord Setup Fails on Disk 2; DRIVPARM Solution 124970  (http://support.microsoft.com/kb/124970/EN-US/ ) OFF: Troubleshooting DMF Issues

APPLIES TO
  • Microsoft Access 97 Standard Edition
  • Microsoft Access 2.0 Standard Edition
  • Microsoft Access 95 Standard Edition
  • Microsoft Excel 97 Standard Edition
  • Microsoft Excel 95 Standard Edition
  • Microsoft Excel 5.0 Standard Edition
  • Microsoft Excel 5.0c
  • Microsoft Office 97 Standard Edition
  • Microsoft Office 95 Standard Edition
  • Microsoft Office 4.0 Standard Edition
  • Microsoft Office 4.2 Standard Edition
  • Microsoft Office 4.3 Standard Edition
  • Microsoft PowerPoint 97 Standard Edition
  • Microsoft PowerPoint 95 Standard Edition
  • Microsoft PowerPoint 4.0 Standard Edition
  • Microsoft Project 98 Standard Edition
  • Microsoft Project 4.1 Standard Edition
  • Microsoft Project 4.0 Standard Edition
  • Microsoft Visual FoxPro 3.0 Standard Edition
  • Microsoft Word 97 Standard Edition
  • Microsoft Word 95 Standard Edition
  • Microsoft Word 6.0 Standard Edition
  • Microsoft Word 6.0a
  • Microsoft Works 3.0 Standard Edition
  • Microsoft Works 4.0 Standard Edition
Keywords: 
kbprb kbsetup kbtshoot KB119837
 

Article Translations

 

Related Support Centers