"Windows NT nemohol spustiť...Ntoskrnl.exe"chybové hlásenie

Preklady článku Preklady článku
ID článku: 124550 - Zobraziť produkty, ktorých sa tento článok týka.
Verzia tohto článku pre systém Microsoft Windows XP je dostupná pod číslom 314477.
Rozbaliť všetko | Zbaliť všetko

Na tejto stránke

PRIZNAKY

Pri pokuse o spustenie systému Microsoft Windows NT, môže sa zobraziť nasledovná chyba Správa:
Windows NT sa nemohol spustiť, pretože nasledovný súbor chýba alebo skorumpovanej:

Winnt_root\System32\Ntoskrnl.exe

Please re-install a copy of the above file.

PRICINA

Toto správanie sa môže vyskytnúť, ak vykazujú akýkoľvek z týchto podmienok:
  • Predvolená hodnota v sekcii [Boot Loader] súboru Boot.ini, je chýba alebo je neplatná.
  • Systém Windows NT nie je nainštalovaný v umiestnení určenom v súbore Boot.ini súbor.
  • Pre systém Microsoft Windows 2000, Hal.dll súbor môže byť poškodený alebo chýba.
POZNÁMKA: Tento problém môže vyskytnúť aj v systéme Windows NT 4.0 a 3.5 systémovú oblasť je väčšia než 7,8 GB a zavádzacie súbory systému majú byť umiestnené mimo limit 7,8 GB (možná z dôvodu uplatňovania service pack alebo defragmentáciu jednotky). Windows XP nemá toto obmedzenie. Toto je obmedzenie hardvéru a nastane nezávisle od operačného systému. To by nemali byť problémom na novšom počítači, ktorý je predvolene, ak ich BIOS podporuje INT13 rozšírenia a táto funkcia je zapnutá.

Ďalšie informácie získate po kliknutí na nasledujúce číslo článku databázy Microsoft Knowledge Base:
224526Windows NT 4.0 podporuje maximálne 7,8 GB systémovej oblasti

RIESENIE

Ak chcete tento problém odstrániť, použite jednu z nasledovných metód:

Metóda One

Spustenie operačného systému s spúšťaciu disketu. Po spustení operačného systému, upraviť predvolené položky v Boot.ini a zabezpečiť, že ostatné položky v sekcii [Operating Systems] poukazujú na príslušné adresáre.

Dve metódy

Používanie procesu vykonávania opráv na opravu nekonzistencií v súbore Boot.ini. Vykonaná akcia tak urobiť, postupujte nasledovne:
  1. Spustite počítač pomocou troch diskety Windows NT Setup. Po zobrazení výzvy zadajte r začať proces opravy.
  2. Vložte núdze Repair Disk (ERD) v disketovej jednotky po zobrazení výzvy.
  3. Keď sa zobrazí výzva, len skontrolovať spúšťacie prostredie na zapnúť možnosť opravu nekonzistencií v súbore Boot.ini.
  4. Postupujte podľa pokynov na obrazovke dokončite proces opravy.

Metódy tri

Ak zistíte, že je systémová oblasť väčšiu než 7,8 GB, systém Windows NT bol v nepodporovanú konfiguráciu nastavení a jednotka bude musieť byť jeho veľkosť menšia než 7,8 GB.

Metóda štyri (Windows 2000)

Opraviť poškodený Hal.dll súbor Hal.dll súbor obnoviť zo zálohy do priečinka %windir%\sytem32\.

Ďalšie informácie o ako opraviť poškodený Hal.dll súbor, po kliknutí na nasledovné číslo článku databázy Microsoft Knowledge Base:
237556Riešenie problémov Windows 2000 hardvéru abstraction layer

DALSIE INFORMACIE

Ak je predvolená hodnota v sekcii [Boot Loader] súboru Boot.ini chýba, Windows NT zobrazí nová položka v OS Loader (zavadec) menu s názvom "NT (predvolené)" a predvolené na nový záznam. "NT (predvolené) "body vstupu do nasledovnú cestu na načítanie systému Windows NT:

   multi(0)disk(0)rdisk(0)partition(1)\WINNT
				
Ďalšie informácie o súbore Boot.ini, po kliknutí na nasledovné číslo článku databázy Microsoft Knowledge Base:
102873Boot.ini a ciest ARC a ich názvové konvencie využitie

Vlastnosti

ID článku: 124550 - Posledná kontrola: 10. októbra 2011 - Revízia: 2.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
Kľúčové slová: 
kberrmsg kbmt KB124550 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok bol preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft, nie prekladateľom. Spoločnosť Microsoft ponúka články preložené prekladateľmi aj strojovo preložené články, vďaka čomu máte možnosť prístupu ku všetkým článkom databázy Knowledge Base vo svojom jazyku. Strojovo preložený článok však nie je vždy perfektný. Môže obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky, podobne ako cudzinec môže robiť chyby, keď rozpráva vašim jazykom. Spoločnosť Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené akýmkoľvek nepresným prekladom obsahu alebo jeho použitím zo strany zákazníkov. Spoločnosť Microsoft softvér na strojový preklad pravidelne aktualizuje.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem:124550

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com