ข้อความแสดงข้อผิดพลาด "Windows nt ไม่ไม่เริ่ม... ntoskrnl.exe ที่ได้รับ"

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 124550 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
หากต้องการดูบทความนี้สำหรับรุ่น Microsoft Windows XP โปรดดูที่314477.
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

เมื่อคุณพยายามเริ่มการทำงานของ Microsoft Windows NT คุณอาจได้รับข้อความแสดงข้อความแสดงข้อผิดพลาดต่อไปนี้:
Windows NT could not start because the following file is missing or corrupt::

Winnt_root\System32\Ntoskrnl.exe

Please re-install a copy of the above file.

สาเหตุ

ลักษณะการทำงานนี้อาจเกิดขึ้นได้หากเงื่อนไขต่อไปนี้ใด ๆ ที่มีอยู่:
  • ค่าเริ่มต้นในส่วน [ตัวโหลดการบูต] ของแฟ้ม Boot.ini จะหายไป หรือไม่ถูกต้อง
  • ไม่มีการติดตั้ง windows NT ในตำแหน่งที่ตั้งที่ระบุในแฟ้ม Boot.ini
  • สำหรับ Microsoft Windows 2000 แฟ้ม Hal.dll อาจเสียหาย หรือสูญหาย
หมายเหตุ:: ปัญหานี้ยังสามารถเกิดขึ้นใน Windows NT 4.0 และ 3.5 ถ้าพาร์ติชันระบบมีขนาดใหญ่กว่ากิกะไบต์ 7.8 และไฟล์บูตของระบบจะเก็บอยู่ภายนอกของวงเงินกิกะไบต์ 7.8 (อาจเป็นผลมาจากการใช้เซอร์วิสแพ็ค หรือการจัดเรียงข้อมูลไดรฟ์) windows XP ไม่มีข้อจำกัดนี้ ไม่มีข้อจำกัดของฮาร์ดแวร์ และเกิดต่างหากของระบบปฏิบัติการ นี้ไม่ควรเป็นหัวข้อในคอมพิวเตอร์รุ่นใหม่ที่มี โดยค่าเริ่มต้นถ้า BIOS ของพวกเขาสนับสนุนส่วนขยาย INT13 และลักษณะการทำงานนี้เปิดอยู่

สำหรับข้อมูลเพิ่มเติม ให้คลิกหมายเลขบทความต่อไปนี้ เพื่อดูบทความในฐานความรู้ของ Microsoft::
224526windows NT 4.0 สนับสนุนสูงสุดของพาร์ติชันระบบ 7.8 กิกะไบต์

การแก้ไข

เมื่อต้องการแก้ไขปัญหา ให้ใช้วิธีการอย่างใดอย่างหนึ่งต่อไปนี้:

วิธีที่ 1

เริ่มระบบปฏิบัติการ โดยใช้ดิสก์ที่ใช้เริ่มระบบได้ หลังจากที่คุณเริ่มระบบปฏิบัติการ แก้ไขรายการเป็นค่าเริ่มต้นใน Boot.ini และให้แน่ใจว่า รายการอื่น ๆ ในส่วน [ระบบปฏิบัติการ] ชี้ไปที่ไดเรกทอรีที่เหมาะสม

วิธีที่สอง

ใช้กระบวนการซ่อมแซมเพื่อแก้ไขไม่สอดคล้องกันในแฟ้ม Boot.ini โดยให้ทำตามขั้นตอนต่อไปนี้:
  1. เริ่มการทำงานคอมพิวเตอร์ของคุณโดยใช้แผ่นดิสก์การติดตั้ง Windows NT สาม เมื่อได้รับการพร้อมท์ พิมพ์ R เพื่อเริ่มกระบวนการซ่อมแซม
  2. แทรก Emergency ซ่อมแซม Disk (ERD) ในไดรฟ์ฟล็อปปี้ดิสก์เมื่อคุณได้รับการพร้อมท์
  3. เมื่อได้รับการพร้อมท์ เปิดใช้งานเท่านั้นตรวจสอบสภาพแวดล้อมเริ่มต้นตัวแก้ไขไม่สอดคล้องกันในแฟ้ม Boot.ini
  4. ทำตามคำแนะนำบนหน้าจอเพื่อทำกระบวนการซ่อมแซม

วิธีการสาม

ถ้าคุณกำหนดพาร์ติชันระบบมีขนาดใหญ่กว่า 7.8 GB, Windows NT ได้ถูกเซ็ตอัพในการกำหนดค่าที่ไม่สนับสนุน และไดรฟ์จะต้องสามารถ repartitioned จะมีขนาดน้อยกว่า 7.8 กิกะไบต์

วิธีการสี่ (Windows 2000)

เมื่อต้องการแก้ไขแฟ้ม Hal.dll เสียหาย คืนแฟ้ม Hal.dll จากการสำรองข้อมูลไปยังโฟลเดอร์ %windir%\sytem32\

For additional information about how to fix a corrupted Hal.dll file, click the following article number to view the article in the Microsoft Knowledge Base:
237556How to troubleshoot Windows 2000 hardware abstraction layer issues

ข้อมูลเพิ่มเติม

If the Default value in the [Boot Loader] section of the Boot.ini file is missing, Windows NT displays a new entry in the OS Loader (boot loader) menu named "NT (default)" and defaults to the new entry. The "NT (default)" entry points to the following path to load Windows NT:

   multi(0)disk(0)rdisk(0)partition(1)\WINNT
				
For additional information about the Boot.ini file, click the following article number to view the article in the Microsoft Knowledge Base:
102873Boot.Ini and ARC path naming conventions and usage

คุณสมบัติ

หมายเลขบทความ (Article ID): 124550 - รีวิวครั้งสุดท้าย: 11 กันยายน 2554 - Revision: 3.0
ใช้กับ
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
Keywords: 
kberrmsg kbmt KB124550 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:124550

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com