Article ID: 127730 - Last Review: October 30, 2006 - Revision: 3.1

PROFS: SoftSwitch Gateway Hangs on Large Attachments

This article was previously published under Q127730
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SYMPTOMS

The SoftSwitch gateway may stop working when it receives attachments larger than 32K.

CAUSE

The Microsoft Mail Gateway to IBM PROFS and OfficeVision sends attachments larger than 32K. However, SoftSwitch cannot process 64K attachments.

RESOLUTION

To limit the size of the attachments sent to SoftSwitch, change all of the LRECL values in the LAN_HOST DATA file on MS-GATE 193 from 65535 (64K - 1) to 32767 (32K - 1).

MORE INFORMATION

The IBM PROFS and OfficeVision specification defines 32K attachments. The Microsoft Mail Gateway to IBM PROFS and OfficeVision supports 64K attachments.

The Microsoft Mail Gateway to PROFS Host Access component was written to work the way the PROFS and OfficeVision code works, and supports 64K attachments.

Because SoftSwitch was written to support the PROFS and OfficeVision specification, SoftSwitch cannot process 64K attachments.

Therefore, the size of the attachments sent from PROFS and OfficeVision to SoftSwitch needs to be limited to 32K.

APPLIES TO
  • Microsoft Mail Gateway for IBM PROFS and OfficeVision 3.4a
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KB127730
Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
 

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