Article ID: 129148 - Last Review: October 23, 2003 - Revision: 3.0

Error 33 on Alternate RPC Calls

This article was previously published under Q129148
Expand all | Collapse all

SYMPTOMS

Every other RPC call fails when RPC applications are running on Windows and Windows for Workgroup clients. If the failed RPC call is issued a second time, it completes successfully.

CAUSE

Some DCE compliant RPC servers shutdown the RPC connection after a period of inactivity. The 16-bit Windows RPC client does not respond to the shutdown request. This prevents the client from cleanly closing the connection to the RPC server. After an extended period of time, the RPC server closes the connection even if the 16-bit RPC client does not respond.

STATUS

Microsoft has confirmed this to be a problem in the RPC16C3.DLL file that ships with Windows NT version 3.5 SDK. A fix to this problem is in development, but has not been regression-tested and may be destabilizing in production environments. Microsoft does not recommend implementing this fix at this time. Contact Microsoft Product Support Services for more information on the availability of this fix.

APPLIES TO
  • Microsoft LAN Manager 2.2 Standard Edition
  • Microsoft Windows for Workgroups 3.11
Keywords: 
KB129148
Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
 

Article Translations