DriveSpace を使用した後にコンピュータが再起動ループから抜けられなくなる

文書翻訳 文書翻訳
文書番号: 130018 - 対象製品
この記事は、以前は次の ID で公開されていました: JP130018
すべて展開する | すべて折りたたむ

現象

DriveSpace を使用してドライブを圧縮すると、コンピュータが 再起動 ループから抜け出せなくなることがあります。コンピュータを再起動したときに F8 キーを押して、[Command Prompt Only] を選択すると、コンピュータが再び再起動ループに入ります。[Step-By-Step Confirmation] を選択すると、Windows 95 を起動できます。ただし、DriveSpace を実行すると、コンピュータは再び再起動ループに入ります。

原因

以下のいずれかに該当する場合、この問題が発生する可能性があります。
  • Msdos.sys ファイルに "DRVSpace=0" または "DBLSpace=0" という設定が存在します。
  • Drvspace.bin ファイルまたは Dblspace.bin ファイルが破損しており、起動時にファイルが読み込まれませんでした。
  • EMM386 メモリ マネージャを読み込んでおり、E000 以下の範囲を使用しています。この問題は Compaq Deskpro 386/20e コンピュータで発生しており、他のコンピュータでも発生する可能性があります。

解決方法

この問題を解決するには、次の手順を実行します。
  1. Msdos.sys ファイルに "DRVSpace=0" または "DBLSpace=0" という設定が存在する場合は、行の先頭にセミコロン (;) を挿入して設定を無効にします。次に例を示します。
          ;DRVSpace=0
     
    

    Msdos.sys ファイルの編集方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) の資料を参照してください。
    文書番号 : 118579
    タイトル : Contents of the Windows Msdos.sys File

    Msdos.sys ファイルに "DRVSpace=0" または "DBLSpace=0" という設定が存在しない場合、またはこの手順によって問題を解決できない場合は、次の手順に進みます。
  2. 既存の Drvspace.bin ファイルと Dblspace.bin ファイルの名前を変更し、インストール元の Windows 95 ディスクまたは CD-ROM から新しくこれらのファイルをコピーします。この操作を行うには、以下の手順に従います。

    1. コンピュータを再起動します。"Starting Windows 95" メッセージが表示されたところで F8 キーを押し、[Startup Menu] で [Safe Mode Command Prompt Only] を選択します。
    2. 物理ブート ドライブ (通常、ドライブ C または、ドライブ C が圧縮されている場合はドライブ C のホスト) 上の隠しフォルダ Failsafe.drv から Restart.drv ファイルを削除します。この操作を行うには、コマンド プロンプトで次のコマンドを入力します。
      deltree <drive>:\failsafe.drv\restart.drv
      ここで <drive> は、物理ブート ドライブです。
    3. 物理ブート ドライブ (通常、ドライブ C またはドライブ C が圧縮されている場合はドライブ C のホスト) 上の隠しフォルダ Failsafe.drv から Autoexec.bat ファイルと Config.sys ファイルをドライブ C のルート フォルダにコピーし、既存のファイルを上書きします。この操作を行うには、コマンド プロンプトで次のコマンドを入力します。
      copy <drive>:\failsafe.drv\autoexec.bat c:\ /y
      copy <drive>:\failsafe.drv\config.sys c:\ /y
      ここで <drive> は、物理ブート ドライブです。
    4. 物理ブート ドライブ (通常、ドライブ C またはドライブ C が圧縮されている場合はドライブ C のホスト) のルート フォルダに存在する Drvspace.bin ファイルと Dblspace.bin ファイルから Read-Only 属性、System 属性、と Hidden 属性を削除します。この操作を行うには、コマンド プロンプトで次のコマンドを入力します。
      attrib -r -s -h *.bin
    5. 物理ブート ドライブ (通常、ドライブ C またはドライブ C が圧縮されている場合はドライブ C のホスト) のルート フォルダに存在する Drvspace.bin ファイルと Dblspace.bin ファイルの名前を変更します。この操作を行うには、コマンド プロンプトで次のコマンドを入力します。
      ren *.bin *.bix
    6. Microsoft Plus! を使用している場合は、インストール元の Microsoft Plus! ディスクまたは CD-ROM から Drvspace.bin ファイルを物理ブート ドライブ (通常、ドライブ C またはドライブ C が圧縮されている場合はドライブ C のホスト) のルート フォルダに展開します。

      Microsoft Plus! を使用していない場合は、インストール元の Windows 95 ディスクまたは CD-ROM から Drvspace.bin ファイルを物理ブート ドライブ (通常、ドライブ C またはドライブ C が圧縮されている場合はドライブ C のホスト) のルート フォルダに展開します。

      OEM Service Release 2 を使用している場合は、インストール元の OEM Service Release 2 ディスクまたは CD-ROM から Drvspace.bin ファイルを物理ブート ドライブ (通常、ドライブ C またはドライブ C が圧縮されている場合はドライブ C のホスト) のルート フォルダに展開します。

      Extract ツールの使用の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) の資料を参照してください。
      文書番号 : 129605
      タイトル : How to Extract Original Compressed Windows Files
    7. 物理ブート ドライブ (通常、ドライブ C またはドライブ C が圧縮されている場合はドライブ C のホスト) のルート フォルダに存在する Drvspace.bin ファイルを、物理ブート ドライブ (通常、ドライブ C またはドライブ C が圧縮されている場合はドライブ C のホスト) のルート フォルダにコピーし Dblspace.bin に名前を変更します。この操作を行うには、コマンド プロンプトで次のコマンドを入力します。
      copy <drive>:\drvspace.bin c:\dblspace.bin
      ここで <drive> は、物理ブート ドライブです。

      ドライブ C が圧縮されている場合、Drvspace.bin ファイルをホスト ドライブのルート フォルダにコピーします。この操作を行うには、コマンド プロンプトで次のコマンドを入力します。
      copy <drive>:\drvspace.bin <x>:\dblspace.bin
      ここで <drive> は物理ブート ドライブで、<x> はドライブ C のホスト ドライブです。
    8. 通常の方法でコンピュータを再起動します。
    この手順によって問題を解決できない場合は、以下の手順に進みます。
  3. DriveSpace を正常に終了させるには、Emm386.exe を読み込まないようにします。この操作を行うには、以下の手順を実行します。

    1. コンピュータを再起動します。"Starting Windows 95" メッセージが表示されたところで、F8 キーを押し、[Startup Menu] で [Step-By-Step Confirmation] を選択します。

      Windows 98 では、[Windows 98 Startup Menu] が表示されるまで Ctrl キーを押し続けます。次に [Step-By-Step Confirmation] を選択します。
    2. すべての確認表示に対して Y キーを押します。ただし、EMM386 を起動するように要求された場合は N キーを押します。

詳細

既存のドライブを圧縮するときは、Windows 95 はメモリにリアル モードの圧縮ドライバを読み込む必要があります。Windows 95 が最小設定で Windows を再起動すると、Restart.drv ファイルはリアル モードの圧縮ドライバが存在するかどうかを調べます。リアル モードの圧縮ドライバが読み込まれていない場合、コンピュータはリアル モードの圧縮ドライバが読み込まれるまで再起動し続けます。リアル モードの圧縮ドライバを読み込めない場合、コンピュータは無期限に再起動を繰り返します。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 130018 (最終更新日 2001-09-20) をもとに作成したものです。

この資料に含まれているサンプル コード/プログラムは英語版を前提に書かれたものをありのままに記述しており、日本語環境での動作は確認されておりません。

プロパティ

文書番号: 130018 - 最終更新日: 2004年12月27日 - リビジョン: 3.2
この資料は以下の製品について記述したものです。
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
  • Microsoft Plus!95 Standard Edition
  • Microsoft Windows 95
  • Microsoft Windows 95
  • Microsoft Windows 95
キーワード:?
kbtool kbenv diskmem win98 kbprb win95 kbdiskmemory KB130018
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com