Help and Support
 

powered byLive Search

Windows does not save memory dump file after a crash

Article ID:130536
Last Review:October 11, 2007
Revision:6.5
This article was previously published under Q130536

SYMPTOMS

When you receive a STOP error message or a fatal system error message, a Memory.dmp file may not be created.

Note Before troubleshooting the problem, make sure that the computer is correctly configured to save a crash dump file.

CAUSE

There are several reasons why the Memory.dmp file is not being created when your computer encounters a STOP message:
The Memory.dmp file already exists and the option Overwrite Any Existing File (found in Control Panel System) is not selected. It is a good idea to leave this box checked and to move or copy the current Memory.dmp file.
The paging file on the boot drive is not large enough. To use the "Write Debugging Information To" feature to obtain a complete memory dump file, the paging file on the boot drive must be at least as large as physical memory + 1 MB. When you create a kernel memory dump file, the file is usually around one-third the size of the physical memory on the system. Of course, this quantity will vary, depending on your circumstances.
The paging file is not on the %systemroot% partition. When the STOP error occurs, the system crash dump is written out to the pagefile on the root of the %systemroot% drive.
There is not room for the Memory.dmp file in the path specified in Control Panel for writing the memory dump.
It is possible that the SCSI controller is bad or the system crash is caused by a bad SCSI controller board.
If you specify a non-existent path, a dump file will not be written. For example, if you specify the path as C:\Dumpfiles\Memory.dmp and no C:\Dumpfiles folder exists, a dump file will not be written.
Note The administrator can configure the computer to generate system event log and to send alerts to specific computers or users upon a system crash. This is a very useful feature of Windows for monitoring systems for system crashes when away from computers and when system configured for automatic reboot.

APPLIES TO
Microsoft Windows Server 2003, 64-Bit Datacenter Edition
Microsoft Windows Server 2003, Enterprise x64 Edition
Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Microsoft Windows Server 2003, Web Edition
Microsoft Windows XP Home Edition
Microsoft Windows XP Professional
Microsoft Windows XP Tablet PC Edition
Microsoft Windows 2000 Server
Microsoft Windows 2000 Advanced Server
Microsoft Windows 2000 Professional Edition
Microsoft Windows 2000 Datacenter Server
Microsoft Windows Server 2003, Standard x64 Edition
Microsoft Windows Server 2003, Datacenter x64 Edition

Back to the top

Keywords: 
kbtshoot kbprb KB130536

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.