DHCP-Enabled MS-DOS Clients Do Not Resolve Host Names

Article translations Article translations
Article ID: 130538
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

Symptoms

When you ping a host name from a Dynamic Host Configuration Protocol (DHCP) enabled LAN Manager for MS-DOS version 2.2c or Network Client for MS-DOS version 3.0 client computer, the following error message may appear:
DGN0217: Remote name cannot be resolved
NOTE: IPCONFIG returns the current configuration including the WINS server. If you ping a valid IP address, or use the NET VIEW or NET USE command, the operation is successful.

Cause

This problem occurs if the entry for the host name does not exist in the HOSTS file. LAN Manager for MS-DOS version 2.2c client and Network Client for MS-DOS version 3.0 can be WINS-enabled. When you ping a host name from a DHCP-enabled client, the order of name resolution should be as follows:

  1. Local host name
  2. HOSTS file
  3. DNS
  4. Local NetBIOS cache
  5. WINS server
  6. Broadcast
However, NMTSR.EXE, which handles ping requests, is only using the HOSTS file. It does not check the local host name. A protocol trace may reveal that nothing was sent out on the network.

Workaround

To work around this problem, enter the host names, including the local host name, in the HOSTS file.

Status

Microsoft has confirmed this to be a problem in LAN Manager for MS-DOS version 2.2c and Network Client version 3.0 for MS-DOS.

Properties

Article ID: 130538 - Last Review: June 22, 2014 - Revision: 5.0
Keywords: 
kbnosurvey kbarchive KB130538

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com