レジストリ エラーをトラブルシューティングする方法

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文書番号: 131431 - 対象製品
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重要 : この資料には、レジストリの編集に関する情報が含まれています。レジストリを編集する前に、レジストリ ファイル (System.dat と User.dat) のバックアップ コピーを必ず作成してください。これらの 2 つのファイルは、Windows フォルダにある隠しファイルです。
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目次

現象

Windows 95 を起動すると、以下のエラー メッセージのうちの 1 つを受け取ることがあります。
  • メモリ不足の為、レジストリを読み込めませんでした。
  • システム レジストリへのアクセス エラーが起きました。レジストリを復元し、コンピュータを再起動してください。

    このエラーを無視してシステムをシャットダウンすると、データが失われることがあります。

    レジストリを復元することにより、障害のあるレジストリは既知の正常なバックアップ コピーに置き換わります。しかし、このバックアップ コピーは最近システムに追加された情報をすべて含んでいるとは限りません。

    注 : [バックアップを復元して再起動] をクリックすると、Windows 95 を再起動したときにエラー メッセージを再び受け取ります。

原因

これらのエラー メッセージは、レジストリが破損している場合に発生することがあります。

解決方法

警告 : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。Windows 95 の再インストールが必要な場合もあります。Microsoft は、レジストリ エディタの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディタは、自己の責任においてご使用ください。

注 : レジストリの編集方法の詳細については、レジストリ エディタ (Regedit.exe) のオンライン ヘルプ トピック「キーと値の変更」を参照してください。レジストリを編集する前に、レジストリ ファイル (System.dat と User.dat) のバックアップ コピーを必ず作成することに注意してください。

破損したレジストリを復元するには、次の各方法 (必要に応じて) で説明されている手順を実行してください。

リアル モードのレジストリ エディタを使用する

リアル モードでレジストリ エディタを使用して、レジストリ ファイルをいったんエクスポートしてからインポートしてください。手順は次のとおりです。
  1. コンピュータを再起動します。"Starting Windows 95" メッセージが表示されたところで F8 キーを押し、[Startup Menu] で [Safe Mode Command Prompt Only] を選択します。
  2. 次の行を入力して、レジストリをエクスポートします。
    regedit /l:<path1> /e <path2>system.txt
    <path1> は System.dat ファイルへのパスです。<path2> は受け側のファイルへのパスです。たとえば、Windows 95 がドライブ C の [Windows] フォルダにインストールされている場合は、次の行を入力します。
    regedit /l:c:\windows\system.dat /e c:\system.txt
  3. 次の行を入力して、各行の後で Enter キーを押します。
    cd\windows
    attrib -s -h -r system.dat
  4. 次の行を入力して、現在のレジストリ ファイルの名前を変更します。
    ren system.dat system.old
  5. 次の行を入力して、レジストリの System.dat の部分をインポートします。
    regedit /l:<path1> /c <path2>system.txt
    <path1> は System.dat ファイルへのパスです。<path2> は、インポートするファイルを含むパスです。たとえば、Windows 95 がドライブ C の Windows フォルダにインストールされていて、System.txt ファイルをドライブ C のルート フォルダからインポートしたい場合は、次のように入力します。
    regedit /l:c:\windows\system.dat /c c:\system.txt
    注 : レジストリの System.dat の部分をインポートしようとするときに、"レジストリを開けません。" または "レジストリにアクセス中にエラーが発生しました。" というエラー メッセージが表示される場合は、次の Microsoft Knowledge Base 資料でエラー メッセージの詳細情報を参照してください。
    132064 Regedit May Not Be Able to Import Registry with Large Keys
  6. Windows 95 を通常どおり再起動します。
エラーが発生し続ける場合は、以下の手順に従ってください。
  1. コンピュータを再起動します。メッセージが表示されたら F8 キーを押し、[スタートアップ] メニューから "Safe mode command prompt only" を選択します。
  2. 次の行を入力して、レジストリの User.dat の部分をエクスポートします。
    regedit /r:<path1> /e <path2>user.txt
    <path1> は User.dat ファイルへのパスです。<path2> は受け側のファイルへのパスです。たとえば、Windows 95 がドライブ C の Windows フォルダにインストールされている場合は、次の行を入力します。
    regedit /r:c:\windows\user.dat /e c:\user.txt
  3. 次の行を入力して、各行の後で Enter キーを押します。
    cd\windows
    attrib -s -h -r user.dat
  4. 次の行を入力して、User.dat ファイルの名前を変更します。
    ren user.dat user.old
  5. 次の行を入力して、レジストリの User.dat の部分をインポートします。
    regedit /r:<path1> /c <path2>user.txt
    <path1> は User.dat ファイルへのパスです。<path2> は、インポートするファイルを含むパスです。たとえば、Windows 95 がドライブ C の Windows フォルダにインストールされていて、User.txt ファイルをドライブ C のルート フォルダからインポートしたい場合は、以下を入力します。
    regedit /r:c:\windows\user.dat /c c:\user.txt
    注 : レジストリの User.dat の部分をインポートしようとするときに、"レジストリを開けません。" または "レジストリにアクセス中にエラーが発生しました。" というエラー メッセージが表示される場合は、Microsoft Knowledge Base の以下の資料を参照してください。
    132064 Regedit May Not Be Able to Import Registry with Large Keys
  6. Windows 95 を通常どおり再起動します。
リアル モードでのレジストリ エディタの使用についての関連情報は、Microsoft Knowledge Base の以下の資料を参照してください。
131352 Using Registry Editor in Real Mode
この項の手順に従った後もエラーが発生し続ける場合は、次を参照してください。

System.da0 を使用する

レジストリを、最後に Windows 95 を正常に起動したときの状態に復元します。そうするには、以下の手順に従ってください。
  1. コンピュータを再起動します。"Starting Windows 95" メッセージが表示されたら F8 キーを押し、[スタートアップ] メニューから "Safe mode command prompt only" を選択します。
  2. 以下のコマンドを入力して、Windows フォルダに移動します。
    cd \<windows>
    <windows> は Windows 95 のフォルダです。たとえば、Windows 95 が Windows フォルダにインストールされている場合は、次の行を入力します。
    cd \windows
  3. 次の行を入力します。
    attrib -s -h -r system.dat
  4. 次の行を入力します。
    ren system.dat system.bad
  5. コンピュータを再起動します。Windows 95 は、System.dat ファイルが見つからない場合に System.da0 ファイルを使用します。このファイルが使われる場合、Windows 95 はその名前を System.dat に変更します。
この項の手順に従った後もエラーが発生し続ける場合は、次を参照してください。

System.1st を使用する

レジストリを、最初に Windows 95 を正常に起動したときの状態に復元します。手順は次のとおりです。
  1. コンピュータを再起動します。 "Starting Windows 95" メッセージが表示されたら F8 キーを押し、[スタートアップ] メニューから "Safe mode command prompt only" を選択します。
  2. 次のコマンドを入力して、Windows フォルダに移動します。
    cd \<windows>
    <windows> は Windows 95 のフォルダです。たとえば、Windows 95 が Windows フォルダにインストールされている場合は、次の行を入力します。
    cd \windows
  3. 次の行を入力します。
    attrib -s -h -r system.dat
  4. 次の行を入力します。
    ren system.dat system.xxx
  5. 次の行を入力します。
    cd \
  6. 次の行を入力します。
    attrib -s -h -r system.1st
  7. 次の行を入力します。
    copy system.1st c:\<windows>\system.dat
    <windows> は Windows 95 のフォルダです。
  8. 次の行を入力します。
    attrib +s +h +r system.1st
  9. コンピュータを再起動します。
この手順に従った後もエラーが発生し続ける場合は、次を参照してください。

注 : 上記の手順に従った後で、フォント フォルダまたはプログラムに TrueType フォントがないことに気づく場合があります。この場合は、Microsoft Knowledge Base の次の資料にリストされている解決方法を使用してください。
133732 Missing TrueType Fonts in Fonts Folder or Programs

Windows 95 を再インストールする

Windows 95 を再インストールして、レジストリ ファイルを再作成してください。

これを行うには、次の手順を実行してください。

注 : コマンド プロンプトから CD-ROM ドライブにアクセスできない場合は、CD-ROM ドライブのドキュメントを調べるか、または CD-ROM ドライブのリアル モード ドライバのロードについて、製造元に問い合わせてください。
  1. コンピュータを再起動します。 "Starting Windows 95" メッセージが表示されたら F8 キーを押し、[スタートアップ] メニューから "Command Prompt Only" を選択します。
  2. 次のコマンドを入力し、Enter キーを押してすべてのユーザー プロファイルを削除します。
    ren c:\windows\profiles c:\windows\oldprofiles
  3. 次の行を入力して、既存のレジストリ ファイルの名前を変更します。各行の後で Enter キーを押します。
    cd \windows
    attrib -s -h -r system.dat
    ren system.dat system.xxx
    attrib -s -h -r user.dat
    ren user.dat user.xxx
    attrib -s -h -r system.da0
    ren system.da0 system.yyy
    attrib -s -h -r user.da0
    ren user.da0 user.yyy
    cd \
    attrib -s -h -r system.1st
    ren system.1st system.zzz
  4. Windows 95 セットアップを実行します。
バックアップを復元した後、または System.1st を使用してレジストリを置き換えた後で、プログラム (特にレジストリに書き込むプログラム) を再インストールしなければならない場合があることに注意してください。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 131431 (最終更新日 2000-01-20) をもとに作成したものです。

プロパティ

文書番号: 131431 - 最終更新日: 2001年4月3日 - リビジョン: 1.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows 95
キーワード:?
kbenv kberrmsg kbfaq kbinfo kbtshoot win95 KB131431
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