Messaggio di errore: Impossibile trovare un file di periferica necessario per eseguire Windows

Traduzione articoli Traduzione articoli
Identificativo articolo: 132008 - Visualizza i prodotti a cui si riferisce l?articolo.
Questo articolo è stato precedentemente pubblicato con il codice di riferimento I132008


IMPORTANTE: in questo articolo sono contenute informazioni su come modificare il Registro di sistema. Prima di modificare il Registro di sistema, assicurarsi tuttavia di sapere come ripristinarlo in caso di problemi. Per informazioni su come eseguire questa operazione, vedere l'argomento della Guida relativo al ripristino del Registro di sistema in Regedit.exe oppure l'argomento relativo al ripristino di una chiave del Registro di sistema in Regedt32.exe.
Espandi tutto | Chiudi tutto

Sintomi

Quando si avvia Windows, è possibile che venga visualizzato il seguente messaggio di errore:

Impossibile trovare un file di periferica necessario per eseguire Windows o un'applicazione di Windows.

Il file del Registro di configurazione di Windows o il file SYSTEM.INI richiede tale file, ma esso non è più presente.

Se il file è stato eliminato, provare a disinstallare l'applicazione associata.

Se si desidera continuare a usare tale applicazione, installarla nuovamente per ripristinare il file mancante.

<nomefile>.vxd

NOTA: il file specifico potrebbe non essere indicato.

Cause

Questo messaggio di errore potrebbe essere visualizzato per uno dei seguenti motivi:
  • Un driver di periferica virtuale (VxD) di Windows a cui si fa riferimento nel file System.ini o nel Registro di configurazione è mancante o danneggiato.
  • Uno dei valori StaticVxD presenti nel Registro di configurazione contiene dati non validi. Il valore potrebbe ad esempio essere vuoto o contenere soltanto spazi. In questo caso il driver di periferica mancante non è indicato nel messaggio di errore.

Risoluzione

ATTENZIONE: l'errato utilizzo dell'Editor del Registro di sistema può causare seri problemi che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che i problemi derivanti dall'errato utilizzo dell'Editor del Registro di sistema possano essere risolti. L'utilizzo dell'Editor del Registro di sistema è a rischio e pericolo dell'utente.

Per informazioni su come modificare il Registro di sistema, vedere l'argomento della Guida "Modifica di chiavi e valori" nell'Editor del Registro di sistema (Regedit.exe) oppure gli argomenti relativi ad aggiunta, modifica o eliminazione di dati nel Registro di sistema in Regedt32.exe. Si raccomanda di eseguire una copia di backup del Registro di sistema prima di modificarlo.

Per risolvere il problema, seguire le procedure indicate di seguito finché l'errore non si verifica più:
  1. Se di recente sono stati rimossi programmi o componenti, provare a reinstallarli quindi eseguire lo strumento di disinstallazione, se disponibile. Se per il programma o componente non è disponibile uno strumento di disinstallazione, rivolgersi al produttore per istruzioni sulla disinstallazione.
  2. Se il driver di periferica mancante ha estensione 386, disattivare la riga che si riferisce ad esso nel file System.ini inserendo un punto e virgola (;) all'inizio della riga. Se la riga che fa riferimento al driver di periferica mancante è la seguente
          device=Example.386
    
    modificarla come segue
          ;device=Example.386
    
  3. Se il driver di periferica mancante ha estensione vxd, si tratta di un driver progettato per l'utilizzo con Windows 95 o Windows 98 e nel Registro di configurazione esiste un riferimento ad esso. Nella maggior parte dei casi un programma o componente con driver progettati per l'utilizzo con Windows 95 o Windows 98 risulterà elencato anche nello strumento Installazione applicazioni del Pannello di controllo. Seguendo le istruzioni riportate al punto 1 il problema dovrebbe risolversi.

    Per Windows 98

    Se il messaggio di errore continua a essere visualizzato dopo avere svolto le procedure descritte al punto 1 oppure se non è pertinente, utilizzare Controllo file di sistema per estrarre il file mancante dal CD di Windows 98 come segue:

    1. Fare clic sul pulsante Start, scegliere Programmi, Accessori, Utilità di sistema e infine Microsoft System Information.
    2. Scegliere Controllo file di sistema dal menu Strumenti.
    3. Scegliere il pulsante di opzione Estrarre un file dal disco di installazione, immettere il nome del file da estrarre nella casella File da estrarre e scegliere il pulsante Avvia.
    4. Nella casella Ripristina da digitare il percorso della cartella Win98 nel CD di Windows 98. Se necessario immettere la cartella di destinazione nella casella Salva il file, quindi scegliere OK.
    5. Scegliere OK, quindi scegliere di nuovo OK e fare clic su quando viene chiesto di riavviare il computer.

    Per Windows 95

    Utilizzare la seguente sintassi per estrarre il file da un file cab noto:
    extract <CAB> <nomefile> /l <destinazione>
    Per estrarre ad esempio il file Unidrv.dll di Windows 95 dal file Win95_10.cab contenuto in un disco inserito nell'unità A nella cartella Windows\System dell'unità C, utilizzare il seguente comando:
    extract a:\win95_10.cab unidrv.dll /l c:\windows\system
    Per ulteriori informazioni sull'estrazione di file, vedere il seguente articolo della Knowledge Base (gli articoli con prefisso "Q" contengono informazioni in inglese):
    ID ARTICOLO: 129605
    Come estrarre file di Windows originali compressi
  4. Se nel messaggio di errore non è indicato un driver di periferica specifico, uno dei valori StaticVxD nel Registro di configurazione è vuoto o contiene soltanto spazi. I valori StaticVxD si trovano nella seguente chiave del Registro di configurazione:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD


    Utilizzare l'editor del Registro di configurazione per individuare ed eliminare il valore StaticVxD contenente dati non validi, vuoto o con soli spazi.

Informazioni

All'avvio di Windows vengono letti il file System.ini e il Registro di configurazione per ottenere un elenco di driver di periferiche da caricare. Quando non è possibile individuare il driver di periferica che sta tentando il caricamento, viene generato un messaggio di errore.

I driver di periferica virtuali sono file necessari per vari programmi per comunicare con l'hardware del computer.

La seguente chiave di Registro d'esempio contiene un valore StaticVxD:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\COMBUFF


I dati del valore StaticVxD sono "*COMBUFF" (senza virgolette; le virgolette sono presenti nell'editor del Registro di configurazione ma non fanno parte del nome del VxD). L'asterisco (*) che precede il nome del VxD indica che è interno al file Vmm32.vxd. Se il VxD a cui fa riferimento il valore StaticVxD non è interno al file Vmm32.vxd, il suo nome non è preceduto da un asterisco e di solito ha estensione vxd.

Proprietà

Identificativo articolo: 132008 - Ultima modifica: mercoledì 29 dicembre 2004 - Revisione: 1.2
Le informazioni in questo articolo si applicano a
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 95
Chiavi: 
kberrmsg kbenv win98se win98 kbprb kbfaq win95 KB132008
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com