오류 메시지: Cannot Find a Device File That May Be Needed to Run Windows

기술 자료 번역 기술 자료 번역
기술 자료: 132008 - 이 문서가 적용되는 제품 보기.
이 문서는 이전에 다음 ID로 출판되었음: KR132008


중요: 이 문서에서는 레지스트리 편집 방법을 설명합니다. 레지스트리를 편집하려면 문제가 발생한 경우 복원하는 방법을 알고 있어야 합니다. 복원 방법에 대한 자세한 내용은 Regedit.exe의 "레지스트리 복원" 도움말 항목 또는 Regedt32.exe의 "레지스트리 키 복원" 도움말 항목을 참조하십시오.
모두 확대 | 모두 축소

현상

Windows를 시작할 때 다음 오류 메시지 중 하나가 나타날 수 있습니다.

Cannot find a device file that may be needed to run Windows or a Windows application.

The Windows registry or SYSTEM.INI file refers to this device file, but the device file no longer exists.

If you deleted this file on purpose, try uninstalling the associated application using its uninstall program or setup program.

If you still want to use the application associated with this device file, try reinstalling that application to replace the missing file.

<filename>.vxd

참고: 특정 파일의 이름이 나타나지 않을 수도 있습니다.

원인

다음과 같은 이유로 인해 이러한 오류 메시지가 나타날 수 있습니다.
  • System.ini 파일이나 레지스트리에서 참조하는 가상 장치 드라이버(VxD)가 없거나 손상되었습니다.
  • 레지스트리의 StaticVxD 값 중 하나에 잘못된 데이터가 들어 있습니다. 예를 들어, 값이 없거나 공백만 있습니다. 이러한 경우에는 손실된 장치 드라이버의 이름이 오류 메시지에 나타나지 않습니다.

해결 방법

경고: 레지스트리 편집기를 잘못 사용하면 심각한 문제가 발생할 수 있으며 문제를 해결하기 위해 운영 체제를 다시 설치해야 할 수도 있습니다. Microsoft는 레지스트리 편집기를 잘못 사용하여 발생하는 문제에 대한 해결을 보증하지 않습니다. 레지스트리 편집기의 사용에 따른 모든 책임은 사용자에게 있습니다.

레지스트리 편집 방법에 대한 자세한 내용은 레지스트리 편집기(Regedit.exe)의 "키 또는 값 변경" 도움말 항목이나 Regedt32.exe의 "레지스트리 정보 추가와 삭제"와 "레지스트리 정보 편집" 도움말 항목을 참조하십시오. 레지스트리를 편집하기 전에 먼저 백업해야 합니다.

이 문제를 해결하려면 오류가 더 이상 발생하지 않을 때까지 아래의 각 단계를 수행하십시오.
  1. 최근에 프로그램이나 구성 요소를 제거한 경우에는 해당 프로그램이나 구성 요소를 다시 설치한 다음 해당 제거 도구를 사용하여 제거합니다. 프로그램이나 구성 요소에 해당하는 제거 도구를 사용할 수 없는 경우 제조업체에 문의하여 제거 지침을 구하십시오.
  2. 손실된 장치 드라이버의 확장명이 .386이라면 System.ini 파일에서 이 장치 드라이버를 참조하는 행의 맨 앞에 세미콜론(;)을 입력하여 해당 행을 사용 불가능하게 합니다. 예를 들어, 손실된 장치 드라이버를 참조하는 행의 내용이 다음과 같은 경우
          device=Example.386
     
    다음과 같이 변경하십시오.
          ;device=Example.386
     
  3. 손실된 장치 드라이버의 확장명이 .vxd라면 그 드라이버는 Windows 95나 Windows 98용으로 사용되고 레지스트리에서 참조되도록 설계된 드라이버입니다. 대부분의 경우 해당 드라이버가 Windows 95나 Windows 98에서 사용되도록 설계된 프로그램이나 구성 요소라면 제어판프로그램 추가/제거에도 나타납니다. 1단계의 지침을 수행하면 문제가 해결됩니다.

    Windows 98의 경우

    1단계의 지침을 수행한 후에도 여전히 오류 메시지가 나타나거나 지침이 적용되지 않는 경우에는 시스템 파일 검사기를 사용하여 다음과 같이 Windows 98 CD-ROM에서 손실된 파일을 추출하십시오.

    1. 시작을 누르고, 프로그램, 보조 프로그램, 시스템 도구를 차례로 가리킨 다음 시스템 정보를 누릅니다.
    2. 도구 메뉴에서 시스템 파일 검사기를 누릅니다.
    3. 설치 디스크에서 한 파일의 압축 해제를 누르고 복원할 시스템 파일을 선택하십시오 상자에 추출할 파일의 이름을 입력한 다음 시작을 누릅니다.
    4. 복원할 원본 위치 상자에서 Windows 98 CD-ROM에 있는 Win98 폴더의 경로를 입력합니다. 필요한 경우 저장할 파일 위치 상자에 대상 폴더를 입력한 다음 확인을 누릅니다.
    5. 확인을 누르고, 다시 확인을 누른 다음 컴퓨터를 다시 시작할 것인지 묻는 메시지가 나타나면 를 누릅니다.

    Windows 95

    다음 구문을 사용하여 알고 있는 캐비넷 파일에서 파일을 추출하십시오.
    extract <cabinet> <filename> /l <destination>
    예를 들어 드라이브 A의 디스크에 있는 Win95_10.cab 파일에서 드라이브 C의 Windows\System 폴더로 Windows 95 Unidrv.dll 파일을 추출하려면 다음 명령을 사용하십시오.
    extract a:\win95_10.cab unidrv.dll /l c:\windows\system
    파일을 추출하는 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
    문서 번호: 129605
    제목: How to Extract Original Compressed Windows Files
  4. 오류 메시지에 특정 장치 드라이버의 이름이 나타나지 않으면 레지스트리에 있는 StaticVxD 값 중 하나가 없거나 공백만 들어 있습니다. StaticVxD 값은 레지스트리 키에서 다음 키 아래에 있습니다.

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD


    레지스트리 편집기를 사용하여 레지스트리에서 잘못된 데이터를 포함하고 있거나, 값이 없거나, 공백만을 포함하고 있는 StaticVxD 값을 찾아서 모두 삭제합니다.

추가 정보

Windows가 시작되면 System.ini 파일과 레지스트리를 읽어서 로드할 장치 드라이버의 목록을 얻습니다. Windows가 로드할 가상 장치 드라이버를 찾을 수 없으면 오류 메시지가 나타납니다.

가상 장치 드라이버는 여러 프로그램이 컴퓨터의 하드웨어와 통신하는데 필요한 파일을 말합니다.

StaticVxD 값을 포함하고 있는 예제 레지스트리 키는 다음과 같습니다.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\COMBUFF


이 StaticVxD 값에 대한 데이터는 "*COMBUFF"(인용 부호는 제외, 레지스트리 편집기에서도 인용 부호가 나타나 있지만 VxD 이름에 속하지 않음)입니다. 이름 앞에 별표(*)가 있는 VxD는 Vmm32.vxd 파일의 내부 드라이버입니다. StaticVxD 값이 참조하는 VxD가 Vmm32.vxd 파일의 내부 드라이버가 아니라면 그 이름 앞에 별표가 없으며 대개는 확장명이 .vxd입니다.

속성

기술 자료: 132008 - 마지막 검토: 2004년 12월 30일 목요일 - 수정: 1.1
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 95
키워드:?
kberrmsg kbenv win98se win98 kbprb kbfaq win95 KB132008

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com