エラー メッセージ : Windows または Windows アプリケーションを実行するのに必要なデバイス ファイルが見つかりません。

文書翻訳 文書翻訳
文書番号: 132008 - 対象製品
この記事は、以前は次の ID で公開されていました: JP132008


重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずシステムの復元方法を理解しておいてください。復元方法の詳細については、Regedit.exe のヘルプの「レジストリを復元する」、または Regedt32.exe のヘルプの「レジストリ キーを復元する」を参照してください。
すべて展開する | すべて折りたたむ

現象

Windows を起動すると、次のエラー メッセージが表示される場合があります 。

Windows または Windows アプリケーションを実行するのに必要なデバイス ファイルが見つかりません。

レジストリや SYSTEM.INI ファイルがこのデバイス ファイルを参照していますが、このデバイス ファイルは存在しません。

意図的にこのファイルを削除した場合は、このファイルを必要とするアプリケーションを、付属のアンインストールまたはセットアップ プログラムを使ってアンインストールしてください。

このファイルを必要とするアプリケーションを今後も使用する場合は、アプリケーションをもう一度インストールして、足りないファイルを復元してください。

<filename>.vxd

注 : 示されるファイルに名前が表示されないこともあります。

原因

以下のいずれかの理由により、このエラー メッセージが表示されることがあります。
  • System.ini ファイルまたはレジストリで参照されている Windows 仮想デバイス ドライバ (VxD) が見つからないか、壊れています。
  • レジストリの StaticVxD 値の 1 つが無効なデータを含んでいます。たとえば、値が空白か、スペースだけを含んでいます。この場合、エラー メッセージに見つからないデバイス ドライバのファイル名が表示されません。

解決方法

警告 : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリ エディタの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディタは、自己の責任においてご使用ください。

レジストリの編集方法の詳細については、Regedit.exe のヘルプの「キーと値の変更」または「キーと値を変更する」を参照してください。または Regedt32.exe のヘルプの「レジストリ情報の追加と削除」または「レジストリの情報を追加または削除する」、および「レジストリ情報の編集」または「レジストリ情報を編集する」を参照してください。レジストリの編集を行う前に、必ずレジストリのバックアップをとってください。

この問題を解決するには、エラーが発生しなくなるまで以下の手順を実行します。
  1. 最近プログラムやコンポーネントを削除した場合は、そのプログラムやコンポーネントを再インストールし、利用できる場合はアンインストール ツールを実行します。そのプログラムやコンポーネントのアンインストール ツールを利用できない場合は、製造元に連絡して、アンインストールの指示を入手します。
  2. 見つからないデバイス ドライバの拡張子が .386 の場合は、System.ini ファイルでこのデバイス ドライバを参照している行の先頭にセミコロン (;) を追加し、その行を無効にします。たとえば、見つからないデバイス ドライバを参照している行が次のようになっている場合、
          device=Example.386
     
    
    この行を次のように変更します。
          ;device=Example.386
     
    
  3. 見つからないデバイス ドライバの拡張子が .vxd の場合は、このドライバは Windows 95 または Windows 98 で使用するようにデザインされており、レジストリで参照されています。多くの場合、Windows 95 または Windows 98 で使用するようにデザインされているドライバを使うプログラムやコンポーネントは、コントロール パネルの [アプリケーションの追加と削除] にも一覧されます。問題を解決するには、手順 1. の指示に従う必要があります。

    Windows 98 の場合

    手順 1. の指示に従った後も依然としてエラー メッセージが表示される場合、または手順 1. の指示を適用できない場合は、以下のようにシステム ファイル チェッカーを使用して Windows 98 CD-ROM から見つからないファイルを抽出します。

    1. [スタート] ボタンをクリックし、[プログラム]、[アクセサリ]、[システム ツール] の順にポイントして、[システム情報] をクリックします。
    2. [ツール] メニューの [システム ファイル チェッカー] をクリックします。
    3. [インストール ディスクからファイルを 1 つ抽出する] をクリックし、[修復したいシステム ファイルを指定してください] ボックスに抽出するファイルの名前を入力して、[開始] をクリックします。
    4. [復元元] ボックスに Windows 98 CD-ROM の Win98 フォルダのパスを入力します。必要に応じて [ファイルの保存先] ボックスにファイルの保存先を入力し、[OK] をクリックします。
    5. [OK] を 2 回クリックし、コンピュータの再起動を要求するメッセージが表示されたら [はい] をクリックします。

    Windows 95 の場合

    以下の構文を使用して、既知のキャビネット ファイルからファイルを抽出します。
    extract <cabinet> <filename> /l <destination>
    たとえば、ドライブ A のディスク上の Win95_10.cab ファイルからドライブ C の Windows\System フォルダに Windows 95 の Unidrv.dll ファイルを抽出するには、次のコマンドを使用します。
    extract a:\win95_10.cab unidrv.dll /l c:\windows\system
    ファイルの抽出方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
    文書番号 : 129605
    タイトル : How to Extract Original Compressed Windows Files
  4. エラー メッセージにデバイス ドライバの名前が表示されない場合、おそらくレジストリの StaticVxD 値の 1 つが空白か、スペース文字だけを含んでいます。StaticVxD 値は以下のキーの下のレジストリ キーに配置されています。

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD


    レジストリ エディタを使用して、レジストリ内で無効な値、つまり空白またはスペース文字だけを含む値を検索し、削除します。

詳細

Windows を起動するときに、System.ini ファイルおよびレジストリを読み取り、読み込むデバイス ドライバのリストを取得します。Windows が読み込もうとしている仮想デバイス ドライバを検索できないと、エラー メッセージが生成されます。

仮想デバイス ドライバは、さまざまなプログラムがコンピュータのハードウェアと通信するために必要なファイルです。

以下のサンプル レジストリ キーが StaticVxD 値を保持しています。

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\COMBUFF


この StaticVxD 値のデータは "*COMBUFF" (二重引用符は含みません。レジストリ エディタでは二重引用符が表示されますが、VxD 名の一部ではありません) です。VxD 名の前のアスタリスク (*) は、VxD が Vmm32.vxd ファイルに対して内部的であることを示します。StaticVxD 値が参照する VxD が Vmm32.vxd ファイルに対して内部的でない場合は、名前の前にアスタリスクが付かず、一般的には拡張子 .vxd が付きます。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 132008 (最終更新日 2001-11-23) をもとに作成したものです。

この資料に含まれているサンプル コード/プログラムは英語版を前提に書かれたものをありのままに記述しており、日本語環境での動作は確認されておりません。

プロパティ

文書番号: 132008 - 最終更新日: 2004年12月27日 - リビジョン: 1.1
この資料は以下の製品について記述したものです。
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 95
キーワード:?
kberrmsg kbenv win98se win98 kbprb kbfaq win95 KB132008
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com