REGEDIT pode não conseguir importar o registro com chaves grandes

Traduções deste artigo Traduções deste artigo
ID do artigo: 132064 - Exibir os produtos aos quais esse artigo se aplica.
Importante: Este artigo contém informações sobre a edição do Registro. Antes de editar o registro, verifique se que você sabe como restaurá-lo se ocorrer um problema. Para obter informações sobre como fazer isso, consulte o tópico da Ajuda "Restaurando o registro" no Regedit.exe ou o tópico da Ajuda "Restaurando uma chave do Registro" no Regedt32.exe.
Expandir tudo | Recolher tudo

Sintomas

Quando você tenta importar registro usando o Editor do Registro (Regedit.exe) em modo real, você pode receber uma das seguintes mensagens de erro:
  • Não é possível abrir registro (14) - System.dat
  • Erro ao acessar o registro: O arquivo pode não estar completo.

Causa

O stub de modo real do Regedit.exe tem a capacidade para exportar, importar e criar arquivos do Registro. Regedit.exe usa a biblioteca interno do registro de modo real para realizar essas tarefas. O código de modo real nesta biblioteca tem alguns problemas com arquivos do Registro grande.

Por exemplo, se houver muitos aplicativos instalados, HKEY_CLASSES_ROOT pode ser muito grandes. Se uma das estruturas no arquivo System.dat ocupa muito espaço na memória convencional, o registro não pode ser acessado.

Resolução

Aviso: Usar o Editor do Registro incorretamente pode causar problemas sérios que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que problemas resultantes do uso incorreto do Editor do Registro possam ser resolvidos. Use o Editor do registro por sua própria conta e risco.

Para obter informações sobre como editar o registro, consulte o tópico da Ajuda "Alterando chaves e valores" no Editor do Registro (Regedit.exe) ou tópicos de Ajuda "Adicionar e excluir informações no Registro" e "Editar dados de registro" no Regedt32.exe. Observe que você deve fazer backup do registro antes de editá-lo.

Para contornar esse problema, use o Editor do registro no modo protegido.

Para obter informações sobre como importar o registro, consulte o tópico da Ajuda "Importando o registro" no Editor do Registro (Regedit.exe).

Situação

A Microsoft confirmou este é um problema no Windows 95. Estamos estiver pesquisando esse problema e divulgaremos novas informações na Base de dados de Conhecimento da Microsoft como ele se torna disponível.

Propriedades

ID do artigo: 132064 - Última revisão: quarta-feira, 15 de novembro de 2006 - Revisão: 1.1
A informação contida neste artigo aplica-se a:
  • Microsoft Windows 95
Palavras-chave: 
kbmt kberrmsg kbusage KB132064 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 132064
Aviso de Isenção de Responsabilidade sobre Conteúdo do KB Aposentado
Este artigo trata de produtos para os quais a Microsoft não mais oferece suporte. Por esta razão, este artigo é oferecido "como está" e não será mais atualizado.

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com